English

FP2 Bricked - Recovery Help

Try this first:
Installing stock Android + recovery: You can just install the stock Android (no other recovery needed) using the stock build images (they contain recovery.img*, boot and system) using fastboot flashall.

If all that works, you can try the TWRP:
TWRP-recovery: Can you ask @Moritz | @Max_S (!) for a link (23 days old! Don’t use this one, maybe there is a better one out there!) to his latest recovery?

Hey there,
the link is not by me, but by @Max_S. He ported the TWRP recovery and as far as I know it’s the latest version. I flashed it just 4 days agp and it worked fine on my FP2, so if there is no valid recovery on the phone at the moment, I would second @fp1_wo_sw_updates’s suggestion on putting one there. I believe I mentioned that earlier in this threat somewhere already :slight_smile:
I believe, the ota does not include the recovery, so probably flashing the TWRP and then using it to flash the ota stock system is the best way to go…
Good luck and keep us posted! :slight_smile:

1 Like

Hi, and many thanks for the Help here.
If I wold get the .img files - whats the order to flash my phone?
Do i start with the recovery.img or wit the boot.img and what all do i need to flash. Whats required?

Normally fastboot flashall takes care of all that if the files are around and as long as the phone is in fastboot mode and “reachable”.

Well, I don’t think that the order is that important (but I’m not entirely sure). I’d try

$ fastboot flash boot boot.img
$ fastboot flash recovery <insert name of TWRP recovery image here>
$ fastboot flash system system.img

If that doesn’t work, replace the last command by

$ fastboot -w flash system system.img

or even flash more images as some people have tried with self-compiled versions:

Edit: @fp1_wo_sw_updates If that’s possible, nice! Though I thought fastboot flashall only works if you have a build environment which was set up properly (with android-info.txt present and so that flashall knows which device to flash etc.).

2 Likes

That file:

[quote=“tphysm, post:46, topic:12032”]
android-info.txt
[/quote] i am missing. Does somebody have me an example of that?

I’m still not sure whether flashall will work even if you have that file. Note though, that if you flash the images one by one, you don’t need that file.

Anyway, in my out-directory, the file in question only consists of one line:

board=FP2

Mine just contains:

board=FP2

Just a quick terminology question: If you can’t get to recovery mode to perform a hard reset then the phone is not soft bricked but hard bricked right? So do you guys agree to change the title?

Usually I would agree, but in this case apparently fastboot mode is still working, which might enable the user to still recover his phone (by flashing a new recovery and then doing al the rest…). So I would still say it’s softbricked as oppoed to hardbricked, where there is no option left for the user but to send in the device.
But that’s just my take on things :slight_smile:

Well, as far as i can tell im able to enter fastboot because i can get the device nr. by typing fastboot devices and it prints “234F6a0” (what ever that means)

And i realy hope i don’t have to send it back :sob:

On the other side, what @paulakreuzer says makes sense, because the only two modes where i see something on the screen is the standard fastboot “FAIRPHONE” - Logo with at the bottom “powered by android” and the Charging Battery animation when plugged to a USB power supply.

On XDA there is a guide for recovering a hardbricked FP1 and I guess it works similiarly to fastboot recovering FP2. (But I don’t really understand most of it, so you be the judge of it.)

http://forum.xda-developers.com/wiki/Fairphone_Fairphone/Guides#Bricked_your_Fairphone.3F

1 Like

Ha. That’s true… ok, then maybe we should change it to something broader. Maybe just “bricked”? That would definitely include all the possible modes :slight_smile: If people come here regularly we could also make it a wiki. Or start a new wiki with some simple steps for people who’s phones won’t turn on anymore…

1 Like

yes i already read that, but the needed binaries aren’t available it seams…
there is a link to the FP1 binaries, but im shure that i can’t use those because the Hardware is total different.
I woldn’t change the topic because the top of the thread is really about softbricked phones…
Regards, Novski

Why would you want to use any binaries? Are you still planning on flashing your self-built os? I would rather recover your phone with the stock rom to be sure everything works fine again, before you go on and experiment any further…
Did you succeed in restoring the recovery? What’s your current status?

I just whanted to reply and thaught i need to try the commands i executed yesterday without results because i didn’t remember the exact terms. So i tried all again and alredy whanted to post as the executed sudo fastboot reboot showed a blue Fairphone logo!!!
Its like magic. A programmer once tells me that’s called the teddy-bear test. Once you reproduce to explane to somebody it works for shure…

(just to state what i whanted to write:)
I tried all. nothing works.
I flashed with
sudo fastboot flash -w boot boot.img
sudo fastboot flash -w recovery recovery.img
sudo fastboot flash -w system system.img
sudo fastboot reboot

Il try to insert a SIM and get a testcall done…
will report more later.
Thanks a lot, i just felt a relief falling from my chest heavy as Fair traded cobalt. :blush:

edit: yes, works as fresh unpacked, without google of corse…

2 Likes

Good to hear that. So you now have FP OSOS on your phone and it works? That’s good news :slight_smile:

Yes seamed to work now.
Im surprised that the privacy impact and sideswipe is within it…

1 Like

I would like start writing a “unbrick howto” for fastboot, recovery, and maybe even worst cases. But as long as there is no full recovery ROM (stock android or Google FP OS) or other recovery software publicly available this doesn’t make any sense for now.

This may be a stupid question, but what exactly is the ota? Is a full system image or only a patch?

I installed the FP OSOS on my phone to try it out. I was hoping I could go back to the original system with the ota. My current status is that I have the OSOS on the phone, and it works. I can boot the phone, reach the recovery and fastboot mode. The recovery screen shows the system as my self-compiled OSOS version.

I tried fastboot flashall from the directory of the unpacked ota zip file. This flashed some files and the phone rebooted, but the OS is still the same (recovery shows the OSOS system and there are no google apps). I also tried a factory reset, but that had the same effect (it just cleared the user data). Is there a way I can get back to the original system installation?