FP2 Battery Problems (drains quickly, CPU gets hot) - See batteryguide for workarounds

Hmmm … perhaps my wording was not accurate … I meant you have to pay the 5 EUR/month additionally to your existing plan if you want to make it LTE-capable. Edited.

My contract only allows 3G and the FP2 was trying to use 4G. At the time I had two SIMs only capable of 3G and both were set to 4G (default). So the networks rejected the cards. Both of my providers offer 4G contracts now (as described by @AnotherElk) but that would cost me twice the fee I pay now and is pretty useless for me because sometimes I even only have EDGE speed in the region I live. :cry:

It is not possible to have both sim cards set to 3/4G.
You have to choose. You can’t set your second sim to 3/4G if you already have set your first sim to 3/4G. You have no other option then to set your second sim to 2G.
If you want your second sim to have 3/4G then you have to set your first sim to 2G before you can set the second sim to 3/4G.

1 Like

I’d like to share my experience with a quickly draining battery and a solution I found. Maybe others can make use of it:

I’m using a chromecast in my home network to stream media. It has a setting where not only the device streaming something can control the media playing, but also all other devices in the network.
This caused my FP2 to stay connected to the wifi and constantly keeping the phone active. According to BetterBtteryStats it never went to deep sleep, even if nothing was actually being streamed.

The solution:

  • First, I deactivated this “feature” on the chromecast using the Google Home app, since it is a setting on the chromecast device itself.
  • Second, I set my FP2 to not control streaming-media via a notification. (switch off Settings > Google > Streaming media control (or similar))

Since this, my phone goes to deep sleep as it should and battery life is back to normal.

3 Likes

It would be a huge usability improvement if we could select 3G/4G and then got a warning prompt asking:

Warning! Choosing 3G/4G for this SIM card will requires setting the other back to 2G. Continue?

One thing that was initially confusing for me was that I could not select 4G even when I had the other SIM card comletely disabled.

1 Like

I guess although you had disabled your sim card, the sim slot was still on 4G and thus blocking the 4G setting on the other sim slot.
When changing the 4G from one sim slot to the other you first have to put onesim slot on 2G.

2 Likes

Yep, that’s what I discovered at the end of my holidays, after paying for a month of 4G :frowning:

I honestly find it really strange that I cannot change the setting for the disabled sim-card either. I had to re-enable it first. Is 2G/3G/4G something set inside the chip of the sim-card or something?

No, it is the configuration of the phone’s radio which allows only one 4G connection. The UI is just a bit complicated (it was probably written by Google to deal with a variety of different phones - so on any phone it’ll work but on some the UI makes more sense than on others).

3 Likes

I had similar battery issues, recalibrating the proximity sensor as suggested here: Screen stops working during phone calls since new update fixed the problem for me.

Has anyone else noticed that updating anything through the Google Play store just eats up battery like crazy? In my case trying to update anything without the phone being on a charger results in the phone quickly running out of battery.

It also seems to be an update specific issue - installing is less affected. Did they turn on File-by-File patching by default or something?

I cannot confirm this. I´ve done several updates (>10+) the last few days mainly using the mobile network but could not see any difference in performance or power consumption.
Looks like this is a device specific issue.
Google play store app also has a cache. Maybe clear this in first instance.

1 Like

4 posts were split to a new topic: My friend bought an FP2 and I’m not happy with it

I cleared the cache. It seems to have sped up Google Play somehow (so still a useful tip), but didn’t resolve the issue. I’ll stick to updating only when on the charger for now

Maybe run another short test. Are you using your home WiFi for updates? Is Bluetooth enabled also?

If so disable Bluetooth and check the Playstore performance again.

Just recently I had Bluetooth enabled and my Fritzbox had auto-switched to another WiFi channel which interfered with Bluetooth causing a very poor performance while updating.

I never have Bluetooth enabled, so that can’t be it. Also, upon closer inspection it’s very visibly the unpacking and installing that is energy draining.

Could it be that I have an energy-draining SD card somehow?

I have not heard of such an effect yet.
But I once had a Kingston sd card which showed a permanent performance loss after some time. I could not figure out for what reason. Re-formating and even re-partitioning did not help. So its performance now is noticeable lower than it was initially.

But since you have the sd card in focus maybe try installations without it on internal memory to see if there is any difference.

Of course this is easier if used as external memory not as internal. Maybe it has defective sectors.

I’ve a relatively new Fairphone 2, which I’ve equipped with Fairphone Open, Xprivacy and AFWall+ (these are the relevant apps, I think).

The battery really drains fast and the phone is getting hot for no reason – I even cannot carry it in my Jeans pocket any more (Not because it is too hot for my skin, but too warm to be comfortable)!

Yesterday, I was browsing this forum, and it sucked up the entire battery in about an hour.

This is a screenshot I took a few minutes ago:

95% “Sonstiges”!!! I’ve read something about this yesterday, but unfortunately I got so frustrated that I cannot remember which thread I’ve already read and which I didn’t. :frowning:

I’ve tried “another monitor”, and it shows the CPU being used >60%.

Is there any kind of guide one can follow to get rid of this seemingly common problem?

I really feel for you. WLan can really suck on the battery; yet your experience is not normal.
Your first stop for advice should be the #batteryguide.
Maybe you got some app running, that is draining the battery? The regula Facebook app is renown for all kinds of bad effects. Or maybe your phone is infested by a malware, that is mining crypto currency in the background?
The guide should really help you, unless you got a broken battery of course.

Well, that should be visible, as the ones you read are listed in a light grey script in the “latest threads” list, while the unread/new ones are in black.

:slight_smile:

Today I had it in flight mode, it stayed hot and kept draining the battery.

The battery isn’t bloated, I’ve already tried the battery reset (twice), and I’ve tried it without SIM and SD card. Better battery stats is installed, but I do not know how to read what it is telling me!?

Pfuideifi, I do not have any Facebook at my device! :wink: But indeed I suspect that maybe XPrivacy/AFWall+ is blocking anything that is running wild because of that. But how could I determine that? The battery graph keeps saying, it was no specific app, and the CPU monitor doesn’t see anything using that much CPU.

I do not think so. The phone is very newly installed, i am blocking scripts in my Fennec (NoScript) and that kind of computer scientist that thinks octuply before installing anything.

Unfortunately I was browsing the forum with my phone, thus in a private tab without logging in. Sigh.

1 Like

That really makes me suspect an app as cause for the problem.

:grinning: I share your feelings. In fact, no Facebook and the like at all,

When my phone turned hot (has not done so since long now), I turned it off and started it anew. Sometimes up to three times. Then the behaviour was always back to normal.

I suspected the alarm clock, as I had programmed lots of alarms, that I activated to requirements and when I rebooted the phone, once in a while lots of “missed” alarms miraculously appeared at startup. Of course I no longer have that many alarms preprogrammed.
So I guess even system-apps can cause trouble, though I have no proof yet.

Bad luck. Haven’t thought of that. :frowning: