English

FP2 Battery Problems (drains quickly, CPU gets hot) - See batteryguide for workarounds

Fyi: i pugged it in yesterday and shut it down when plugged in.

Now after hardreset, it charged normally, drainage normal…

Everythings fine again :innocent:

1 Like

I also had this problem - battery lasted 4-5 hours, phone got warm. I turned off things I thought might be using power, but it didn’t help much. I put the phone in flight mode for a few hours when crossing a border. Then back to normal. Since then it works a lot better.

Thanks @skimo12. This really helped. I was about to send my phone back for a replacement after only having it for two weeks. It was working fine and then the battery drained completely two nights in a row, waking up in the morning to a dead phone. Cleared the cache on gmail and voila - it’s like new.

1 Like

Someone should really do some tests with the Gmail app …

Hey rock.minister,

did you solve your problem? You had the heating issue right after reseting your phone. I have the same issue using my phone with Open Fairphone OS. I checked all my apps on the phone but couldn’t find anything. I don’t have google apps so I couldn’t test “clean master” and gmail app cannot be the problem.

Any ideas?

hey,

i wasn´t able to solve the problem. First i did a hardware reset and wiphed the data cache. Worked some weeks for me. But after another update, the phone dind´t react any longer.
I think it´s a hardware defect. I wrote for a aupport ticket (took one month), and the Fairphone Stuff wants me to send in the Phone.

Sorry

Hello, I updated FP2 to OS 1.6.2 and battery problems started: after 5 hours in airplane mode battery lasted 25% of charge. I have not facebook, nor spotify. With an extremely reduced usage the charge did not last a day. The phone was a little hot. Finally I downgrade to OS 1.5.1 and I found the battery life I had before.

hello, How do you downgrade the OS? It seems my phone has the same problem but when updated to 1.7.0. battery is not lasting event the day.

Do you use any apps that use the proximity sensor e.g. to lock/unlock the phone? There is a bug that causes wakelocks, so it’s best not to use such apps until the bug is fixed.
Downgrading is never recommended.

No, I’m not using thoses applications, I just use the right button to
lock/unlock it. Others applications that could be draining the battery?

Hi dear, have the same problem, Can’t find the Clean Master App, could you help?

I’d suggest not using it - I found later that it was CM that was causing the problem. Justuse an app which can scrub out your accumulated waste data.

2 Likes

@juanmog Sorry, I don’t see your question. I just download OS 1.5 files and follow the instructions for Manually install Fairphone OS for the Fairphone 2 in https://fairphone.zendesk.com/. I had no more problem with OS 1.5 but I’ll try soon OS 1.8.1

I think 1.8.1 is not the best one, since I updated it, the phone performance is worst ever. Battery running out in a morning, phone restarting randomly, typing not working well… Let me know if it works for you, may be is related to applications i’m using.

Hi there,

I installed the 1.8.1 update last week and now the battery drains very fast. It doesn’t last a day anymore. Do other people also have this problem, or could it be an issue with something else (SIM, SD Card, App, etc.) that 1.8.1 has somehow aggravated for me? I’m reasonably certain 1.8.1 has something to do with it, because right after I installed it, the battery started draining very fast.

Thanks in advance!

Disabling the scan for wifi’s when in standby and disabling Gmail and clear this cache helped a little bit on my wife’s FP2.
(Options in wifi settings)

I have the exact same problem: my battery only lasts half a day, even when I don’t even use it. Have you heard of any solutions already?

Hi. The workaround in this post https://forum.fairphone.com/t/use-of-proximity-sensor-drains-the-battery/22155/31 help me to solve the problem.

1 Like

For me the problem kind of solved itself. I think it might have been a misbehaving app that got updated around the same time I updated the firmware,

I cannot confirm this. Actually with each update my battery/phone performance got better. Now I can keep on one full charge for almost 2 days when not using the phone heavily. The update worked fine right from the start. But since there are many other users running into troubles with this update there must be something they all have in common. I would rather assume a bad behaving app.