English

FP2 2020 bug? Phone reboots

Tags: #<Tag:0x00007f05d9a61478>

I wonder if this is just a strange coincident or if there might be a 2020 bug in the phone. This morning 1 Jan 2020, my phone suddenly started to reboot itself for no apperant reason. Sometimes it reboots itself over and over again, sometimes I work with the phone for a minute before it happens. But when working with the phone, a lot of functionality is missing.
I’ve done all the staps in https://support.fairphone.com/hc/en-us/articles/115001041206 except for te factory reset. Before doing that it would be good to know if other owners of FP2 experience the same problem starting this specific day.

3 Likes

Mine hasn’t experienced any reboots today, so I cannot approve the idea of a y2020 bug. I’m runnung LineageOS 16 w/ microG, so I can’t rule out that the Situation on FP OS / FP Open might be different or that the issue might be related to Google Services.
So if you post some more details, esp which OS you are using and which new apps you possibly installed recently, other FP2 users with a similar setup might be able to provide more help.

Happy new decade anyways. :slight_smile:

3 Likes

I have the same problem. I put the phone into flight & energy safe mode before I went to bed (which was 2020 already). After I got up I went back to normal mode. Since then my phone has permanent hard reboots. I can barely make it into Android with unlocking then the reboot appears after max. 10 seconds of usage. It also restarts if I don’t use it.

My phone is running FPOS. What I already have tried (without success)

  • Taken out the battery, fully charged the battery
  • Started in #dic:safemode several times --> restarts there also occur after a few seconds
  • Accessed #dic:recoverymode , cleared the cache
2 Likes

As an observation my backup FP2 running FairphoneOS, although not signed into Google elicits no such behaviour .

3 Likes

No abnormalities with Android 6 on my FP2.

1 Like

Hi, and happy new year, even if our fairphone makes for an annoying start … when we want to make those special calls and can’t. I had to take out the sim card and put it into my old phone to make those calls. My FP2 version is 7.1.2 and has been showing the behaviour you described all day today, not allowing me to use any of the functionality. But I noticed that the rebooting happened also on Dec 22 when things went back to normal the next day (with a bunch of messages coming in that I had missed out on). I have taken out the battery and made sure it’s recharged, haven’t tried anything else yet. I hope this is only a temporary bug and to hear more on this in the next few days…

On my Fairphone 2 with Android 7.1.2 no abnormalities.
Perhaps it’s an app that is misbehaving.
I don’t use Facebook or Whatsapp.

Mine is currently working again. I can’t say why. During the day I have tried several things without any success, enduring dozens of reboots. Then, suddenly I was able to use the phone again. First only for about a minute to the next reboot, now I am typing this reply with the phone running since about 2 hours without any reboot.

Hello and Happy new year!!!

I got the same experience (reboots on the 1st of January + many bugs) and it’s working a bit better but I still have problems :

  • the bottom center and right buttons are not working anymore
  • my parameters had changed with my Sims so I had problems to connect to data
  • I wanted to Initialize the phone but first get all my files still on the phone but I cannot connect my phone on my computer to transfer the files…

I am using the phone for work and it’s calm today so not big deal but I hope anybody will find an answer to our pb!

Hello, my FP2 Android 7.1.2 Open 19.11.2 working correctly, without problems. Happy new year !

Hello, exactly same issues: my FP2, which used to reboot alone occasionally for months (1 or 2 times a day!) began a few days ago (before the 01/01/2020) to reboot itself continously. It seems better now, but the two right buttons don’t work, I can’t access my parameters from the top-sliding menu, I can’t connct my phone with my computer, All my contacts and agenda are lost and doesn’t synchronize with DAVx5, etc… Does anyone can solve this before I hard-reboot
the phone?

Same over here. FP2 started rebooting every now and then since 2020. Then more often. I tried to delete some apps, but I couldn’t really, because it rebooted allover again. Now some other apps don’t even work …

Now the FP2 is rebooting every 10 seconds. Therefore I can’t even do a factory reset.

Any help?

You could still do a factory reset by entering recovery mode (by pressing power and volume up keys for a few seconds when the phone is off).

By the way my old Fairphone 2 (bought it in Sept 2017) shows the same behavior. Even a factory reset has not brought any improvement. A newer FP2 I have tried does not show any problems.

1 Like

Interesting.
Any difference between them? Old/new camera module(s)? OS version?

Both have the new camera, I have manually upgraded the older one. What I noticed however is that despite manually flashing the latest FPOS (19.08.01) available for download to the older device, it still shows the robot (“no command”) first. The newer FP2 has TWRP recovery, even though I just updated both phones using the updater app and have not manually installed TWRP on the newer FP2. So I thought maybe the core module has some differences depending on its age or the upgrade process from Android 5 to 6 and then 7 does not result in the exact same condition as from 6 to 7 on newer phones.

1 Like

I could do a factory reset! Thanx. The problem vanished … FP2 is working again :slight_smile:

2 Likes

I’ve finally done a factory reset also. Everything seems working fine now,… hope it won’t occur again!

1 Like

Thank you all for feedback, I’ve been away travelling for some days and just came back. Luckely my FP1 was still working decently.

I guess I need to do a factory reset.

I was going to write …last night I decided to reboot the phone to its initial…as it came from fabric…saved all photos , apps , contacts etc… and did it!!! And …know it works perfectly and much better than before…I have to write to support , they where telling me to send the phone for revision…
So take good note.

3 Likes

Anyone concerned by this – you might want to give a manual installation of the latest update (19.11.2) a try. Sometimes erratic behaviour like the one you folks describe results from imperfect installations of updates, and it seems to me that is more often the case with OTA (“over the air”) updates (i.e. update through Wi-Fi).

It cannot really hurt to give this a try, it’s a softer approach than going for the hard reset (factory reset) right away because unlike the factory reset, this should usually keep your data (a backup is highly advisable anyway). And if it doesn’t help, you can still go for the factory reset.

1 Like