FP2 %1$d%% on lock screen after freeze

Since the recent big update my phone has been slow at performing basic tasks, sometimes to the point that I have to lock the phone. When I do that and then wake it up using the power button I get this message on the lock screen in the place the battery percentage would normally be: %1$d%% (see attached screenshot).

Is this just the phone struggling to display the battery percentage or is something else going on?


1 Like

I’ve seen this too on a FP2 once. I believe it’s just a placeholder displayed before the battery percentage is calculated.
It’s only displayed for a second or so right?

I have been having exactly the same issue with the battery indicator, and most of all with the phone being painstakingly slow to perform basic operations like opening apps or typying. This is since the last update.
I can’t believe this phone is not only still on Android 7 and subject to so many bugs.

I also get the same behaviour after switching to Android 7, which introduces these very annoying slowdowns every now and then…


Same with my FP2 since Nougat

1 Like

Seems like a legit bug … somebody has to enter it into the bugtracker then, else it will not be fixed … (or did I just not find it?) …


(Currently, use a browser which lets you work around the expired certificate, i.e. not Firefox.)


Exact same issue for me! Only since last major Android update. Tried doing usual business like clearing apps cache and such to make sure I’m not just clogged up, but even basic normal tasks like locking the screen, typing, opening ANY app, entering unlock code… Tends to go non-responsive for about five seconds.

Most annoying thing is when it stops responding, then catches up and THEN decides to bring up the little ‘X app is not responding, close, wait etc’ once it starts working again.

Glad to hear this isn’t just me - my phone is getting nearly unusable!


j’ai les mêmes problèmes sur mon Fairphone2 après cette Mise à jour avec également de nombreuses coupures intempestives.
Il semblerait que ce soit un problème très répandu.
I have the same problems on my Fairphone 2 after this Update with also many untimely cuts.
This seems to be a widespread problem.

An issue has been opened already (here), and I just chipped in to let them know the user is not the only one experiencing that same problem. I would invite everyone who experiences these very disruptive freezes to also comment and report any relevant detail.

1 Like

This screen has also appeared on my new (1 week old) fp2 several times. So far, in my case, this screen has only appeared after a call (a normal phone call via mobile Connection, or a WiFi-call over Signal or Telegram) has been abruptly disconnected and ended.

On this issue in the bug tracker it has been suggested to try either a factory reset or to manually reinstall the OS. Has anyone tried that already?

1 Like

Just seen that the bug tracker thread has links to how to do both of those. Think I’ll give it a go. :+1:

I’d also be very interested to hear if anyone’s had any luck!
My phone is getting frequently unusable, but in all honestly the last thing I want to do is go through the whole process of backing up and resyncing all my data and files, reinstall all my apps etc etc

If anyone’s tried and can confirm this does / doesn’t solve it, it would save me a LOT of work!

Just FYI to anyone else having this issue since the Android update:

I’ve managed to get things working as normal by clearing a lot of storage space.
Basically the issue (for me, at least) seemed to be that since the last major android update (7 I think?), the phone needs a LOT more space just to do normal functions. Can anyone else confirm this is the case for them?

On the old version things would slow down and get occasional ‘not responding’ lag messages when it was very full (ie under 1-2GB of space), but now it seems unable to run even basic functions without major issues without 5+GB free space.

To be honest I think it’s pretty ridiculous that the phone needs that much space to work. I get that any phone/computer/etc needs space to work, but A) it had no trouble before the update even with much less space, B) that is a LOT of space and C) this isn’t even for difficult or intense stuff, this is for basic functions (ie unlocking the phone, typing etc)

Essentially you’ve got a phone advertised as 32GB, which apparently actually means 29GB, with another nearly 4GB used for system files, then needs another 5GB+ to actually maintain basic function. So really, about 60% the advertised capacity.

Sorry to rant, it just seems the last update Fairphone has basically shaved several more gigs off the storage to maintain basic functions, which is pretty poor.

My phone has 3.87G free at the moment and does not behave abnormally in any way. Yes, it sometimes does not reply for a few seconds but that’s not new since the last update nor in the previous one (Android 6 to 7). Anyway, if the bug affects you, you can upvote it on the bugtracker.

Realised I never reported back - it worked! :smiley:

1 Like

Me too. I’ll post in the bugtracker too.
Just wondering if the following is also related to it, but if I recall it well, it has started parallel.
I’ve not been able to reproduce the “reset to the factory home and lock screen” -my home and home screen are one of the other factory delivered one- which happens when the phone is idle or at least locked (I find the screens changed after not having using it)