English

FP1 slowing down significantly

Sorry, I was a bit monosyllabic… :wink: Ahm, well, it was just a guess. The more apps you install, the more services run in the background/get started at boot time.

There are also services that start at the time you connect to a network. Autostarts lists these services and lets you disable them.

Same problem for me. Fairphone 1 from August 2014, reeeeeaaally slow and switching off frequently.
Probably since Kola Nut 1.8.7 update?
Really annoying, indeed, becoming unuseful cell phone.

You might want to try a factory reset and start anew with an uncluttered phone. :sunny:

Same problem here! Since Kola Nut 1.8.7. update, the phone is turning slower and slower every day! It takes now 10 minutes to boot (blue fairphone screen) and around 8 seconds to turn on the screen every time I want to use it after having switchend it off. Also, texting and even dialing is very slow…

I had the same problem earlier this year, after a previous update and it ended with the phone being completely useless and me having to do a hard reset. Wouldn´t want to do that again… and every other time there´s an update… :unamused:

I have very few apps (whatsapp, spotify, firefox, avira, adobe reader) and haven´t installed a new app since that ominous hard reset months ago. So I don´t think it has anything to do with the apps… Actually, the only change I made to the phone in the last few months was installing the new Kola Nut update!..

If anyone has any idea on how to solve this without having to hard reset, it´d be great! :slight_smile:

If not, I´ll try the factory reset :frowning: But it would be great if Fairphone could look into this, so that users don´t have to go through this after every update :blush:

1 Like

I would suggest that you check your battery. See a little guide to fairphones battery.

For those how have the slowing down FP1:
can you please check with an App of your choice, which processes/Apps are using the most CPU time (preferable with comparison before/after this behavior starts, if not always there).
I only have “BetterBatteryStats” to make this, and it does look for example as shown below.
But I am sure there are plenty of apps availabele to check this.

If you can claim any process/App which is occupying your CPU permanently, you maybe have a clue where to start for trouble shooting…
Cheers, Robert

Here the Screenshot with BetterBatteryStats for my well behaving FP1:

1 Like

I don’t know it this gives enough information, apparently there are not many apps that give the “permanent” cpu usage. (I wasn’t really willing to pay 2,42€ for the BetterBatteryStats app, just for getting these stats once ;))

Maybe WakeLock Detector does the job :wink:

Can you sort by CPU usage? And within the xda forum the apk is free Form better battery stats…

Thanks, it worked.
I let it run for some time, but I don’t think I see anything unusual… :frowning:

Maybe the Tool Usage Timlines (Free) might help. I think you have to configure it to show system processes to but then you can sort the running processes by CPU usage. Maybe you can discover a process that permanently needs much CPU time.

regards,
Shiny

1 Like

Thanks, I’ll try it!

Just for the record, I also noticed a significant slow down since the 1.8.7 update.

@Stefan, I think that a hard reset is not an option for everyone. Also, if apps would be causing this, restoring my backup would cause the problem to re-appear.

I didn’t install many new apps since the update, BTW. But I suspect that one which worked fine before is probably causing a significant drop in performance since the system update: I use twilight for automatic bed reading screen dim, and I suspect that the system-wide screen overlay is causing problems with, e.g., the responsiveness of keyboard apps. (I use Swype, BtW.)

It can’t be that in my case, I have a brand new battery, and I’m experiencing the same problem :frowning:

1 Like

My phone is also really slow since some Weeks.
It takes 10-15 min to start and switching apps takes very long.
There is nothing that runs in background!

My battery is new!
And I do not have much apps installed!
The problems started without installing a new app.

I red somewhere that the Google Play services could be the problem.
They have been updated some weeks ago so this could be the problem?!?!

I do not use twilight or Swype so this cannot be the problem

The problem persists, even after I had to do a hard reset because the phone was frozen…
I did a reset around every two months since I got my Fairphone. Now I’ve given up and ordered a FP2. I just hope I won’t throw it my phone against the wall out of frustration before the new one is delivered :slight_smile:

I tried to make a screenshot of the CPU usage when the phone was really slow. Needless to say, this was impossible. When it’s slow, it takes several minutes before this app opens and I can take a screenshot.
Anyway, I hope it can help to discover if the problem is an app or the system_server process service that’s almost always on top of this list. The other one that frequently reaches the top is the android.process.media…

@danielsjohan

  • Without provide real help I noticed you are far not the only Android user with this problem, as a short google search showed, but by fast-reading the links ([1][1], [2][2], [3][3]) I could not see any useful solution.

  • Are any more details available, if you click “system_server” in your screenshotted program?

  • are these values the real-time-values or averaged values (over which time?)?

  • If it are real-time-values you could try as follows:

  • start to manually terminate app by app to check, whether any of the installed app (running active, in background or in cache) causing this

  • do so by: system settings --> apps --> active apps --> tapping on on app and “terminate”

  • after each termination check if the cpu usage of the system_server did change (drops) drastically for some ?minutes?

  • it could be, that android becomes unresponsive if you terminate any system app. But in “emergency” I think this sould be solved by restarting the FP and begin with anohter app…[please correct me, if I am wrong]

  • By the way: you have only one mobile-network symbol in the notification bar. How you made this? If you are using GravitiyBoy for this, maybe there is any wrong setting?

@uudddu maybe you can also provide a screenshot with the app @danielsjohan used, if you don’t have a better one?
[1]: https://code.google.com/p/android/issues/detail?id=160945
[2]: http://forums.androidcentral.com/google-nexus-5/574440-constant-high-cpu-usage-system_server-bluetoothphoneservice.html
[3]: https://together.jolla.com/question/62372/alien-dalvik-in-busyloop/

1 Like

@therob, thanks! I’ll try to provide some more information!

Not much information: Type,Package, Process ID and Command line
And 3 buttons: open, details, terminate. Pressing “details” does not do anything, alas…

[quote=“therob, post:24, topic:10187”]
are these values the real-time-values or averaged values (over which time?)?
[/quote]As far as I understand, these are real-time. That’s the reason why I’m trying to take a screenshot as fast as possible once the phone starts behaving strange…
Most of the time, when I finally manage to enter the Usage Timelines app, the phone already runs a lot smoother than some minutes before :confused:

[quote=“therob, post:24, topic:10187”]
If it are real-time-values you could try as follows:
[/quote]The problem is, the slowing down gets worse and better from one moment to another, without any visible reason. Terminating apps didn’t work (I tried it before). Or at least the speed change that did occur sometimes (when terminating random apps, no logic to be found) didn’t last for long.I supposed the speed change didn’t had anything to do with the termination, since it really goes very randomly…

[quote=“therob, post:24, topic:10187”]
it could be, that android becomes unresponsive if you terminate any system app. But in “emergency” I think this sould be solved by restarting the FP and begin with anohter app…[please correct me, if I am wrong]
[/quote]I don’t completely understand. You mean restarting the FP every time the problem occurs? I can try, but the power button doesn’t really react when the phone goes in crisis mode (yes, it’s really annoyingly trying to do everything to prevent finding a solution, I know!)

[quote=“therob, post:24, topic:10187”]
By the way: you have only one mobile-network symbol in the notification bar. How you made this? If you are using GravitiyBoy for this, maybe there is any wrong setting?
[/quote]It’s a gravity-box setting I have used (and not changed) for over a year now. But I’ll check if I can find something!

@therob: No I cannot take a screenshot, because when I open the OS Monitor the system is okay again…

Now my phone does not start any more, even after 8 hours… -> Factory reset :frowning:

I uses the Fairphone Launcher Version 2 could this be the problem? But I use it since it is available without problems, so I do not think so…

Edit 1: I had the idea to do the “update” from Kola Nut 1.8.7 to Kola Nut 1.8.7 without doing the Factory Reset. See here (I did a clear cache before)
And it works it starts normal :slight_smile: and all my apps and data are still there.

Edit 2: If I enable the Xposed Framework it does not start anymore like before…

Edit 3: It is only Xprivacy if it is disabled the phone starts normal.
I found this in the web:

For those who installed xposed v2.5 there is a safemode feature.

Boot your phone as normal, and keep on tapping either the power, volume
up or volume down button (for mi note it’s power) until you feel a
vibration from the phone.

And then you will need to press another 4x of the button to get into
safemode and bypass the xposed loaders and the phone can boot as normal

for me volume down worked

1 Like

Nice that you figured it out!
I use Xprivacy 3.6.18 and don’t have these problems.
Can you confirm that enabling/disabling will provoke exactly your problem?
Which version of Xprivacy you tried?

All other people (@danielsjohan, @Kristine_ @Isabel_Urrutia, @Andres, @madslj) having this problem are using xprivacy as well?

1 Like