Forum using (mobile) Firefox browser

just tried: no issues : )

It’s not that much about issues, but about limited forum features.


  • When I click on a topic to show the latest post, the page jumps up to like 20 posts earlier.
  • marking text in a post-edit-field is hard because cursor jumps (maybe Firefox’s fault)


  • You can’t quote through a button.
  • You can’t insert a link through a button.
  • Bullet points in lists don’t seem to work
  • the pop-up, when you type @ to summon other users, does not work properly.
  • If you have a higher forum user access level, you can’t edit the category or title of a thread.

can replicate this. it’s a little surprising : )

I don’t think the limitations are limited to just Firefox browser, as I have noticed these limitations in chrome.I think it’s a case that discourse need to work on the mobile version a little :slight_smile:

1 Like

Hi folks,

Any update on usability issues with Chrome or Firefox? Any improvements?

I got another question from @TheDon about the forum (Discourse software) not running well on any of his browsers.

You mean this:


No problem with desktop Firefox here but various mobile browsers sometimes fail to load a discussion thread (it shows the loading indicator and it doesn’t disappear anymore). Started happening around the 1.8 release and I think it’s more prone to happen with long threads.

This happens to me all the time, not just on my Phone. Whenever I click on a Topic with lots of replies I end up in the middle and If I want to go to the first or last topic I have to scroll to to top or bottom of the page multiple times, because each time it loads more posts. Its pretty annoying

A workaround is

a. Do not click anywhere until the post has fully loaded. Best not even move your mouse, if on desktop. :wink:
b. And if you click on the post number which displays in the lower right corner (e.g. 10/10), there is a shortcut to the last/first post.

1 Like

Sorry for resuming this old post but I can confirm navigating and editing posts on FP with Firefox is terrible!!!
Hope this will be fixed soon :smile:

There is a topic discussing scrolling in Firefox Mobile further. It’s a very interesting read. Basically we found out, that it started after Firefox Mobile 32 and that it is caused by JavaScript (disabling Javascript renders the Fairphone Forum completely useless though…).

1 Like

Thanks! Its very strange I found this thread regarding Firefox issues, but the forum didn’t notify me of new posts in the thread you linked the very same day :confused:

When I would like to open a thread the screen left white… Just the rotating circle…
And yes, some month ago the problem did not exist.

Any help?


@Dosc You should check this thread: I cannot view posts on mobile when logged in. You most probably will find out, that this does also occur with any other browser you will try. The worst part of it is that there is no obvious pattern.


Thanks, happy to see I’m not the only one…

Me too, but I suppose (didn’t try though) this depend on the problem mentioned in the @Stefan linked post

The mobile experience of the forum is still not great.

  • I can’t scroll on popups, so if a button on a popup is not being displayed right away I can’t get to it. (Sorry I don’t know how to describe this better, I’ll add a screenshot later. @Stefan @Chris_R you can try and reproduce this next time a spambot-post needs to be approved. When you click “delete user” a popup will appear but you can’t get to the button to confirm)

  • I also can’t send “new messages” because I can’t get to the field to add a user to write to.

1 Like

I don’t have problems with the spam-popups. Also I can add users to recieve-field in a pm. I’m on Fennec F-Droid 39.0.2

Another weird thing I discovered though:

At first it is only 10 characters as a limit and then Discourse wants 20 again.

PS: I guess this is not a mobile specific.

1 Like

This is what it looks like when I abandon a post on mobile. The botton is still visible and can be used, but with other popups some buttons are hidden.

About the messages: If I hide the keyboard I can get to the field where I can enter a username. When I click into the field the keyboard is back and the field can’t be seen again. I don’t see what I type but fortunately suggestions pop up downwards so I can choose the recipient.

1 Like

I can’t reproduce your issue. See my “abandon”-message:

Edit: You know what’s your problem? You have “Desktop-site” checked in Fennec’s menu… :wink:

1 Like