I cannot view posts on mobile when logged in

Hi all!

I have an issue, which makes it impossible for me to be as active on the forum as previously.
When I access the forum on the FP itself, I cannot view posts (I only get a blank page, even without the navigation bar on top).

  • everything else can be viewed
  • this happens in both Firefox for Android and the Stock Browser
  • it is the same on 3G and Wifi
  • I believe this started after the Discourse upgrade to 1.2.0beta3
  • when logged out, threads can be viewed.

I strongly think this is related to the upgrade of Discourse.

Can someone try to reproduce this please?

Thanks in advance, Stefan

Edit: My log, from the times I notice it happen:

  • Sa., 27.12.2014, 9:00
  • Mo., 29.12.2014, 14:23
  • TU., 30.12.2014, 13:22 (OK 30mins later)
  • Th., 01.01.2015, 14:30
  • Fr., 09.01.2015, 12:36 (I had only opened one PM before the issues occured)
  • Sa., 17.01.2015, 8:59
  • Su., 18.01.2015, 17:36 & 18:45

Edit2: I stopped noting down every time it happens. It’s still happing various times a week!

You beat me to reporting this, with the 1.8 update I haven’t had a chance to play around with this, but yes I have the same results.

The only way I can get it working is to use the “request desktop site” option on chrome

1 Like

Works for me today. I’ll post back if the issues return.

Even editing a post title is possible now (Just edited my issue list here.)

1 Like

I’ve seen this as well, but though it would be a Firefox or connectivity problem. Happens every now and then. I could access the forums several times without problems, but especially when I try to follow a link in a notification e-mail, I get the blank page issue.

Could be that the Discourse update really brought some strange side effects.

1 Like

Same problem. No thread loads on mobile browsers (Chrome, Firefox, Browser). Circle loops forever, no page loads, sometimes blank. Desktop site works (basically). Probably bug in layout algorithm.


ah, thanks God i am not alone in this - i was out and around and couldn’t use the laptop, but couldn’t load the FP forum on the phone… oddly enough, some threads would load, others not. same issue with both the stock browser and chrome - so i assumed a forum bug rather than a connectivity issue or a browser bug. quite annoying, i have to say :smile:

1 Like

Are you still having this issue on Dec., 20th? It seems to work for me now! :slight_smile:

hi Stefan,
i got a notification via mail of your reply to this thread this morning. so i loaded the forum in my phone, opened a few threads, and it worked. so i wanted to load this thread to reply to you and confirm - but instead i just got a blank page… :frowning: it works fine on my laptop. so no, unfortunately not fixed.

1 Like

Did you try to open the thread from the notification e-mail? That seems to be the problem in my case. I can open the forum manually, but the links in the mails lead tip blank pages. Mental note: I need to look at these links.


It doesn’t work for me. I still have to switch Firefox to Desktop version to read threads.

interesting… i’ll keep an eye on it!
(just now i opened this thread without problem…)

1 Like

Strange. I can’t reproduce it any more. Following links from the mail notification works, also for older links.

Maybe something changed, or I was imagining things. =)

Just BtW, is there a easy way to check if someone tightened some screws on the Discourse installation? Or updates were made?
I haven’t seen any notifications, anywhere. Also no admin comments when the forum was down last week.

Still happening here. Since quite a while actually. Cyanogenmod with FIrefox Browser / Android Browser. Worked perfectly before…

The issue returned for me, after not occurring for one week or so. :frowning:

Edit: I could not find anyone reporting this issue at https://meta.discourse.org, so it seems to be only happening here on the Fairphone Forum. The current version we are running is 1.2.0beta3. The next stable version of Discourse (namely 1.2) is to be released in early January 2015.

You should open a ticket then, I tried out this forum: http://forum.fairmondo.de with the same result.

It’s strange that this does not occur for everyone. I suspect the problem has to be reproducible on a mobile device:

  1. Open Firefox 34.0.1, bring up the menu and make sure “desktop version” or “desktop site” is unchecked.
  2. Close all tabs, open a new tab
  3. Go to http://forum.fairphone.com
  4. Make sure you are logged in, if not, log in and go back to step 2
  5. The list of threads will display
  6. Click on the first thread (the one about the update)
  7. The loading circle will be displayed, but nothing more happens
  8. Bring up the menu and hit Refresh
  9. The page loads again, and a completely white screen is displayed

Same behavior with the stock Android browser, with Chrome 39.0.2171.93

I’m running FP1, Android 4.2.2, Kernel 3.4.5, Build W20-HL.V0036, up for 230h
The site basically works (the list of threads appear), but display of a thread doesn’t work.

Now try and switch Firefox to Desktop version in the menu and see that it works. It has to be a problem with the responsive UI of the forum software.

Sometimes it does work on mobile too. I am still trying to find out a pattern there…

Last time it did not work for me was Sat, 27.12.2014, 9:00

I had the same problem when I first used the forum on my Phone. I haven’t used it on the Phone ever since.
Right now I can’t reproduce the Problem at all, but at that time, for me, the pattern was: I could open all topics except the one I posted myself.

I’m going to collect a log of the times it happens to me. I will update my original post as I gather more data.

Thanks for the feedback, all.

I believe it could be an issue with the server/storage of the forum. It is causing general bugginess and could be the reason for this. @Marco and I are looking into it and hope to have a long-lasting solution for this in the coming weeks (let’s say goal is mid-January). But in the short-term, it seems like the forum is readable on mobile again.