Foodora App logs me out instantly

This might be a pretty complicated problem, but here it goes:
I use a FP2 with the software LineageOS. I’m working for Foodora (food delivery by bike) and the app we use while working is called Roadrunner. In this app we can receive and accept orders and also connect to Google Maps to find our way. Today I had my first shift but when logging in to the Roadrunner app it instantly logged me out again. Like after half a second. I’ve tried everything I could think of (restarting my phone, reinstalling the app, changing all sorts of GPS settings, reinstalling Google Maps, restarting my phone again), and nothing worked.
Do you have some more ideas what I could try?
Extremely thankful for responses!

Questions that come to mind:

Does Google Maps work on its own (i.e. outside of the RoadRunner app)?
How did you install Google Apps (procedure + version)?
Does RoadRunner rely on the Google Services Framework?
Have you registered your Google Services Framework ID?


Hey Johannes! Thanks for your reply!!
Yes Google Maps works fine on its own.
I install Google apps through this other app, called Yalp. But Roadrunner I installed via a link:
Version 9.79.2 of Google Maps and version v2.9.2 of Roadrunner.
I don’t know if Roadrunner relies on the Google Services framework, but I’m starting to suspect that that might be the case and the problem…not sure though.
Does registering your Google Services framework ID mean connecting the phone to your Google account? Many apps in my phone are connected to my Google account, but I actually don’t think my phone itself is.
I’m very new to this all, sorry! But trying to learn! Thanks again for the response!

Keep in mind not to use Yalp with an own important Google account, as Yalp violates Google’s Terms and Google could terminate the account in question at any time.

But individual Google Apps aside which may work stand-alone or not … some Apps require Google Mobile Services (or GMS for short), which are the standard Google services and App outfit on most Android phones.

Fairphone OS has them.
Fairphone Open OS and LineageOS don’t have them by default, but they can be added by installing an Open GApps package.
“pico” is the minimum for getting the Play Store up and running, “stock” should be similar to what Fairphone OS comes with.
Those packages can be installed using the TWRP recovery you should already have when having LineageOS on the phone.

Did you install those GMS already? (If not, don’t do it hastily now, as depending on the package Apps you use might get replaced by Google Apps, data you want to have on the phone might be synced or uploaded to Google etc. … this needs thinking beforehand or better a data backup and re-installing of the phone)

Furthermore, which version of LineageOS do you use (Settings - About phone.- LineageOS version)?

In a sense. But it is not something in the account settings on the phone, it is just Google’s way of “allowing” you to run GMS on an Android OS installation not certified by Google (like LineageOS) by whitelisting the mentioned framework ID with Google. More on that here …


As it seems this app has a hidden part of AI implemented to protect you from doing such a job. Apologies if I am wrong here.

Hey, I am Heiner.
I sold my Fairphone 2 to Yooyo in April this year. I would like to help to resolve her problem with the Roadrunner App, but I am very limited , because I don’t have a FP2 anymore.
What I did: I installed the Road runner App at my Samsung S5 phone. I could start the app, but couldn’t log in because I don’t have an account there and don’t know, how to get one.
At my phone I am running Lineage 14.1 microG, the actual version of 2018-06-14. Before I have send the FP2 to Yooyo, I installed the Lineage 14.1 microG version at the phone in version 2018-03-18, actual at that time.

I don’t know, whether you have updated the OS to the actual version, Yooyo??? You should do that!

I could do another attempt to work with the Road Runner app at my Samsung phone, if you would send me your login data for this app within a personal mail, if you want?
Hopefully same other guys will try to run the app at their FP2s at the Lineage microG version, or at other OSes?

I really would like to get this app running at your phone!


Just some words of caution:

microG tries to mimick Google Mobile Services to give users a way to run Google-dependent Apps without having to install Google stuff.
That’s all fine for private use, but microG is not Google Mobile Services, doesn’t mimick it completely yet, and can break at any given time Google change something on their services end (again) before the microG community catches up and works around this (again).

It is just my personal opinion, but I don’t think choosing LineageOS + microG as a base for Apps you depend on for your job would be such a good idea.

In that regard, even the choice of LineageOS + Open GApps could be questioned, but it is Android + “real” Google at least and in practice just works up until now.
But if the App in question should continue giving trouble, the Root status of the OS (waiting for version info for that) and then the officially Google-sanctioned and -outfitted Fairphone OS should be the next tries to remedy the situation for the job.


This remark of course doesn’t help you with your problem at the short run, but it’s worth to mention:
The last 11 years in Germany we have a kind of competition to use your bike instead of a car. It runs over three weeks at different times at different communities. Everybody, who wants to take part, can sign in at the ‘Stadtradeln’ app and see whether her/his community takes part at what time period. Then she/he just needs to confirm the kilometers, she/he has run at the bike and it is summed up and compared with the other participants of the community (by the way, I did the most this year for Luebeck, 2360 km within three weeks). Also communities outside of Germany can take part!
At the ‘Stadtradeln’ smartphone app you also can track your bike kilometers automatically.
Until last year this app was depending on the Google Playstore and Google Maps.
But this year the new ‘Stadtradeln’ app is’n depending on Google anymore!!! Same people and me hove claimed to the developers to create a new, googlefree app an they did it!

We just have to tell them, what we want and what we don’t want, loud enough!


1 Like

…oh, I’ve done this. Thank you for the info!

Yeah, I think this might be the problem…

Thank you!! Do you think I could install GMS and still keep apps like Yalp on the phone?
I actually installed Google Play Services even before writing this post but it is not able to run due to “conflict with another app” (I suspect the MicroG?).

I use the LineageOS version 14.1

Thank you so much again!! Will look into that!

Haha to be honest I really like the job so far. Then again it’s not my main occupation, just a job on the side. So I can see his points in the article.

No, I haven’t updated the OS. Will try to do so now!

So what I should do is (starting with step 1 and in case it doesn’t work, move on to step 2, and so on):

  1. Update the OS
  2. Write to the developers that I would appreciate if they could make the app non-google-dependent, like @Heiner suggested.
  3. install Open GApps (and remove microG?)
  4. Switch to Fairphone OS
1 Like

Ooh nice competition! And congrats!!
Also so awesome that they listened!

That’s a safe bet for a start.
Although honestly, with all this installing this and that having been going on now on your phone, I personally would wipe the phone completely and set it up from scratch.

But I know (because I’ve done that a few times myself) that it’s a real hassle and you have to have confidence in your data backup and I understand everybody wanting to avoid that … but it really takes possible pitfalls in the current setup out of the way reliably.

Can’t hurt, but don’t expect quick results.
You could ask them which Google services the App exactly relies on. That would help in picking the right Open GApps package for the moment until they perhaps improve the App.

Yes. If you don’t want to wipe the phone, then remove microG at least, as you can’t count on it to reliably solve your case.
Then install Open GApps.

If all else fails, yes.

Of course you can, but it makes no sense.
Even the smallest Open GApps package, pico, installs the real deal, the Google Play Store.
If you have the Play Store, you don’t need Yalp or the likes.

I don’t have much insight regarding microG because I don’t use it, but it seems reasonable to me that microG and Open GApps could get in the way of each other.
The purpose of microG is to try to look like GApps as much as possible to the OS afterall.


In case you’ll follow @AnotherElk’s suggestion to wipe the phone anyway and want to deactivate microG, I would consider switching to the original LineageOS (i.e. the flavor without microG).
Then you won’t risk any interference between microG and OpenGapps.


The minimal OpenGApps package (pico) has all the necessary parts and libraries for third-party apps to work just fine. So don’t worry.

Yes. microG and original GMS are incompatible.

I’d say there’s no other way. Flashing OpenGApps on top of microG could go wrong, and OTA updates for the LineageOS for microG ROM could cause a lot of troubles, too.

Just for stating this here: official LineageOS can’t be flashed on top of “LineageOS for microG”. System certificates are different, and certificates are saved to the data partition, so it won’t boot without wiping the data.


Hi again, and thank you all for your help! I’ve really learned a lot!
I’ve now installed the newest version of LineageOS, but for some reason can’t find it in storage when the phone is in recovery mode (I think this is because of some setting I’ve changed way back but am not sure which one). Either way, from what I’ve learned from your comments, I am pretty sure just updating LineageOS won’t help me with my problem. So what I am planning to do now is:

  1. backing up contacts, photos, etc
  2. factory reset
  3. install LineageOS (without microG)
  4. install pico (GApps)

I’ve never done anything like this before so am excited but a little scared I’ll mess something up. Therefore asking you here, is that the right order to do everything? Did I miss something? Do you have some tips, or some info I just have to know before I start?


Really wipe the phone.
The factory reset only deletes all user Apps and data, leaving the OS as is (including possible problems).

1 Like

4 posts were split to a new topic: The Fairphone 2’s factory reset … or the lack thereof

now I’ve backed up everything I wanted, downloaded Lineage OS (latest version from here: and wiped my phone.
When trying to restart it tells me “encryption unsuccessful” and that I need to perform a factory reset. But when I click “reset phone” it restarts again and then just comes back to the same page. Have I destroyed it?