Finally... a new forum theme!

That one is still on the to-do list. One thing at a time… :wink:

3 Likes

I tried installing the theme component that you suggested but got a warning that it was already installed. Upon closer inspection of the GitHub URL I noticed that it’s in fact the exact same theme component that I already installed. :grin:

You’re right, I think they removed the hamburger menu item because of the new sidebar behavior in Discourse, which is not enabled yet on this forum (still experimental). It’s strange that my forum does automatically switch theme when dark mode is enabled on my Fedora Linux and Android OS. I hope they merge the icons in the sidebar/hamburger menu soon again. It’s more efficient for space.

and it’s beautiful!

I wouldn’t say that but useable in the evening seems tolerable :slight_smile:

Just a brainfart. If the top logo has the round logo with the hands on the left side, then the transition from the big logo to the small logo when scrolling through a thread is smoother. Because then the round hand logo remains static and the text just gets replaced with the thread details. At the moment the round logo is on the right and then pops to the left corner when scrolling. It’s not a major thing. But I think it can be smoother. :nerd_face:

5 Likes

When in WCAG dark mode I go to

some of the text is in black and unreadable.

As always, @UPPERCASE is absolutely right! I moved the round logo to the left and indeed it looks much better. Thanks for pointing it out! :slight_smile:

5 Likes

I would say since the update I have troubles to use the forum on my FP4. I see glitches when an answer box is open I start to type, look up something and come back and than I cant see the cursor in the box, its hidden by the keyboard. I have to close the forum and reopen to proceed with my answer. Cant explain well and I’m wondering if anyone else is seeing this?

Also, today I tried to move some posts to another topic and I think I selected those I wanted to move (last 3), however the system moved all other posts except the last 3 I selected and closed the topic I was moving into. I have re-done this now and I’m sure I wrote a reply on the topic I wanted to move and which I finally moved, however the answer was put on the other topic where it was split from.
So yeah, I know sounds more like a glitch in blond brain and a user error, still I would like to document…

Is it like this? It’s partly fixed by Discourse, but needs more work. I don’t think it’s related to the theme change.

2 Likes

Yes thats it.

I have seen this sometimes (quite rarely) before the theme change, and see it since the theme change def more often than ever before, so wondering of I’m doing something different since yesterday🤔

So it def. happens when I’m at the bottom of a page, seems when you then scroll up a bit, the answer Windows is “released” again, so no need to close…

Yes you’re right. You may add a big report on the angels homepage GitHub pages. : -)
Unfortunately I don’t have an idea at the moment how to fix it. Will have to look into the html code again…

An easy fix would be to use this CSS for the Angels page that’s embedded on the forum. The downside is that it then isn’t supporting the dark theme. But I suppose that’s fine for now.

body {
  background-color: white;
}

I already forked the Angels page and made many customizations already. I may be able to cherry pick this change I made for my custom page and do a pull request. But that will be later this week when I’m near my laptop and have some time. But of course, feel free to add it already or test it in developer mode in your browser.

My custom variant of that map on my forum in dark mode.

2 Likes

I’ve now already added it as a quick fix. Hope this will not break your pull request. Still very interested in other improvements.

So there’s now a quick workaround for:

2 Likes

Cool! And no worries. I am working on another version, a kind of rewrite to use webpack and download the JS libs via a repository. So that an eye can be kept on potential security updates. It will take some time, it’s a low prio for me. I suspect somewhere Q1 2023.

1 Like

This has now been fixed.

3 Likes

Not sure if this is a ‘new’ issue but I used an html tag [button] the result shows in the right side editor but not in the post.

1 Like

It seems that the <button> tag is no longer supported.

2 Likes

Let’s see if <kbd>foo</kbd> is still supported:
foo

Edit: Seems it is, might that be a solution? :slightly_smiling_face:

7 Likes

Then why is it showing in the editor preview ???