Fairphone4 Issue Sending/Receiving text messages over GSM

Hi there,

last week I received the new fairphone4, everything seems to work except following:

I receive text message over GSM min. 10 minutes delayed.
Also I cannot send any text messages, neither with he built in “messages” app, nor with “signal” or any other 3rd party app. (FYI: I always set the default text message apps in android settings when trying another messaging app).

My provider is “congstar” from Germany.
I have bootloader unlocked & rooted fairphone4 (via Magisk).

Is someone else having this issue? Perhaps this issue appears only on unlocked bootloader phones?

When I go into the hidden android menu:

@ dialer app, entered the code ##4636##

Under phone infos, the “SMSC” number is completely empty, when entering the number
" +491710760000"
(source: Tipps und Tricks zum SMS-Versand - Tarif- & Produktberatung - congstar Support Forum)

it seems nothing changed (still not able to send text messages, also not after rebooting).

For future ref.

Surround the star hash star has 4636 etc with the Preformatted text option </>


I’m a congstar user as well, my FP4 is rooted with Magisk and SMS work without any problems (just sent one to myself using Signal).
This is on a eSIM though, are you using a regular SIM? :thinking:

Thanks for your response. Yeah I am using the normal SIM not the eSIM.

Just one more question:
When sending via signal app to yourself, signal isn’t sending a text message via SIM card, it is using the signal protocol over Internet, not GSM. So you have a second phone which received the text message? You can turn on “airplane mode” and then enable WIFI only, then try sending a message via signal app. You will also receive the message which proofs that it isn’t using GSM.

Can you confirm, that the “SMSC” is also empty when you enter the code in your phone-app:


Thanks in advance

If you long press the send button in Signal you can change the sending method. I changed it to SMS before trying.
But just to be absolutely sure, I just sent a SMS message from an old flip phone without internet connectivity (also on congstar) to my FP4 and the other way round. Zero delay either way.

The “SMSC” wasn’t empty when you first asked your question, funny enough, now it’s empty, but still works :thinking:

1 Like


could you solve the problem?

I have the same problem with O2 Germany and eSIM:
I receive SMS, but I cannot send SMS regardless of the app I use.
O2 does not find any probems.

Is there a problem with eSIMs and Fairphone4?


Welcome to the forum :wave:

Have you tried deleting the eSIM and adding it again? :thinking:
Maybe something went wrong during the initial setup.

So far I haven’t encountered any problems with my two eSIM from different providers, but maybe I’m just lucky :man_shrugging:


deleting the eSIM will “destroy” it, then you have to get a new one.

But by chance I found the cause:
I deactivated the Google carrier services app.
I did not need this app with the SIM card of my girlfriend to send SMS, but I need it to send (not receive) SMS with the eSIM.


Huh, didn’t know that, had to try it of course and you’re right :smirk:

Yeah, even custom ROMs have to ship it to get eSIM working… :roll_eyes:


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.