Fairphone OS 17.06.4 (Android 6.0) is now available

Hi all -

We have a new software update ready for your Fairphone 2. It is named Fairphone OS 17.06.4.

##What’s new

  • Fixed bootloop issue caused by disabling the Google App
  • Fixed unable to mount micro-SD card in Recovery Mode
  • Improved the built-in Fairphone Updater app
  • Updated the ‘Powered by Android’ logo
  • Security fixes – Android Public Security Bulletin from June (partial)

For the full release notes, check fairphone.com/release-notes

We also released its equivalent Fairphone Open 17.06.4, our open source version of Android 6.0.

Open the built-in Fairphone Updater app on your device to start the download.

If you encounter issues with the software update, please refer to our official bugtracker.

You want to help us test new software updates (Fairphone OS and Fairphone Open)? You can do so by applying for the beta testing program.


Product team


And obviously it is out for Fairphone Open OS as well! At long last…


That’s great news !
Now we can even enjoy android 6 + two releases’ worth of beta tests !
Thanks a lot !

Update went smoothly, but the android security level is still 1. May 2017. Don’t know is this a typo or if there is something missing in the update :slight_smile:

1 Like

Security fixes* – Android Public Security Bulletin from June (partial)

Please note: Due to missing platform vendor specific patches, the Android security patch level will remain May 1, 2017. Protecting our users is our top priority, and as this month’s software update addresses some important security issues, we have decided to not wait with releasing this month’s update. We are working closely with our platform vendor to address the remaining issues as quickly as possible.

*Security fixes: CVE-2015-8871, CVE-2016-1839, CVE-2016-4658, CVE-2016-5131, CVE-2016-5861, CVE-2017-0391, CVE-2017-0637, CVE-2017-0639, CVE-2017-0640, CVE-2017-0641, CVE-2017-0642, CVE-2017-0643, CVE-2017-0644, CVE-2017-0645, CVE-2017-0646, CVE-2017-0647, CVE-2017-0648, CVE-2017-0650, CVE-2017-0663, CVE-2017-5056, CVE-2017-7367, CVE-2017-7368, CVE-2017-7373, CVE-2017-7375, CVE-2017-7376, CVE-2017-8236, CVE-2017-8241, CVE-2017-8242

The way I understand it all the ones listed there are already June fixes - it’s just not all June fixes. (cf. Open Os Release Notes)


Oh, good to know, thanks! :slight_smile:


6 posts were split to a new topic: Feature Request: Ability to download updates via mobile network

Again the (incremental) update via Updater app failed (like the upgrade from 5.1 to 6.0 and the first update from 17.094 to 17.05). This time, however, I’m not sure why it the Updater app had failed: this time I hadn’t deactivated any standard / Google apps, so basically everything should have been fine.

I had to flash the binary images from my computer (method 4) like described on the Fairphone Support page, which worked very well.

Maybe deletion of Updater app cache and data would also have done, but since I had the phone connected to my computer anyway (for the non-installed-TWRP backup, thanks again to @retsifp for this description), I reasoned this was the fastest and cleanest way to update.
Hopefully the improved Updater version coming with this update will improve the situation.

OTA Fairphone OS 17.06.4. does not work. It stops at 18%?

The actual issue will be seen behind the Error message; can you open recovery when you see the Android robot, and check what it says?

hi Rick

I can not open recovery when I see the Android robot.

I tried with Volume Up and Vo Down.


To open recovery mode, you need to press the Power button and the Volume up button.

When I press the Power button and the Volume up button, the only thing, which happens is the Android robot appears again after short buzzing.

You have to press and hold the power button, then the volume up.

I could manage:
E: Error in /cache/fp_update_FP2-gms-17.06.4.zip
(Status 7)

Just to be sure, you actually press the power button and the volume up once you see the resting robot right? Not when the phone is off.

I could manage:
E: Error in /cache/fp_update_FP2-gms-17.06.4.zip
(Status 7)

Is that all you see? It might be your download got corrupted, just clear the data of the Updater app and try again. If you remain having issues, just install it manually.

Now I did manually as described. Same again.

Ok, that’s clear, it means you altered the partition before (in this case the boot partition), by rooting the device, etc. Please note that installing these updates only work on original partitions, not when you alter them. The solution for you is to flash the latest image: https://support.fairphone.com/hc/en-us/articles/213290023-Fairphone-OS-downloads-for-Fairphone-2 (use the latest binary image at the bottom of the page).

1 Like