Fairphone Open 17.06.4 (Android 6.0) release

Not sure if it’s worth anything, but here’s my report of my second attempt to install Marshmallow:
I re-downloaded all the files necessary, just in case, and made a backup through TWRP. Then I disabled the GravityBox module in Xposed, as that requires a different version in Marshmallow and I was hoping that might’ve caused the first update failure. Then I had a very smooth installation process, flashing the OTA file, followed by OpenGAPPS and Xposed, wiping Cache and Dalvik, and finally rebooting the system. Was very smooth, indeed, just like last time.

Optimising 144 apps takes some time, but it was a lot faster than before for some reason. However, I got caught in the cyclic reboots shortly after. It seemed like the phone freezes every time when a message pops up, asking me to allow Xposed access to write on the external sd card. I took the battery out, let the phone cool off (phone gets insanely hot during the entire process) and took the sd card and my second sim card out. After turning it on again it needed to optimise 20 apps again. Then I noticed that the battery charge dropped from 79% to 26% and was actually discharging 1% per second. I quickly connected the phone to the charger and it was back to both: being extremely hot and caught in the good old cyclic reboot.

Every time the phone boots up I can actually use the phone for a couple minutes before it freezes and it looks like it might be the fault of Xposed. Every app seems to open up just fine (in the way app like to open up directly after booting up), except for Xposed. Every time I try to open the Xposed app the phone freezes instantly and reboots shortly after. Maybe the cyclic reboots have to do with Xposed? Does anyone have a working Marshmallow with Xposed to rule that out?

Anyway, quite annoying long procedure, looking forward to downgrade again later on… :cry:

Yep, works fine for me. No GAPPS, though, just Xposed, XPrivacy and microG.

Just to make sure: You’ve downloaded SDK23 of Xposed for usage with Marshmallow, right? SDK22 like it was for Lollipop won’t work.

Hello, upgrade from fp2-sibon-17.04.0-ota-userdebug.zip to fp2-sibon-17.06.4-ota-userdebug.zip. Downloaded OTA file and xposed-v87-sdk23-arm.zip to the sdcard, reboot into TWRP, made a backup (!!!), flashed OTA file and Xposed, wiped Cache and Dalvik, rebooted. Everything ok, but then, similar to @leVin42 : half a dozen reboots later, no stable phone, everything is there, but when I have to put in the code for the simcard, it freezes immediately or a few seconds later, then reboots a few minutes later… no issue found… downgraded with TWRP (!!!), everything is back again. I had no problem with the battery. So what should I try now? First time I do have a serious problem with FP Open.

Damn, would’ve been at least a reason why it doesn’t work for me…

Yep, I was using SDK 23.

Now I’m back to Android 5.1 and lost all messages I got sent via whatsapp while my phone was caught in the reboot cycle. Very annoying stuff, just hoping I’ll be able to use Android 6 at some point soon!

I don’t know, maybe just use the old Open OS until someone comes up with a solution or Fairphone releases a new version, I guess. Slightly inconvenient, but after two attempts that’ll be my solution for now, I guess.

This sounds a lot like this unsolved bug:

However, doing a handful things at once like a major upgrade of a system (from 5.1 to 6.0) plus upgrading a quite complex mod (like Xposed) sounds like a terrible idea. You may want to split this into several subtasks after each one you can assure your system boots and works, and if not, isolate better your problem. Here is how I’d do it:

  1. Uninstall Xposed.
  2. Boot into your clean system and upgrade to Marshmallow
  3. Boot into Marshmallow and make sure everything works as expected (if not, refer to the bug linked on the top)
  4. Install Xposed Framework for Marshmallow (SDK 23)
2 Likes

X-posed in Marshmallow worked fine for me but, after a few days, I have downgraded to Lollipop again. My battery was draining very fast apparently due to the proximity sensor since it was better when I stopped Gravity Screen (similar to Wave Up and working in Lollipop with Explit’s workaround). I had also problems with a very unstable Wi-Fi connection that I could not fix.

1 Like

Thanks @esther. However, I’m already dealing with a ridiculous fast draining battery (no, cannot be the proximity sensor in my case!) and therefore might give it another go like @Roboe suggested.

1 Like

Hello everyone!

I have a quick question… If I come from lineage os, can I install use FairPhone open just through twrp or I need to do something else?

Merci @Roboe I’ll try this!

1 Like

Just for some kind of heads up. I also had reboot loops, while trying to some this i accidentally did a factory reset cos fastboot (yeah, i know. Silly me). But system was stable afterwards. I then sit an “official” factory reset, so i was able to encrypt my data partition again
So, for a week now, I’m on mm open os with xposed, opengapps and encrypted. No further problems, phone runs fine
Excerpt for the cpu scheduler, which let’s run the cpu soon too high frequencies, in my opinion. Pasted here, and also reported on the bugtracker, which probably leads to give battery usage while screen is on. Idle usage is fine, but I’m also using greenify

4 Likes

Sounds slightly similar like something @freibadschwimmer did. Although I didn’t dare do this yet, as I’m not sure I fully understood the method or implications and am afraid of data loss… :confused:

I tried a third time to upgrade.

First I tried @Roboe’s suggestion:[quote=“Roboe, post:190, topic:29656”]

  1. Uninstall Xposed.
  2. Boot into your clean system and upgrade to Marshmallow
  3. Boot into Marshmallow and make sure everything works as expected (if not, refer to the bug linked on the top)
  4. Install Xposed Framework for Marshmallow (SDK 23)
    [/quote]

Of course, I got stuck at step 3 and couldn’t solve that bug. Then I followed the suggestion by @freibadschwimmer:

That kind of worked. At least the first part. I had a functioning clean version of Android 6 without my data on it. It did get stuck in the setup wizard, though. I couldn’t log in to my google account, it just delivered the same pop up regarding logging in over and over. I could break temporarily break out the setup wizard, by just swiping down and go into settings. That worked fine and while the functionality was quite limited, it was stable. So not usable, but at least no freezing or rebooting. Then I tried to restore my data through TWRP and: did not work! I ended up in an eternal boot process and it nearly looked like I bricked it as booting into recovery only worked half the time.

No matter what I’m trying, I always end up with an unusable phone. Luckily, I’m back on Android 5.1 with all my stuff, including various minor bugs I was hoping to vanish with Marshmallow, but it certainly looks like I’ll be stuck with Lollypop for some more time now! :’(

Same here as I had it in previous OOS Versions too. I tap on the calling symbol and try to drag it to the right but I can’t move it and therefore can’t answer the call. Annoying!

Is it the same as with @ungutknut in the sense that it happens occasionally and not every time?

If it happens every time, then perhaps it is worth having a look at Apps that have display overlay permission, as they can cause UI elements to be unresponsive (but normally you should somewhen encounter an error message regarding this):

I had a similar problem. See post FP2 Won’t turn on or charge - See first post for troubleshooting
From all I gathered in the forum, I was sure that my bottom module was broken. Support figured it was the battery. They sent a new one (after 1 month) and it did not change a thing. With the new charged battery the phone worked, until the battery was empty. Still no charging and the red blinking light. So again I told them that I was sure the problem lies in the bottom module. They did not want to send me a new module, but wanted to repair the phone themselfes. I can understand this; they do not want to send out “free” spare parts because some strangers believe they will help. But in my case it was a pain in the ass. The repair-place (it is apart from the normal support) told me that they would definitely delete all my data and I should make a backup. But how am I to do this, if the phone is not working at all??? I contacted my “normal” contact person and she told me, the data will not be deleted. Who am I to believe? Luckly I trusted the technical support. So I had to buy an external charger to charge my battery (on my cost, but they are cheap, crappy pieces childlabour-electronics). Then I could do my backup. I sent the phone to the fairphone repair and got it back 2 weeks later with a report stating: Bottom module replaced. Of course they deleted all my data for privacy reasons.

So, in short:

  • You should contact support and they will help you. They are very friendly, but slow. Which is annoying, because people rely on a phone (I was back on my 10-year old phone for 2 months…).
  • Test to charge your battery with an external charger or a fairphone from somebody else. If it charges, the bottom module is likely broken. If it does not charge, it is likely a broken battery.
  • If you sent in the phone for repair, make a backup before. They will delete your data.
  • You should not buy spare parts on your cost, this is normal warranty.
  • Prepare a bathtub of green tea, buy a rubix-cube and try to solve it just by yourself (no help from the internet!). You will have time to cover and should stay relaxed.

A post was merged into an existing topic: [Bug] :pencil2: Upgrade to FP Open 17.06.4 renders phone useless (freezes once booted and reboots itself)

Hey @conrad, I have the same problem: phone no longer knows what to do with an apk. How did you solve your problem?

Thanks

Hey @s99h, newbie here - grateful for your advice.

I have the same problem, the file manager can’t open apk files to install them. Which also means I can’t install another file manager which would work.

I see you said it’s not too much of a problem - care to share how you solved it?

Thanks

Initially and out of security reasons I wanted to use my local download folder on sdcard to install my network security app “netguard”. Unfortunately that idea didn’t work anymore because of the too limited preinstalled file viewer in FP Open OS Marshmellow, this thing is a sad joke and I can’t imagine why it is considered an alternative solution for anything.

In the end I acted against my conviction, went online, downloaded f-droid from f-droid.org that could be installed from within the Android download app.
Afterwards I used f-droid to find a simple filemanager that deserves this label and subsequently installed further selected apps.

I’m still very interested in better ideas. I am very reluctant to go online too early in the installation process without initial protection.

Thanks @s99h, that worked!