[Bug] ✏ Upgrade to FP Open 17.06.4 renders phone useless (freezes once booted and reboots itself)

There’s no such difference. Fairphone Updater just checks update integrity and calls TWRP.

Yup. Fairphone messed up something with the update but they don’t want to withdraw the update for some reason. Reason that they have not disclosed yet. I’m afraid they are overlooking this critical bug. I won’t recommend plain Fairphone 2 (without Lineage OS) anymore with its history of software bugs, and that’s a pitty, because they are virtually the only business to care for material sources with its high standards.

I’m curious. What did you learned that has to be specificly to FP Open?

I also had no problem with my setup of FP Open 17.04 and Open GApps Pico. Everything went smooth. Thanks for this bug report anyway, because of you I made a full TWRP Backup before the update and will continue to do so for future updates.


Hallo, I realized that my Contacts were gone, (except these ones who were using the app Telegram…) and I read that this happen in safe mode sometimes. I try it again to recover my TWRP Backup and ofcourse the phone is freezing again. So I went again in safe mode to uninstall AdBlockPlus. After that the phone is running normaly but, because of the safe mode the contacts were gone…
But maybe there is a Problem with the Contacts, not with AdBlockPlus…?

Is there a possability to get just the contacts from the TWRP backup?
…or is there maybe a different idea what I can do?

I did the update yesterday and can’t use my Fairphone since then. Same problem as reported by others. I had OpenGApps installed but it broke some updates before. I newer get it to work again.

I tried several things listed here to fix it like booting without cards or safe mode without success.

Then i manually updated TWRP to be able to decrypt /data

davidak@unibook:~$ sudo fastboot flash recovery Downloads/twrp-3.1.1-0-fp2.img
target reported max download size of 536870912 bytes
sending 'recovery' (12204 KB)...
OKAY [  0.385s]
writing 'recovery'...
OKAY [  1.211s]
finished. total time: 1.596s

but it was still version 3.0 where “crypto is not included in the build”. i executed the same command again and was able to decrypt /data directly at start.

so i was able to do a TWRP backup, but it is some special container format and i’m not sure how to extract files.

i copied files from internal storage to my pc with this command:

adb pull /data/ ff2_data

so if you need logs to fix this issue i can provide everything you need.

Than i flashed the proprietary OS because i need some apps from play store at work.

It still doesn’t boot. Fairphone Logo start screen forever after “Starting Android”. Maybe the data partition with unkompatible apps is still present.

Recovery Mode also don’t work anymore. Instead it shows this broken Android:

I executed sudo fastboot -w to format the data partition, but it didn’t help. Is there another way to do it?

I flashed the open OS again like described here. That worked since the linked version is still 17.04.0. I can receive calls and push message from our server monitoring, so i can work again. but i don’t have time to install other apps again.

This situation is a total desaster. I wasted my whole weekend and was not reachable by phone, but that was needed for my work. I also have a problem to recommend this device to friends and justify it to my employer!

Update 16.7.17: The bugreport is one month old and nothing happened. I contacted the support.

Rename the .ext4.win000 and .ext4.win001 files to .tar and you could then extract the content with any archive manager.

Regular FP OS doesn’t include TWRP, but the original Android recovery, which is just for flashing updates and probably, wiping the phone, nothing more. You can flash TWRP again with fastboot. I recommend using the official TWRP project itself port, which support encryption, unlike FP Open’s one.

We all agree. Fairphone has not even removed the update. We are now a month after the bug report and they haven’t done anything yet. I don’t think they care at all at this point.

As this affected your work and obligations, made you loss data, time and patience, Fairphone Open is officialy supported and under warranty, and we have pretty good legal coverage here in Europe, I suggest you to fill a Support ticket asking for responsibilities and consider taking legal actions (though a consumer’s rights defense NGO) if you lost sensible or important data.

After more than a year with a Fairphone 2, justifying Fairphone mistakes (because we know launching a startup is hard) and taking part in the community, I’m no longer a Fairphone supporter but just a merely community friend. This is just inadmissible and undefensible, and I’m not angry now but truly sad.


Unfortunately, my feelings come close to Roboe’s. Currently, I do not have too much time to play around fixing my phone and am dependent on a working phone on which I can be reached. I’m still dealing with quite a few issues (GPS, battery life, random reboots, random screen freezes…), making every day usage quite challenging. I still believe in Fairphone and love what they’re all about, but some things are highly irritating. @Douwe this is a very serious bug, how come there’s no statement or at least official acknowledgement, yet? Is something happening? And why has this update not been removed or put on hold, yet? At the very least I’d expect an official warning so others make a full backup before upgrading!

I wrote my whole failed upgrade story in the other thread (e.g. failed last attempt) and it feels like Fairphone hasn’t even noticed there’s an issue. No I did not file a support ticket, I had my hopes up that the reports on backtracker were sufficient for something to happen… :expressionless:


Still nothing new on this problem and no reaction from the fairphone team ?
@Douwe ?

1 Like

Hey @Roboe and others,

Thank you for explaining this bug and helping each other in this topic. I was unaware of this untill @nicop91 tagged me in the last post.

Please be aware that this is a community forum. I try to read along with most threads, but can’t possibly read everything that goes on in this forum.

I have now forwarded this thread to a developer and as soon as I hear more, I will get back to you.



That’s weird @Douwe - I’m quite well aware how this forum works, that’s why I tagged you nearly a fortnight ago:

Nonetheless, thank you very much for looking into it! :slight_smile:

Hey @leVin42, I just saw that yeah. Somehow I missed that notification. Sorry about that. I guess ‘tagging’ me in a topic is not the best way to reach me. PM’s work better most of the time.

1 Like

I understand your part (and your job, I think), but the bug report —tagged as critical— has been overlooked for a month and a half in the official bugtracker.

It highly worries me that Teemu, the only Fairphone staff that replied to the bug report, has renamed it incorrectly today, and the update hasn’t been retired.

I switched to Lineage OS in the meantime.


So far we were not able to find the reason for this to break.
It seems connected the installation of some 3rd party system modifications and the team is not able to support and test for these kind of modifications.

In what sense do you think the bug was renamed incorrectly?

Some people suffered it without modifying their systems in any way.

We weren’t able to reproduce this bug on unmodified Fairphone 2’s

I have the bug and I did not install any 3rd party system modifications. I just enabled root access (for CatLog to see if I can find out why I get random reboots) and installed some regular apps (through F-Droid or apks downloaded from Google Store). I don’t have any (Open) Google Apps installed.

1 Like

How did you download the apps from the Google store?

Through https://apps.evozi.com/apk-downloader/ on my PC and then transferred to the SD card.

Clear. Thank you for explaining.
We’ve tried several times here to reproduce the bug and did not succeed, so it is difficult for us to find out what is happening.

Today we will release the July update for Open. We have not changed anything in regards to this bug (as we wouldn’t know what to change). But we’d be happy to hear if you still experience this issue when updating to 17.07.


I’ll try upgrading directly to 17.07. and if that fails I’m pretty much out of ideas, as I already tried to completely unmodify my phone. I will try to go back to the regular OS, upgrade and then install Open OS again. I just hope that it works eventually!


Thanks for your effort and constantly providing updates!

How can i completely wipe the phone and do a clean install? I thought flashing the image with fastboot would be enough but it seams the /data partition is still there?

Is encrypting the phone officially supported?