[Bug] ✏ Upgrade to FP Open 17.06.4 renders phone useless (freezes once booted and reboots itself)

I don’t have this app installed, but still have the freeze problem.

1 Like

Me too, although I had two root apps.

I moved this topic from #software:bug-reports as that category is no longer visible for most users. The category is no longer used because we now have the #bugtracker.

1 Like

Hi! I’m also having a problem now. I did an update yesterday and it’s broken now. The phone will freeze after startup and then reboot after a while. Safe mode still works. :disappointed:

The thread here is pretty lengthy, so I would appreciate if someone from the active posters could please point out my options now. I guess a fresh install would work. But is there any chance to get the data back? (pictures, contacts, Signal conversations)?

This is really disappointing. It seems the bug was known for several weeks and Fairphone is still distributing the update. That sounds very wrong to me. :angry:


I moved your post to this thread, which has more info about the bug and workarounds in the first post.

I could resolve the problem today by removing most of my manually installed apps in safe mode.

I made a TRWP backup before starting to remove apps and then tried several different removal orders for the apps. In all my trials, I could not trace the problem down to a single app, or a small subset of apps. The only stable configuration for me was when most of them were gone (some small ones, like a free radio player were always fine).

My contacts were gone, but SMS were still there. Luckily, I found a quite recent backup for the contacts. The only downside now is that the data of the removed apps is gone.



This Morning I used the WLAN connection to do the uptade for 17.06.04.

The hole day now I spend in front of the computer and the Phone.

I never used TWRP and fastboot before, now at the end of the day I now at least what it is.

I followd the steps:

I made a backup with TWRP.
I downgrade to 17.04. with fastboot.
(then there were this continually optimizing the apps)
then I made the factory reset in TWRP. after that the phone was running, without contacts and dates
so I could transfer the 17.06.04 files to the sd card.

Then I uptade again to 17.06.04 with TWRP
no Problem, but when I recover my dates it is still the same problem with freezing.

But I ask myself why should there be a difference between update with the offical updater and with TWRP?

Trist day… is this now just a Problem of the Open Version or is it like all the Fairphone user go through this?

Sad to read about all this trouble, but it is neither Open OS nor all users by default … I updated my Fairphone Open OS via TWRP to 17.06.4 and I had no trouble with the updating process and I have no trouble at all with the updated OS.

My phone was/is encrypted, I had/have Open GApps pico, and I had/have Root access enabled for Apps and ADB.
I didn’t/don’t have XPosed.

Ok, so it seems to work now.

I just went into safe mode and deleted some apps like “adblock” which i make suspect for the problem but I alos deleted some others like Vlc player, google maps… so I dont know exactly which app caused the freezing.
But I think it wouldnt have been worth to do the downgrade and update process… In the end I learned a lot about the FP Open Software.
Thanks to the active forum members!

1 Like

There’s no such difference. Fairphone Updater just checks update integrity and calls TWRP.

Yup. Fairphone messed up something with the update but they don’t want to withdraw the update for some reason. Reason that they have not disclosed yet. I’m afraid they are overlooking this critical bug. I won’t recommend plain Fairphone 2 (without Lineage OS) anymore with its history of software bugs, and that’s a pitty, because they are virtually the only business to care for material sources with its high standards.

I’m curious. What did you learned that has to be specificly to FP Open?

I also had no problem with my setup of FP Open 17.04 and Open GApps Pico. Everything went smooth. Thanks for this bug report anyway, because of you I made a full TWRP Backup before the update and will continue to do so for future updates.


Hallo, I realized that my Contacts were gone, (except these ones who were using the app Telegram…) and I read that this happen in safe mode sometimes. I try it again to recover my TWRP Backup and ofcourse the phone is freezing again. So I went again in safe mode to uninstall AdBlockPlus. After that the phone is running normaly but, because of the safe mode the contacts were gone…
But maybe there is a Problem with the Contacts, not with AdBlockPlus…?

Is there a possability to get just the contacts from the TWRP backup?
…or is there maybe a different idea what I can do?

I did the update yesterday and can’t use my Fairphone since then. Same problem as reported by others. I had OpenGApps installed but it broke some updates before. I newer get it to work again.

I tried several things listed here to fix it like booting without cards or safe mode without success.

Then i manually updated TWRP to be able to decrypt /data

davidak@unibook:~$ sudo fastboot flash recovery Downloads/twrp-3.1.1-0-fp2.img
target reported max download size of 536870912 bytes
sending 'recovery' (12204 KB)...
OKAY [  0.385s]
writing 'recovery'...
OKAY [  1.211s]
finished. total time: 1.596s

but it was still version 3.0 where “crypto is not included in the build”. i executed the same command again and was able to decrypt /data directly at start.

so i was able to do a TWRP backup, but it is some special container format and i’m not sure how to extract files.

i copied files from internal storage to my pc with this command:

adb pull /data/ ff2_data

so if you need logs to fix this issue i can provide everything you need.

Than i flashed the proprietary OS because i need some apps from play store at work.

It still doesn’t boot. Fairphone Logo start screen forever after “Starting Android”. Maybe the data partition with unkompatible apps is still present.

Recovery Mode also don’t work anymore. Instead it shows this broken Android:

I executed sudo fastboot -w to format the data partition, but it didn’t help. Is there another way to do it?

I flashed the open OS again like described here. That worked since the linked version is still 17.04.0. I can receive calls and push message from our server monitoring, so i can work again. but i don’t have time to install other apps again.

This situation is a total desaster. I wasted my whole weekend and was not reachable by phone, but that was needed for my work. I also have a problem to recommend this device to friends and justify it to my employer!

Update 16.7.17: The bugreport is one month old and nothing happened. I contacted the support.

Rename the .ext4.win000 and .ext4.win001 files to .tar and you could then extract the content with any archive manager.

Regular FP OS doesn’t include TWRP, but the original Android recovery, which is just for flashing updates and probably, wiping the phone, nothing more. You can flash TWRP again with fastboot. I recommend using the official TWRP project itself port, which support encryption, unlike FP Open’s one.

We all agree. Fairphone has not even removed the update. We are now a month after the bug report and they haven’t done anything yet. I don’t think they care at all at this point.

As this affected your work and obligations, made you loss data, time and patience, Fairphone Open is officialy supported and under warranty, and we have pretty good legal coverage here in Europe, I suggest you to fill a Support ticket asking for responsibilities and consider taking legal actions (though a consumer’s rights defense NGO) if you lost sensible or important data.

After more than a year with a Fairphone 2, justifying Fairphone mistakes (because we know launching a startup is hard) and taking part in the community, I’m no longer a Fairphone supporter but just a merely community friend. This is just inadmissible and undefensible, and I’m not angry now but truly sad.


Unfortunately, my feelings come close to Roboe’s. Currently, I do not have too much time to play around fixing my phone and am dependent on a working phone on which I can be reached. I’m still dealing with quite a few issues (GPS, battery life, random reboots, random screen freezes…), making every day usage quite challenging. I still believe in Fairphone and love what they’re all about, but some things are highly irritating. @Douwe this is a very serious bug, how come there’s no statement or at least official acknowledgement, yet? Is something happening? And why has this update not been removed or put on hold, yet? At the very least I’d expect an official warning so others make a full backup before upgrading!

I wrote my whole failed upgrade story in the other thread (e.g. failed last attempt) and it feels like Fairphone hasn’t even noticed there’s an issue. No I did not file a support ticket, I had my hopes up that the reports on backtracker were sufficient for something to happen… :expressionless:


Still nothing new on this problem and no reaction from the fairphone team ?
@Douwe ?

1 Like

Hey @Roboe and others,

Thank you for explaining this bug and helping each other in this topic. I was unaware of this untill @nicop91 tagged me in the last post.

Please be aware that this is a community forum. I try to read along with most threads, but can’t possibly read everything that goes on in this forum.

I have now forwarded this thread to a developer and as soon as I hear more, I will get back to you.



That’s weird @Douwe - I’m quite well aware how this forum works, that’s why I tagged you nearly a fortnight ago:

Nonetheless, thank you very much for looking into it! :slight_smile:

Hey @leVin42, I just saw that yeah. Somehow I missed that notification. Sorry about that. I guess ‘tagging’ me in a topic is not the best way to reach me. PM’s work better most of the time.

1 Like

I understand your part (and your job, I think), but the bug report —tagged as critical— has been overlooked for a month and a half in the official bugtracker.

It highly worries me that Teemu, the only Fairphone staff that replied to the bug report, has renamed it incorrectly today, and the update hasn’t been retired.

I switched to Lineage OS in the meantime.