Stuck in unusable OS 1.13.0 after switching from Open OS

I’ve been using Open OS and failed to update to Android 6 on several occasions. Therefore I wanted to try to go back from Open OS to the regular OS, update to Android 6 and then switch back to Open OS again. First I made a backup in TWRP and then I tried to switch OS.

Before switching I made a factory reset and had a fresh Open OS 17.04.0. From there going back through the Updater was not possible, as it didn’t show me any options to go back. Therefore, I downloaded the OTA Switcher file and flashed it in TWRP. After it was done TWRP asked me if I want to root the phone with SuperSU, which I denied.

Now I have a seemingly flawless working OS 1.13.0 and wanted to update to the latest OS 17.07.6 - however that’s not possible. If I use the updater (which I updated first to the latest version through the play store) it downloads the file and when I restart the installation gets aborted. I downloaded the file manually and tried to update from sd card, but the same dead android robot screen tells me that the process was aborted.

So now I’m stuck in what seems to be a fresh OS 1.13.0 and cannot do anything. I can’t update and I also can’t use my backup as there’s no TWRP from which I could load my backup files.

I saw that there’s a section on how to go back and it seems like I did it wrong. Method 1, however, did not work and Method 2 seems a bit too advanced for me as I have absolutely no clue how to run that adb sideload.

Can anyone help me out of my situation? How should I switch from Open OS to the regular OS and how could I load my TWRP backup in the first place?

https://forum.fairphone.com/t/howto-use-twrp-without-flashing-it-e-g-for-backup/23747?source_topic_id=31401
1 Like

Thanks a lot for your help @AnotherElk! As I have a Mac I followed this guide and then followed the Linux guide on the HowTo you posted and so far it seems to work fine! :slight_smile:

I’ll try to recover my backup and then give it another go with the fastboot method.

1 Like

I recovered my backup through TWRP with fastboot and it looks like it worked and if I’m back to Open OS 17.04.0. However, I just tried to boot into TWRP and instead my phone booted into the standard Android recovery screen. Am I in Open OS now and just ‘lost’ TWRP or am I in the normal OS looking like OpenOS?

Edit: I just checked the dev options and root is on. Also checked AdAway (needs root) and it seems to work. Therefore I guess I’m running Open OS, like the system tells me. It just seems that TWRP wasn’t recovered from the backup…

Settings - About phone - Build number should tell you that … if it has “gms” in it, it would be Fairphone OS (without “Open”).

That’s normal behaviour. If you have fastboot installed anyway, you can just flash TWRP again.

1 Like

There’s no ‘gms’ and it shows the correct version name of Open OS 17.04.0. I didn’t manage to flash TWRP, though. I have the app and followed the official guide but it didn’t work. The app asked me for superuser rights twice and in the end told me flashing to recovery was successful, but then I still end up in the normal Android system recovery screen. I tried it twice, both times same outcome.

I don’t know the App, I always flashed TWRP from my computer … As you have fastboot installed on your Mac now, you could do the same and follow the “Fastboot Install Method (No Root Required)” section of the TWRP page.

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.