Fairphone 5 : Camera app creating 0 bytes photos

For those of you (still) facing this issue, I solved it by reinstalling the default camera app using adb.

  1. Have a working ADB
  2. Find the correct package:
    adb shell pm list packages -f "camera"
  3. I transferred the APK it to my local pc (but this turned out to be unneccessary, as the APK remains on the device when uninstalling the app)
    adb pull /system/priv-app/FPCamera/FPCamera.apk
  4. Uninstall the current app:
    adb shell pm uninstall --user 0 com.fp5.camera
  5. (Re)install the app:
    adb shell cmd package install-existing com.fp5.camera
  6. Enjoy a perfect stock camera experience :grinning:
2 Likes

It’s a great workaround! But to truly mark it as fixed a solution must come in the form of a FP camera update :slight_smile: Regular users won’t implement this solution.

1 Like

True, perhaps we should call it a ‘community solution’ for now :wink:
It looks like the original installation of the stock Camera app was incomplete or partially corrupt (as of yet with unknown cause).
I have added this information to the Support ticket, hopefully they are able to somehow correct it from the Camera app itself (or trigger a reinstall during a patch/upgrade of FPOS).

2 Likes

What is called a workaround🙃

Havent ever faced that so there might be other things adding to it…

1 Like

I have the same problem. Did you ever get any further updates on the support ticket?

So far, the updates from support were:

  • A request to test the issue in Safe mode (where the problem also occurs)

  • An update that they have forwarded this internally:

…To help you further with your request, I will need to ask for advice from the relevant department. As soon as we have an update, we will get back to you…

That was a week ago and it triggered me to try a reinstall through ADB later that day.
Immediately after confirming that this ''workaround" fixes the problem, I updated the ticket with these results, but there has not been any response on that message so far.

The workaround works perfectly and fixed the issue, thank you very much.
Also had a support ticket for this and they actually suggest your post now as workaround (besides factory reset…) They also commented that this is a low priority issue and could take a couple months to get fixed via normal update.

Additional links for anyone who needs help with establishing the adb connection with the phone via windows etc.

Full guide:
https://www.xda-developers.com/install-adb-windows-macos-linux/

Step 2-5:

1 Like

Hi all, just received my F5. When I take a picture, the camera starts ‘processing’, but doesn’t finish.l this. Sometimes the picture taken is visible as a thumbnail, but most of the time it isn’t.

As a result, I cannot take pictures and cannot share them.

I have installed the latest Fairphone OS (141), but the problem still occurs.

Please advice.

Regards, René

Hi René,

The symptom you describe, especially regarding the thumbnails, sounds like the one I experienced here: Fairphone 5 : Camera app creating 0 bytes photos

Do you notice the other symptoms described in that topic as well or is your situation different?

Hi Johan, I had exactly the same experiences.

That post and your replies triggered me however to install another camera-app and the problem was gone. I’m not that technical to implement your in-depth solution.

Now I’m just looking for the best free camera-app (I don’t know if the pre-installed app is ‘a good one’).

Regards,

René

As you confirmed its the same issue, i moved the posts over here.

Hi,
same problem and the workaround fixed it, many thanks
:slight_smile:

I have the same problem! Is there an “official” Fairphone solution without using the workaround?

Has anyone ever contacted Fairphone about this? If not they cant work on a fix

Yes, as response to my support ticket, support wrote back the following:

We highly appreciate your feedback and the details shared of your investigation to find this workaround. We will share your workaround with users experiencing the same issue

Then the ticket was closed, so no indication whether they are working on a permanent/automatic fix.
I agree, it is an excellent idea if the people affected by this issue log a ticket with Support (referencing this topic should be enough), especially those for whom the ADB workaround is too complex to perform.

I experienced the same problem. I came to the solution to install “Open Camera”, which works like it should.