Fairphone 5 : Camera app creating 0 bytes photos

I recently bought a Fairphone 5 phone and have set it up.

I found some bugs (which have already been reported on this forum).
But also another one regarding the Camera app.

When I take a picture using the Camera app, the icon in the left bottom corner indeed shows an icon of the picture I just took. However, when I click on it I have a black page with a loading icon at the middle of it.
When I go on Google Photos, I see a grey image, which is 0 bytes according to the details.

First, I noticed that rebooting the device allows me to access the images via Google Photos, along with these 0-bytes pictures which are still here.

After more troubleshooting, I found that, when taking a picture with the Camera App:

  • an empty picture of 0 bytes is created in the “DCIM” folder
  • the original picture is stored in the “DCIM/Camera” folder

For sure, Google Photos app thinks that the camera folder is “DCIM” and not “DCIM/Camera” because it auto-detects the empty file. But I didn’t found a way to tell Google Photos to use a different location for the Camera folder. I didn’t found either a way to change the folder used by the Camera app.

Does anyone experience the same issue?
Any idea on how this could be solved?

I’ll be happy to provide more details if needed.
Thank you by advance.


1 Like


For your information I have reproduced the steps on the same FP5 phone under the “Guest” account, and I don’t have this strange behavior.
With Guest account, a picture is created in “DCIM/Camera” folder, and no empty image inside “DCIM” root folder.

Thanks by advance for your feedback on this.

Did you set it up from scratch or did you use a backup of your old phone?

Hi Incanus and thanks for your reply,

I think I set it up from scratch.
I was given the opportunity to import things from my old device. I imported the apps but didn’t import the configuration.

I hope this helps.
If you need more information feel free to ask.

This is quite contradictory, because if you had set up the system from scratch, you would not have imported anything. :wink: .
Maybe it’s a setting, that worked differently on your old phone, that generates this behavior now.

I was not sure what you meant by “setting up from scratch”.
That’s why I prepended my sentence by “I think” :wink:

However, I did not import settings from my old phone. Only apps.
Do you have any idea which particular setting (or group of settings) could be in cause? Or any method I could use to reset all settings without resetting all the apps’ data and configured accounts?


if you have microsd card, then maybe try in Camera Settings switch Storage to sdcard and back to internal (for sure between close/reopen Camera app)

BTW: i imported to FP5 from previous (Motorola with Android12) all settings, data, apps… a not have this problem

I have the same problem. Don’t know why some Fotos are saved to Camera and others to DCIM. I don’t have an SD card and transfered all data and apps from my oneplus3 phone.

I have The Same Problems!

When i do a restart, then i see The Pictures in Google Fotos and 0 byte files there!

Could it be a problem with the Google Foto app? Possibly because the data transfer was somehow not complete? The app only does a Sicherung when I reboot the phone. When I look in the app under the account it says it is preparing a Sicherung, but the process button on the left just blinks and shows no progress.

Kann man die Kamera-App neu installieren?

Offensichtlich nicht, weil ich es nicht deinstallieren kann. Ich habe gerade in Google play store ein update getipoedvabervdas hatte leider keine Auswirkung. Kann es irgendwie daran liegen, dass mein altes Handy komplett ausgeschaltet ist? Muss ich mal versuchen, wenn ich wieder zu Hause bin.


What is “Sicherung” exactly?

From what I understand, the Google Photo app auto-detects the location where pictures are stored. Because there is a zero-byte picture in “DCIM” folder, it may detect that the Camera folder is “DCIM” and not “DCIM/Camera”. Also, photos are not uploaded to Google Photos until reboot, because they are not detected. Only the 0-byte image is detected, and not uploaded because there is nothing really to upload. But I am not 100% sure of this, it’s only my interpretation of things.

What I am sure of however, it is that just after taking a photo, if I want to see the photo (clicking on the icon in the left bottom border), I get a black loading screen. That’s why I though it was more related to Camera App rather than Google Photos.

For your information, I tried to clear data & cache of both Camera and Google Photos, I still have the same issue. I think that it is not possible to reinstall Camera app, at least via the Settings app. Maybe someone else knows a way to do it?


Sorry, Sicherung is German for backup. Yeah, I tried all the things you did too and still have the same issues. I was just thinking that if I turn my old phone on again, maybe that would activate the auto back up again, but I’m not home right now, so that’ll have to wait until this afternoon.


Aha, it must be the camera app. I just downloaded a different camera app and it works just like it should. You can see the picture right away and the picture appears in Google Fotos. And the problem with the continuously “preparing backup” is gone.

I don’t know if the problem was created because of the data transfer from the old phone but if I just use the new camera app, then it looks like that solves the problem for me.

1 Like

Hi Lonlon, thanks for sharing your feedback!

For reference, which new Camera app did you use?

Maybe I will find the time to completely reinstall my phone (which should solve the problem or help me locate which parameter did induce this behavior), otherwise I will use your solution.


It’s called Camera for Android by Litter Penguin. I don’t have a good eye for Fotos so I’m not much of a judge for the quality ,but it seems to work for me, although I’ve only taken a few pics to try out if the problem was solved.

My father has the same problem. Strangely I don’t have it on my phone. We have the same version of the camera app. Other camera apps like Open camera work without any problems for him.

Same issue here: after taking a picture, the correct thumbnail appears in the bottom left, but trying to open it links to a 0 byte file in DCIM, so the photo is not shown. Google Photos only shows the 0 byte file and tries to create a backup forever (because it cannot backup an empty file).
In file manager, both the 0 byte file is shown (in DCIM), as well as the real picture in the Camera subfolder.

After a reboot of the phone, both file are shown in Google Photos. The correct one is backed up, the 0 byte one still fails.

I have tried force close + delete cache + delete data for both the Camera app and Google Photos. Unfortunately that didn’t help.

Version of the Camera app: v6.00.04.0037.47.0