Fairphone 3 stuck in bootloop - data recovery options?


I had LineageOS 19.1 running up until recently on my FP3, but it went into a bootloop shortly after an update. Does anyone have any experience recovering the data in siturations like this?


Do you have Google Play Services installed? We have a known problem that a faulty Google Play Services update causes reboot loops. Uninstalling Google Play Services (or installing an old version) might help.


And yes had google play installed. Not backed up to google servers tho, so want to try and recover from phone.

Hello Robin2
To be honest, the answer is likely “no chance”.
I am far away from being an expert on this, however by personal experience I found, that boot loops most often happened to me, by a failure in accessing the data partition. This happens for instance, when you install (not update) a new OS and therefore loose the key for the encrypted data partition. In such cases you have to format the data partition.
If this not the case here, I believe, you need at least:

  • Ability to stop the loop and then boot into recovery mode by pressing Volume Up + Power while starting again. Try this. If this is possible, you may be on a good way.
  • You should have enable developer options and (hopefully) remote debugging after you installed LOS. Did you?

If both is true, you should be able to “adb pull” your data.
If not, I am pretty sure, this means: No access to your LOS system, no access to the encryption key, no access to your data.

Pls dont blame me for adding this: In 1990, I played my first computer game “Hero’s Quest”.
I died within minutes and a message popped up, that teached me for life:
Save early, save often!

Let me add:
Modern phones have two slots (a, b) of identical partitions for the OS.
Updating one, does not touch the second.
I do not really understand the mechanism behind that.
May be, if you can boot into bootloader instead of recovery, you can switch to the previous installation (before your update).
However, it is far beyond my knowledge, to give you instructions on this.
May be, https://forum.xda-developers.com/ is a good place for such a problem

This would mean changing the slot which is only possible when the bootloader is unlocked, however its worse a try. So find out which is the active slot and then via fastboot change the slot

Reg. going back to previous version by changing slots, here a discussion

Overall, before changing slots etc I would have a look if for some reason the faulty GPlayServices update also causes issues when LOS is used, i.e. deinstall the GPlayServies updates in the App. More information in the topic linked above by TobiasF or does is not boot at all into system?

Just to clarify, Rollback Protection isn’t active while the bootloader is unlocked, so this doesn’t apply here.
(Didn’t know that at the time I wrote that post)

1 Like

Just to clarify, Rollback Protection isn’t active while the bootloader is unlocked, so this doesn’t apply here.

I do not think that an open bootloader prevents Rollback Protection to kick in. I have tried a rollback on my FP3 with unlocked bootloader to no avail. See the whole discussion there.

That depends on which features of AvB are still active while the bootloader is in an unlocked state, from the docs:

Slots that are rejected in the LOCKED state might not be rejected in the UNLOCKED state, (e.g. when UNLOCKED any key can be used and rollback index failures are allowed)

If the device is UNLOCKED, there is no requirement to check the key used to sign the OS nor is there any requirement to check or update rollback stored_rollback_index[n] on the device.

I know absolutely nothing about the FP3 bootloader (and the situation isn’t a lot clearer for the FP4), in doubt, you’ll have to #contactsupport and ask them how this is implemented. The bootloader is proprietary, so only Fairphone / the devs know how it’s set up exactly.

Thanks all. @derbaertigefrytz yes I can get into recovery mode, and I did enable developer options before it was in bootloop. I tried adb pull but zero files were pulled from sdcard, unless I should have been pulling from somewhere else?

Looking through the others posts it doesn’t look like I can recover user data. I’ve tried a data recovery company and they have drawn a blank so might have to leave it there.

Hi Robin,

Looks like I stumbled on the same problem as you today but was more lucky: I was able to reinstall the latest update via adb sideload , without data loss:

1 Like

Hi Nicoolas,

Thanks for flagging this - I will read through all the posts and give it another try to see if it works!

In a nutshell though it sounds like you installed fresh onto the other slot, didn’t factory reset, then you could access your data? How do you access your data once installed on the other slot? Do you have to use data recovery software on the fresh install, or is the data just there on the phone already when you first start up?



No I very simply installed the same update + GApps with the adb sideload command, so I suppose it has just overridden the previous install, on the same slot. The data was just there after reboot.

maybe you could revert to the slot that was active when the update failed, and try the adb sideload command.

The A/B slot system is only in place for system and OS partitions, the data partition (holding user data) is shared.
Regardless which OS slot gets booted, the data partition will be the same, as there’s only one.

Usually this just works as intended and users will not notice much of it.
It gets more complicated when something somehow fails to work as intended. For instance there’s a mechanism in place which should automatically revert to the formerly active slot if the freshly updated OS slot immediately fails to boot several times, and for instance the installed OS upon boot determines whether it likes the state the data partition is in and is willing to work with it as is (if not, presenting the somewhat notorious “Try again” / “Factory data reset” choice).

1 Like

Thanks - finally had a chance to try this. I can get to recovery and reinstall but sadly still stuck in the bootloop. Is it worth trying the other slot?

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.