FP4: is it possible to downgrade to previous OS version with A/B slots?

To see if one bug was already resolved or still present in the previous FP-OS version, I was just curious of downgrading my FP4, just by switching between A/B slots. (I don’t want to do a factory reset nor a fresh install!)

I got the current slot (b) with fastboot getvar current-slot and then fastboot --set-active=a and fastboot reboot but then I was stuck in a bootloop :frowning:

After typing fastboot --set-active=b all was back to normal :slight_smile:

My question: is this bootloop an expected behaviour? or it should have booted to previous version?

I wouldn’t be too optimistic.
I can’t say anything about the Fairphone 4. I can only say that on the Fairphone 3 this worked for me in initial testing, until later users in Custom ROM territory reported that it didn’t, and Fairphone had this to say when the question arose because of a particular update … Software Update: 3.A.0129.20210805 (unknown caller and zero brightness bugs) - #433 by rae.

Perhaps @ray could bring some clarity for the Fairphone 4?


As far as I know a downgrade is only possible automatically if something went wrong during an OTA update. Once the updated system boots successfully Rollback-Protection kicks in and the old slot is no longer bootable.

I have tried multiple times under different circumstances and so far haven’t been able to go back to a previous version.

Edit: The thread @AnotherElk linked already mentions rollback protection, should have looked first, so nothing new here…


Ok thanks to both of you!
Indeed, the rollback-protection is certainly the cause of the above-mentioned behaviour :slight_smile:

EDIT: similarly it prevents to “fastboot boot” from an older boot.img.

1 Like

Hmm, fastboot boot A.067-boot.img still works just fine for me (on A.099) :thinking:
Only takes ages to boot…

Yes, I agree that it looks like rollback-protection is making the idea impossible.
What I tried:
System startng /e/OS successfully from slot b. I’ve flashed the same /e/OS version (only uncritical partitions) onto slot a (didn’t touch slot b at all). After starting successfully from slot a this did always work, but trying to start from slot b was noch longer possible (bootloop).

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.