Fairphone 3 Hotspot

Hello everyone!

I recently purchased a Fairphone 3 and I’ve been testing it and I’ve noticed the Hotspot doesn’t work at all.

I’ve tried to tether three different mobiles to it, and two different laptops.

Any tips/tricks or is this a known issue?

I’ve reset network settings and further reset the entire phone to factory settings.

Many thanks,
Luke!

What kind of “input” signal are you trying to spread through your FP3 to the other devices? Mobile data?

1 Like

Hi @urs_lesse, thank you for the quick response.

Yes, mobile data.

1 Like

Thanks for the clarification, I mainly wanted to make sure. Sorry, cannot provide any experience of my own now.

No problem.

Hopefully someone within the community can shed some light.

I’m interested to know if this is a known problem with the FP3 or if my device is faulty.

1 Like

how is ist not working?
can you establish the hotspot-wifi-connection to your FP3?

I also have that problem with FP3 - my PC is connected to my phone’s hotspot, but “no internet”. I found this post, which points to a solution, though one that seems to require a bit of time to implement - Hotspot but no internet on Vodafone UK (pay monthly)

Yes, I am able to establish a connection, however it doesn’t appear to transmit a data connection to the device I’m tethering to.

Thank you, it is a Vodafone SIM i’m using, but I followed this and it doesn’t seem to still beworking.

Oh :confused:

Thanks for the feedback!

No problem here with my FP3. I am sending this reply through my mobile hotspot.

hotspot

Deutsche Telekom SIM Card, MagentaMobil M contract.

3 Likes

I’m the author of that post.

I’d like to encourage you to try it, though. Eventually I didn’t think it took me much time, in particular not in comparison with the time and effort it had taken me to ‘diagnose’ the problem. Just some additional pointers to the (excellent) instructions as in that post I referred to (“https://support.google.com/nexus/forum/AAAANseOu18DRVyGHFAdjA/?hl=en&gpf=%23!topic%2Fnexus%2FDRVyGHFAdjA”) below.

On the cited page “https://developer.android.com/sdk/installing/index.html?pkg=tools” I pressed the “DOWNLOAD ANDROID STUDIO” button, then left settings as default.

I used Android Studio – I didn’t try the solution using “Minimal ADB” as suggested on “Mobile hotspot issue : no more internet connection” as an alternative.

The Android Studio Setup Wizard “Downloading Components” prompt also showed the location of the “sdk\platform-tools folder inside the Android development kit folder”: “C:\Users<username>\AppData\Local\Android\Sdk\platform-tools” in my case (Windows 10 Home).

When using the shell, first time around I wasn’t aware that I had to confirm something on the phone – the error message I got said “Otherwise check for a confirmation dialog on your device” and indeed this confirmation dialog turned out to be there (i.e., on the FP3).

Also, I assumed that “Hook up your phone to the computer” as in the cited post meant ‘try and connect to PC from phone using hotspot functionality’, and that “$ exit” meant “quit[ting] the android development kit” and indeed this seemed to work.

As another note, at some point I thought that the problem I encountered might have been due to Vodafone UK not allowing tethering/hotspot, but I haven’t found any indication that this is the case so I still think that the described ‘hack’ is a fine solution.

3 Likes

Thanks, I’ll give it a try!

And yes, I don’t think it has anything to do with Vodafone - my previous phone (a FP2) had no problem with hotspots.

I had a similar problem when I moved from FP2 to FP3 (France, Bouygues telecom). the phone could talk to the internet, devices could make wifi connections to the phone, but devices couldn’t talk to the internet. looked like a NAT problem. However it’s all been working OK since the last Fairphone update.

1 Like

Was that the December update?

Phone says I’m running Android 9 with “Security patch level 5 January 2020”

It works fine on my FP3. I have a German Tchib SIM card.

FYI this is still not working for us.

huh, that’s strange. Mine says security patch level 5 Dec, and yet can’t find any new updates. I wonder how that works…

Hi everyone. I cannot activate my Wifi “zone” / hotspot as hiting the on/off icon does nothing. Any ideas on what may be causing this?