Mobile hotspot issue : no more internet connection

Hi there,

I can’t share my mobile connection with my laptop anymore : the Wi-Fi works fine but I keep having a “limited” access with no internet connection.

I have tried to use my SIM in another phone : works fine.
Another SIM in my FP2 : same issue.
Tested with 2 different computers and still doesn’t work.

Data is activated, 4G working, I can’t figure out what the problem might be… Hardware issue ?

Any help would be much appreciated, thanks :wink:


You didn’t install by chance a firewall like “net guard” or similar (as this might block the connection)?

No, I only use Avira AV and the Windows firewall. I had the same thought so I briefly disabled the FW => same.

As I said, it works fine with my SIM card in another phone, so I guess my laptop is not to blame ?

By the way I had no problem when I last used it 1 month ago. The problem appeared recently.



I meant a firewall on your phone. I also don’t blame your PC as you had written that you had exchanged it with another device.

1 Like

Or did you disable some preinstalled Google apps or services? Maybe one of them in necessary to use this function.

No I didn’t…

Still getting this “DNS PROBE FINISHED NO INTERNET” error message whenever I try to load a web page…

I guess I’ll have to reset my FP2. Am I the only one with this issue ?



Here you might find a solution:

Thank you Irina, already tried this method, doesn’t work either…

I finally made a factory reset this morning, because I wondered if the data encryption might have been a part of the problem => still the same, always stuck with this DNS issue.

Should I consider returning my FP2 ? Looks like the tethering function isn’t working anymore…

I don’t think it’s a hardware issue, since the wifi hotspot somehow seems to work, if your laptop can access the phone.

So I think it’s some security setting or an APN setting that changed.

What happens if you set the hotspot security to “none”? (Maybe you have to allow your PC to connect to unsecure wifis first.)

Have a look at your APN settings. Is there a DNS server defined? If yes, what happens if you delete this entry?
Or make a screenshot of the APN settings of the other phone when your SIM is inserted and compare it with the APN settings of your FP2.

No server defined. Never had to. No security doesn’t make any difference.

The curious thing is that my 4G connexion is fine, I guess I couldn’t have any internet if there was a problem with my APN parameters, right ?

You’re right, but I thought that maybe your provider’s DNS wouldn’t allow your laptop to use the internet connection. Some providers don’t allow the usage of mobile data with computers and some actually block it. I’m sorry, it’s all wild guesses…

On your notebook:
if you type
ipconfig -all
in a cmd window then for your wireless adapter you should see same IP for gateway, DHCP-server and DNS-server and it should all be IP of your phone as hot spot.
What happens if you try to reach that IP via “ping”? (in my case it’s, so command would be “ping”)
Are you able to reach internet through hotspot without DNS (i.e. e.g. “ping”)?

And just to be sure: you don’t use a " VPN" config on you phone, right? You can see a VPN by this white key symbol in the top right corner:
(because for me hot spot does not work while VPN is enabled)

Ping works for, not for
Here is a screenshot :

And no, I don’t use a VPN.

And if you do a
(in cmd window) is the first step (hop) the

1 Like

Hi Nicolas,

I have the exact same problem, just slightly extended: Internet tethering does not work with any of the options (Hotspot, Blutooth, via USB cable), with no device (Tablet, Mac, Windows). All devices connect to the hotspot fine, but do not get Internet access.
Internet on the phone works fine (4G), tethering worked fine on FP 1 with same SIM.

I did have some apps installed that might have potentially messed with some settings, but they are all uninstalled now. Would be nice to know where these settings potentially could be and how they could be reset without a factory reset.

I would also appreciate any help very much, as I use (well, used to use…) this feature pretty often…


Hi Volker,
I tried the same suggestions - same result. Ping works, doesn’t. tracert results in 3 ms for the first hop, request timeout for all following. But I have no idea what that tells me… - hopefully you might have?


If the first hop you see is
then it shows for sure that the data packets travel out of your end device (eg notebook) and travel through your phone but are blocked then there.
If the phone has really internet connection at the same time then I can only imagine any app stopping this traffic (as hotspot mode works fine for me so I can’t see a general problem on the phone).

Hi Daniel,

We have the same problem actually : wi-fi connection is fine, Internet is not. Used to work with my FP1 but also with my FP2…

@Volker : could have been an app related issue but I did a factory reset and then tested tethering prior to reinstalling my apps, and it didn’t do the trick…

Tracert : yes, first hop is, and then time-out for the next 29 hops.

No, I just got my phone a few days ago and have the same problem

I just found a solution to our common problem, hope it works for you as well. Apparently not only FP related. I followed the guideline here:!topic/nexus/DRVyGHFAdjA (it’s about Nexus), which worked fine. Got my tethering back, both WiFi and USB (haven’t checked Blutooth). You might want to use “Minimal ADB” from XDA developers instead of downloading the entire SDK as suggested in the original post. “Minimal ADB” worked fine for me.

So, 2 of my 3 major FP2 problems solved today - now I lack a solution to my Blutooth problems, but that’ll have to wait for another day.

Good luck!