Fairphone 2 - Updater not working

When I start my fairphone updater app, it tells me that this app is only a System app and it happens nothing more. No update.??
Does anybody know this Problem??


#moderators info: This issue is also discussed in German here.

Possible solution there: Wiping cache in #dic:recoverymode.

3 Likes

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.

I just had the “This app only works as a system app” issue and previously posted solutions didn’t work for me so I’m updating this very old topic in case someone else might run into this before upgrading to Android 7.
I had this issue on an #austrianfairphoners demo phone. The updater app crashed every time I tried to open it with above error message.

What I tried and didn’t work:

  • clearing the app’s data, updating or de/reactivating the updater -> no effect
  • clearing system cache -> TWRP couldn’t mount cache partition
  • reinstalling the OS via fastboot script -> no effect
  • reinstalling the OS via TWRP -> no effect
  • upgrading to the beta version of Android 7 via fastboot script -> phone couldn’t boot anymore.
  • wiping everything via TWRP (format data & advanced wipe) and then reinstalling -> no effect
  • factory data reset from within the OS -> tapping the button showed a popup for a fraction of a second but then nothing happened.

So what I finally did which fixed the issue for me:

  • TWRP -> Wipe -> Advanced Wipe -> System Partition -> Repair or Change File System -> Change File System -> EXT4
    • repeat with Data and then Cache partitions.
  • reinstall the OS
  • Updater app worked and I could upgrade. :slight_smile:
3 Likes