Fairphone 2 update to android 9 didn't work - why is doing a manual update such a 'roulette'?


I have for a couple of years a Fairphone 2. I kept it on Android 7 for quite a while, but today I’ve decided to go for Android 9.
The automatic update failed (I want to keep this message short, so I won’t put the details here). So I had to do a manual update. It took a while to understand how to do this, and to get the connection between my windows computer the links in Fairphone 2 Android Update failed, phone broken now - #20 by Saphira were very helpful. Thanks!

But when I run the flash-for-windows.bat for version 21.12.0 I get the following error:

The error message says to try it all over again. I have done this, but I then keep getting the same error, but at different places during the update. I have already ran it for at least 20 times. I’ve only kept account where it crashed after a while. Score until now is that it:

  • crashed 2 times while writing ‘system 2/4’
  • crashed 4 times while writing ‘system 3/4’
  • crashed 7 times while writing ‘modem’.

And after each crash I have to remove the battery (to turn the FP2 off), remove the USB cable, restart the phone in fastboot, connect the USB cable and start over again.

So what do I know:

  • recovery mode on my phone doesn’t work: it gives a picture of a ‘dead’ android with a red triangle.
  • the FP2 is in fastboot mode, because I see the blue flashing LED
  • the connection between the windows laptop and the FP2 works as well (because when it didn’t I got an error before reaching this step of the batch file)
  • the images have been unzipped on my computer
  • it seems to manage to flash a couple of files, but not all of them
  • In Manual reboot FP2 failed I’ve found someone with a very similar error, but that whas when updating to version 21.03.0
  • I get the same error when I try to manually flash an older version of android (I’ve tried 19.11.2)

Why is this such a ‘roulette’? Is there a bad connection somewhere? I’ve tried cleaning up the connections in my FP2, but I don’t see any improvement.

I keep trying to flash the image, hoping that eventually it will reach the end. If it doesn’t work, what should I do?

Thanks in advance!

I should have written this post earlier, because finally it seems that flashing did work. Took at least 25 tries, if not more. As written above I haven’t started counting in which file the flashing stopped only after a while. But the score after that were:

  • 2 crashes during system 2/4
  • 4 crashes during system 3/4
  • 2 crashes during system 4/4
  • 10 crashes during modem

Is it my phone that flashing took so long? Or is there another reason?


This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.