Fairphone 2 Android Update failed, phone broken now

I tried to update to Android 9 using the updater app.
Update started, lots of restarts and finally endless loop restart - “no command” - restart again. Image with “dead” Android man lying on the ground and text “No command” on the screen.
What I tried:

Manual Update, bootloader
Manual Update as described in Manually install Fairphone OS for the Fairphone 2 – Support
Power On/Volume down seems to get in bootloader (fastboot) mode (blue LED flashing) but flash-for-windows.bat says “no device found in fastboot mode” and fastboot devices shows no device (FP2 is connected with USB)

Power On/Volume up twice gets me in boot menu. I can choose for adp, but the only possible mode here is sideload.
I tried to install different Fairphone and /e/ images (from Fairphone OS downloads for Fairphone 2 – Support and /e/ documentation | Welcome to /e/ documentation! Download, install and compile /e/OS for your android smartphone Main website Community forums) with adb sideload [name].zip, but in all cases I get two errors: “footer is wrong” and “signature verification error”. According to the /e/ documentation I should install TWRP to avoid that, but that is impossible because bootloader does not work. “adb reboot bootloader” also gets me to the mode with flashing blue LED and “fastboot device” empty.
I used fastboot both from the Fairphone installer and also from a fresh install (version 31.0.2), same result.

SD Card
Boot menu also allows me to “apply update from SD card”. So I copied the zip-files to the SD card but got the same “footer is wrong” and “signature verification failed” as with ADB sideload.

Factory Reset
Last option was a factory reset, allowing to wipe the data. Since I have a backup this is not a big problem to me. But it dit not help. My FP2 still is not booting (endless boot loop “no command”)

Anybody any idea to get out of this?


Are you sure you’re using a USB data cable and not just a charging cable?

Yes, I am sure. adb sideload sent a 800MB image to the phone, this would not be possible with a charging cable. And yes, I did try with 3 different cables.

That seems to be a frequent problem with windows drivers.

If you haven’t seen it already, here is a HOWTO:


Thank you so much!
This helped me out, my Fairphone works perfectly again now.
The underlying reason was not in the Fairphone itself but an outdated Windows driver - although the Fairphone update proces could give a more userfriendly error message with the hint how to update that Windows driver instead of just letting the phone reboot endlessly.
Let’s hope others with the same problem will find this post and this perfect solution.


For the sake of others coming here with the same problem:
The factory reset I did was not necessary, If I would have applied Ingo’s solution directly I would have had no loss of data.


I am experiencing exactly the same problem. Only I tried multiple combination of keys to get into de menu to reboot or follow the instructions that were send here. But I only get the starting screen with Fairphone powered by android and after again the no command screen.
I also tried to take the battery out and put it in again and tried again. without result.
Anyone who can help me?
Or does this mean it definitely crashed?

1 Like

There are two different options:
Boot menu and Bootloader
For both, first turn the phone off (take battery out for some seconds if off-button does not work)
For boot menu:
Press and hold on-button, a split second later also press volume up and hold both pressed until you feel the vibration (1-2 seconds later). From the screen where you get now, press on button again an hold pressed, then press volume up short and release again. You are in the menu now. Use volume up/down to scroll and on to choose.
For bootloader:
Press and hold on-button, a split second later also press volume down and hold both pressed until you feel 3 times the vibration and the blue LED lights. It can take some seconds (up to 5). Then release the buttons. You are in the bootloader but you do not see anything - you can connect your computer now with a USB cable and operate from there, for instance with the fastboot tool.


Thanx a lot for the help! I came further now. Only when I use the bootloader I can’t find the right driver update in the list. It looks like all the driver updates are for my computer since they all start with acer or intel. When I go in settings to devices it says also which devices it detects and it says Android and below it driver program not available. Does this mean I can’t do anything anymore?

Since my FP2 is already 5 years old I was doubting to buy the FP3 because it’s already really slow and also I had some problems with the microphone. I waited for the update to see if this would solve some problems. But now I am thinking I better buy the FP3 :-).

Please do not throw away your FP2, it works perfectly after you will have solved the software-problems.
Did you follow the basic instructions here: Manually install Fairphone OS for the Fairphone 2 – Support ?
If you did, you started the script flash-for-windows
It either worked (than you are ready), or you got a message that it could not connect to the phone.
In that case, the script recommends to use the command “fastboot device” (on a command line in the right directory). If you do not see your Fairphone listed than, you may have the problem of outdated driver which you can solve using the detailed steps in the post of Ingo.


Since the driver problem is a problem of the Windows computer and not of the Fairphone, it may help to use a different computer for that purpose.

1 Like

Thanx for this advice. I am going to try this evening. Hoping it will work out!


Hello Dirk 2
I also own an FP2 and they have promised me that by the end of April an update will be available. Reading what you wrote I’m afraid the same thing will happen to me. I have read the different responses that users have given you; but I don’t see how you went about restarting it in the end. can you describe to me exactly how you did it?
thank you in advance

In almost all the cases an update to Android 9 is as simple as clicking on “Yes” when you are asked if you want to update. What is discussed in this post are the rare exceptions when it does not work as intended.
I have no inside knownledge, but I could imagine the very reason why the distributing of the update is prolonged may be the reports about problems like mine, so the Fairphone developers are now working overtime to make that process even saver now.
Only in the rare cases something goes wrong you need the information about how to deal with it. So what could go wrong?

  1. Outdated updater app
    People reported that they had to update first the updater app itself, otherwise it would not find the Android update.
  2. Endless restarting
    Some restarting while updating is normal, so don’t panic too fast and give your phone the time it needs. But if it takes more than some hours and stays restarting all the time, your update is broken. In that case, you can go back to the previous Android version without data loss using these instructions: Manually install Fairphone OS for the Fairphone 2 – Support
  3. Even manual installation fails
    In my very case even the manual installation failed because I had an outdated Windows driver. Ingo helped out in post 4 and pointed to these instructions how to overcome this: [HOWTO] Fairphone 3/3+ stuck in fastboot/bootloader mode with the Easy Installer on Windows - HOWTOs - /e/ community

But summarizing: good to know how to fix problems when they happen, but keep in mind that these cases are rare. The vast majority of Fairphone users will not have to deal with this and just run the automated update process without problems.


Thank you very much dirk 2 for this information. I hope every thing will be ok.

I got to this point as well, but the flash for windows thing couldn’t detect my phone, although the blue LED light was flashing and I’ve got a USB data cable and no drivers to update - any ideas on what to try next please?

Interesting to read this. I don’t have a Windows computer having defenstrated for good in 99 and switched to Linux. The staged rollout hasn’t reached me yet but there really should be an easy option for those who choose open source as well.

What do you mean? Manually installing an update for a Fairphone can be done on linux, too. And you’re unlikely to run into the driver problem so many Windows users complain about.


Hi AnBoo
I had the same problem as you and found a solution :star_struck:
My PC did not find the correct driver either. So I downloaded the Android USB driver here:

and then followed the steps 1.-14. in this tutorial:

Then I was able to perform the manual update as linked in the first message from dirk2.

I hope that works for you too.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.