Fairphone 2 unusable while charging

I have seen a comment from a user on this forum that received a replacement phone from Fairphone, and only one of them (I don’t recall if it was the new one or the old one) had this problem. So it appears that this problem doesn’t occur on all phones.

It occurs on my phone though, much to my chagrin. It would be good to test replacing the bottom module and see if that fixes this issue. Anybody willing to sacrifice € 20 for science?

Well, of course there are no randomized double-blind studies yet, but I think it’s save to say that there is about a 99% correlation with the used charging equipment (charger, cable, plug) when it comes to this issue.
I wouldn’t invest in a study that tries to determine how much of the last 1% is related to the bottom module.

2 Likes

I find my touchscreen stops working or is very glitchy if I’m charging my phone. Will try the “My display / screen is not working properly” help page and see if that works!

I moved your post here as the topic you posted in was a different issue. You need to try other/better cables/chargers. Here is a list of chargers reported as working by the community:

Thanks - I don’t quite understand how a new cable will stop my Fairphone’s screen from being non-responsive while the phone is charging, but will give that a go!

Bad charging equipment causes static which causes the touch function to malfunction.

1 Like

I think Anker is really overrated.
I bought a charger and cable from them, thinking that for the price I would be rid of problems…

Now I still have the unresponsive screen, and after few weeks the cable is losing contact.
I can even feel the static when touching the end of the cable…
I am strongly dissatisfied.

Does someone know a really serious charger brand ?

1 Like

My Anker charger and cable still works properly. No unresponsive screen, no loose contact.

1 Like

I have an Anker 2-port charger, it produces a lot of static… Maybe it is defective ?

Just bought a Anker 24W 2-Port USB Ladegerät mit PowerIQ and it dont work. Plug in display unusable plug off normal use.

2 Likes

I have an Anker 4-port charger and it often causes lockups with my FP2. It has been rocksolid on all other devices that I ever used it for, though.

3 Likes

I am on version 1.9.3 and got FP2 today. If the phone is plugged to power, the touch function of the display freezes shortly while using it. Pressing the power button twice (first to lock the phone and second to bring it up again; the display needs to be completely dark before unlocking) makes the touch working again after it freezes again shortly.

It is really strange, that this problem is only present while plugged to power and loading the battery.

This should be fixed otherwise this is unusable.

I am not sure if this is related to your problem.

In this tread you can find a lot of useful information on this issue.
Please also read earlier posts above.

Most probably it is related to your charger model. I guess if plugged into your computer for charging the phone is behaving correct?

It looks like you will have to get another charger.

Yes, I have tested with 4 different chargers. Only a very old one from Sony seems to work. I had a look into the userlist, they mentioned the 2-Port-Anker (24W) I have, which had the worst issues of all chargers I have tried with, it should be removed from the list.

Also not working is my Motorola-charger. While phone keeps being responsive the charger-LED turns off and on again random several times a minute.

But, is it possible, that the Anker would work with a different cable? I have tried it only with the cable it shipped with.

Looks like the Motorola charger cannot deliver constantly enough current. Many chargers are rated to deliver up 1 amp of current, which must not necessarily mean permanently full 1000mAh.
FP2 can draw up to 1300mAh depending on battery state.
Also a proper cable of decent quality should be used. Try different ones on one charger maybe to see different results.

Standard usb cables are interchangeable.

Someone who also faced this trouble here brought up the thought that if the voltage while charging would drop far below 5 volts the display could become unresponsive. I think up to now this was not reliably confirmed by anyone. Myself had not yet the option to test this. I only used the free app “ampere” to have a rough estimation on charging conditions.

1 Like

This is just a message to not give up hope. I’m pretty sure I’ve posted in this thread before. At least, I have been following it closely because I have had the same problem. Until one day. Last week. I could use my phone. While it was charging.

Same phone, same adapter (from a Samsung), even the same plug in the wall. Now, the touch screen works while charging! Hallelujah! I wish I had a solid technical explanation. Maybe something was tinkered with in an OS upgrade? It’d be interesting to know if others had this happen.

Now if only it would stop randomly rebooting, we could have a really satisfying relationship.

1 Like

The reason for such behaviour is:
the charger emit high frequent noise with the current and if that reaches the FP2 it makes the phone unusable. In my opinion the FP2 is not ok, because two dozen other phones work flawless while charged with the charger in the images.

the reason is not:
a cable with only two wires for the current. Charging works normal without data-wires.

The solution:
is shown in the picture. Use a calble with such ferrit-denoiser (No clue what the english term is …). I tried to make it clear so I used a cable for 1 Euro and a ferrite-ring from another cable.

The charger: is a cheap Huawei one 5 years old …

Now for the images:

The charger with orgnal cable - the FP2 gets charged but is unusable

the charger with a pimped cable
(without this thing the FP2 is unusable too with this cable)

The term for this thing is “ferrite nuclei” and it works as “low-pass-filter”, that means, it lets not pass signal with a frequncy but DC. If you built a cable like me, then let the wire pass 2 times (or more). And set it as near to the charger as possible …

Spielmops

7 Likes

Maybe it depends also on cable length if the FP2 has issues? I have a 3 m cable and my Anker (4-port) charger with Anker cable works fine.

1 Like

Hi. This issue doesn’t appear to be a cable problem, but an INITIAL Lock Screen problem!
If I start recharging my FP2 from the Lock Screen, the touch screen will not work, no matter what cable I try - I have a multitude to test with! (Reboot then requires a 15s hold of the Off button… as the touch screen doesn’t work!)
However, if I start recharging the phone from the Home screen, then the touch screen works perfectly - and continues to work EVEN WHEN the phone reverts to Lock Screen!!

My experience is that this issue is a Phone/OS problem, and not a cable problem.
Regards,
chrisRoald.

I use the Anker 2-port charger and experience the same issues.
Using it with a 3m cable if that’s of interest.