English

Fairphone 2 not staying connected to my home wifi

Hello!

My Fairphone 2 connects to most networks it remembers except for my own wifi with which I have to connect it manually and then it disconnects (usually within at minute). This seems to be a problem only with the wifi network at home, as it remembers and connected to the networks in other places I go regularly.

Its quite frustrating as I am not on a plan with tonnes of data, so am frequently going over my monthly bundle and incurring huge bills because I am eating into my data while at home.

Does anyone know what I can do to fix it? I have tried restarting my router, forgetting the network, reentering everything, as well as doing a total reset of my wifi settings but to no avail!

Can anyone help?

Many thanks,

Connie

Hi and welcome to the community!
If you don’t mind going in a few technical details, this might help:

PS: I recategorized your topic in the #help:fp2 category, instead of #discuss:fairphone2, because you are seeking help and not discussing.

1 Like

Sometimes such issues are fixed by updating the router firmware. Which router is it?

Additional to router update, router restart and disable 5 GHz, you could try out to change security settings in your router (“WPA/WPA2 (very high secure)” instead of “WPA2 (high secure)”) (for testing).

On the FP2 (Android 7) you could try to change some settings:

  • Location - Mode - “High accuracy” (GPS only)
  • Location - Mode - (3 dots upper right side) “Scanning”: disable Wi-Fi and Bluetooth scanning

The problem which you describe is happening also for many other people with some WiFi networks:
https://bugtracker.fairphone.com/project/fairphone-android-7/issue/139

I personally will wait for the Android 9 upgrade and test there again:


For time being as a workaround, I added another router/repeater/access-point device to my network. I did it with “TP-Link-TL-WA901ND” and I didn’t have a WiFi disconnect since 3 months so far.

1 Like

This can have an impact on various apps, such as a Corona tracing app. Furthermore, it is hard to believe that GPS and Bluetooth settings have an influence on WLAN connections.

1 Like

Hi, thanks for this! Sadly I dont really understand how to change things like channels in my router. I live in a shared house and nobody else i live with does either. I will continue trying to understand. I also can’t seem to select different speed networks from my phone so i am not sure what is wrong!

Hello! I am not sure about router technicalities but on the back its says the following:

Arcadyan
Experia Box V 10A

Here a picture of it:

I have never updated the firmware on a router so do not know if it is possible with this router?

Hi thanks for this, I really do not know how to change the setting on my router because there only seems to be a couple of buttons including the power button. How can I make the changes that you mention?

I tried making the changes in the phone but sadly this is didn’t work :frowning:

Thanks anyway!

For those who cannot view the photo: It shows the type label of a SOHO router, model “Arcadyan Experia Box v10A”.

Please have a look at this post: https://forum.kpn.com/internet-9/firmware-update-v10a-v5-00-31-build420-485099

2 Likes

About the picture. I wouldn’t put a picture on a open forum which contains all keys to my wifi, as well as the admin password. I would suggest you edit the photo and blur these fields (just a suggestion).

@conniejehu, I hadn’t thought about it before, but is your phone up to date?
When you go in the updater app, is it version 19.11.2 (last version available)?

2 Likes

I would have expected that the admin password has been changed already. If not, I second your thoughts.

OK thanks! I took it down! Thanks for the tip. Just really desperate to fix it!

1 Like

ha! Weirdly my phone has just suggested the update. but i need to be connected to the wifi to download it :woman_facepalming:

Well… I wouldn’t investigate further before you update.
The 19.11.2 version solved a lot of wifi problems of the type you describe. So either connect to mobile data to download it, or use another phone to do a bluetooth tethering, or use a computer to do adb tethering, or try to find a wifi which connects without problem… i.e find a way to download this update.

As @DeepSea gave the reference of the router underneath, it is probably better.

2 Likes

Yes, version 19.11.2 of FPOS is a must for those who experience WLAN issues…

1 Like

My quick workaround is to use FLIGHT MODE switch to reset WiFi connection.