English

Fairphone 2 not staying connected to my home wifi

For what it’s worth, I was having similar problems and solved them by configuring my router to use a fixed channel for the 5 GHz band. It seems like the FP2 (and also FP3 apparently) don’t like the higher channels (116-128) very much, so if your router switches channels automatically and lands on one of these, your FP2 loses connection seemingly at random. See my topic here for further details.

I have a similar problem at the moment - it won’t connect at all to my home wifi. This only happened in the last week, I don’t know why. It started to drop out so then I told it to forget the network and reconnected, entered password (I checked I had right password - did the same on my Mum’s Samsung mobile and it worked), but it just won’t connect and says “Authentication problem” and that the password may be incorrect…I have checked multiple times, the password is definitely correct! I don’t know if this is relevant but on the Configure Wi-Fi screen under MAC address it says IP address Unavailable. Please help!

Reset your modem and try again to connect.

Hi,

just to share my point of view: We have three FP2 at home and all of them regularly (every 2 - 10min) disconnect from WiFi. Most of the time they reconnect within seconds, but sometimes we have to deactivate and reactivate to reconnect. Very annoying.
There are discussions that it might be related to IPv6 (eg https://support.google.com/fi/thread/704246?hl=en). We have only an IPv6 connection at home (UPv4 tunnelled) so most of the network traffic at home is IPv6. Unfortunately I did not manage to disable IPv6 in our LAN.
Might be worth a try.

Regards, FM

Hi,

Just to add to the solution: we have a FP2 with the same problem. Disabling WIFI-Scanning and Bluetooth-scanning for location did solve the issue for Build-number 19.11.2, Android 7.1.2

Edwin

1 Like

Thanks for sharing your solution. I have Lineage OS that basically does not use WiFI to scan for location, but I sometimes experience the issue as well.