Fairphone 2 LineageOS 15.1 (Android 8.1) Installation Error

The open source LineageOS version 14.1 (Android 7.1) works fine on my Fairphone 2 with the newest TeamWin Recovery Project (TWRP) Image (twrp-3.2.3-0-FP2.img). The problem is that there are no security updates anymore for this version.
When I am trying to install the newest file of version 15.1 (Android 8.1). I am getting the following error message. Nothing gets installed, no matter if I am trying to Wipe in TWRP beforehand or not:

Installing zip file ‘/sdcard/lineage-15.1-20180917-nightly-FP2-signed.zip’
CHecking for MD5 file…
Skipping MD5 check: no MD5 file found
Warning: No file_contexts
E:unknown command [log]
Updater process ended with ERROR: 7
Error installing zip file ‘/sdcard/lineage-15.1-20180917-nightly-FP2-signed.zip’
Updating partition details…
…done

A factory reset did not help.

Download the zip again. Possibly there was an error during download.

Maybe there is also something relevant here:

1 Like

If it wasn’t a download error with the file, try to wipe everything except your SD card (if you have one in the phone) in TWRP with Wipe - Advanced Wipe before installing.

With a new phone, i have to use twrp-3.2.2-0-FP2 to install lineageos, maybe same for you ?

Hi Stefan, thank you for your advice.
I tried again:
I downloaded the newest file lineage-15.1-20180925-nightly-FP2-signed.zip to my Linux laptop.
I verified the checksum using sha256sum lineage-15.1-20180925-nightly-FP2-signed.zip
I copied the file to my Fairphone 2 using:
sudo adb push lineage-15.1-20180925-nightly-FP2-signed.zip /sdcard/
I rebooted the smartphone and launched TWRP 3.0.2-0 using:
sudo adb reboot recovery
I wiped Data, cache and Dalvik.
Then I tried to install the new lingeage version lineage-15.1-20180925-nightly-FP2-signed.zip without rebooting.
So far without success:

Updating partition details…
…done
Full SELinux support is present.
MTP Enabled
Wiping Dalvik Cache Directories…
Cleaned: /data/dalvik-cache…
– Dalvik Cache Directories Wipe Complete!
Formatting Cache using /data/media
Done.
Updating partition details…
…done
Installing zip file ‘/sdcard/lineage-15.1-20180925-nightly-FP2-signed.zip’
Checking for MD5 file…
Skipping MD5 check: no MD5 file found
Warning: No file_contexts
E3004: This package is for device: FP2; this device is .
E:unknown command [log]
Updater process ended with ERROR: 7
Error installing zip file ‘/sdcard/lineage-15.1-20180925-nightly-FP2-signed.zip’
Updating partition details…
…done
Then I tried to wipe the System partition as well.
Then I wiped system
The log was:
Updating partition details…
…done
Then I tried lineage-15.1-20180925-nightly-FP2-signed.zip, but the error was the same again.
In the end I wiped everything except SDCard, but also the instalation was without success.

Hi AnotherElk, thank you for your advice.
I tried again and wiped everything except my SDCard, but without success.

Hi Shnoulle, thank you for your advice.
I tried again with both TWRP images twrp-3.2.2-0-FP2.img and twrp-3.2.3-0-FP2.img.
It is good that the old TWRP version worked for you.
On my Fairphone I could install and launch TRWP.
But I was not able to install LineageOS 15.1, just LineageOS 14.1 worked.

Unfortunately I seem not to be able to install LineageOS 15.1 (Android 8.1) on my FP2 at the moment.
And there are no security updates for my working LineageOS 14.1 (Android 7.1).
So I will get back to FairphoneOpen (Android 6), which is Open Source and has Security Updates.
Maybe its time to wait for one fine day when Fairphone brings FP 3 to the market.

Sounds impossible to me. The only thing I can still think of:

When TWRP asked you whether to “Keep System Read-Only?” …

… did you “Swipe to Allow Modifications”?

I think that your phone has an identity crisis. It somehow doesn’t know that it is a FP2 and thus refuses to install a package made for FP2. Try to flash an official OS via fastboot and then try again.

1 Like

I solved this issue by installing the latest version of TWRP. be sure you have it.

https://twrp.me/fairphone/fairphone2.html

1 Like

Sounds sure enough :wink: .

Yes I have chosen the option ‘Swipe to Allow Modifications’

I asked the Fairphone support to install LineageOS 15.1 (Android 8.1) on my Fairphone for a fee. The Fairphone support said no. Fairphone told me that they respect Lineage. I can understand this decision, because Fairphone has already has two own operating systems:

  1. Fairphone Operating System
  2. Fairphone Open Source.

The Fairphone support said that it is not possible to run the Fairphone 2 with Android 8 because of hardware restrictions. I said that LineageOS already released an Android 8 version for Fairphone 2. Maybe Fairphone means that not all Android 8.1 features run on the Fairphone 2 hardware.

I was surprised that the Fairphone support said that they are already started working on Fairphone 3. I am sure that this will be Android version 8 or higher. They said that I will not come to the market in 2018. I know that a lot of Fairphone 2 users do not want to buy a new Fairphone 3 but keep there current phone, because it is better for the environment, but I think it is good that Fairphone has a plan for the future. Also this will grant security updates when Google does not deliver security updates anymore for older Android versions.

Also the Fairphone support said they are working on Android 7 for Fairphone 2. At the moment there are still bugs to fix. But when a Fairphone Operation System with Android is realeased, they also plan to release Android 7 for Fairphone Open Source. This sounds good for me, because when I do not bring LineageOS 15.1 (Android 8.1) to work I can at least expect an Android 7 with Fairphone Open Source that contains a security update.

Hi Stefan, I think this is a good idea about what was going wrong.
I made a factory reset that brought me the Operating System Fairphone OS.
I had problems to install TWRP directly after this. The following commands just did not work:

adb reboot bootloader
fastboot devices

So I could not continue with:

fastboot flash recovery twrp.img

So I installed the Operating System Fairphone Open first, then TWRP and then the commands worked.
The additional step with Fairphone Open might have brought me to the identity crisis you described.

1 Like

May need to activate developer settings first (System pref -> About phone -> Tap on Build-number. Then should work.

Hello Amber,
I already activated the developer settings. I could install LineageOS 15.1 on a Google Nexus 6P, but not on a Fairphone 2.
I documented what I did on:
https://github.com/SeasStarsRoses/IT/wiki/Fairphone2

I have exactly the same issue with twrp-3.2.3 but not with twrp-3.2.2 , maybe try other’s :wink:

I use adb sideload for final step.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.