Fairphone 2 does not power off when running LineageOS – Help required

I am one of the few users affected by an annoying bug that prevents us from shutting down the FP2 on Lineage. We track all the technical information in the bugtracker, but I would like to discuss possible solutions and verify some assumptions here.

If you are running Lineage OS on your Fairphone, what happens if you want to power off the device? Also: What camera module (back) are you using?

  • It powers off as expected (and stays off). I have the old camera.
  • It powers off as expected (and stays off). I have the new camera.
  • It reboots. I have the new camera.
  • It reboots. I have the old camera.
  • Something different.

0 voters

You can help by taking part in the poll above, share your Android or Lineage OS knowledge, debug ideas. Did you experience similar problems with other devices?


My phone is encrypted (and has the new camera and reboots when it should stay off).

If I reboot until the request for the encryption password, and I choose to power off from there (the menu appears when pressing Power like it does in the fully booted OS, just with fewer options), the phone stays off.

1 Like

It powers off as expected with my old camera module. Now I just switched to a spare new cam module I have laying around and suddenly it reboots instead of powering off. I didn’t change anything except the camera module.

PS: I switched back and everything works as expected again.
PPS: Since the other posters provide that info I’ll do it too for completeness sake: device is not encrypted.


Mine is not encrypted with new camera - and reboots.
In one case when I tried to shut it down more or less immediately after entering the SIM PIN it actually shut down. However I can’t reproduce it right now.


Thanks, very helpful.

Preliminary Results seem to confirm the observation, that only FP2 with the new camera module are affected. Thanks everybody. It can confirm that Fairphone OS is not affected.

I think the following would help:
A kernel log and logcat from shutdown of a user with the old module. And a kernel log and logcat from shutdown of a user with the new module and Fairphone OS.

Maybe we can find out whats different. If you know the privacy and security implications of sharing logs and how to provide such logs, you can post them in the bugtracker (or send them to mee with your permissions to upload them to the bugtracker). You could also compare them yourself and look for differences. See the bug for that.


Do you know of a good explanation about this? I actually don’t know which logs are useful and how to get them…


I have the old and the new camera modules. Only with LineageOS + new camera -> reboot. Otherwise (LineageOS + old camera, OpenOS + new camera) no reboot.
I can provide logs.



I have the same problem : when I try to shutdown my fairephone 2 whith kubeigos 14.1m it restart immediately

Could you help me please ?

Best regards


It’s a bug which isn’t fixed yet, see here at the bugtracker.
Some options:

  • Press Power so long (really long) that the phone force-shuts down. Sorry, not reliable.
  • If you would rather like a controlled shutdown, then reboot the phone into recovery, and then shutdown from there, that works.
  • Only applicable with encryption: Reboot until the request for the encryption password, then shutdown from there, that works, too.
  • This topic suggests the bug is connected to the new camera module … swap the new module for an old one, and shutdown probably will work :wink: .

Wooops forgot to press “Reply”! Not encrypted, new camera, reboots (EDIT: using LOS).

1 Like

By old/new camera do everyone mean the main camera ? Does anyone experience reboot with the new front camera/top module ?


Good question. I can’t tell for sure, because I’ve got both new modules.
Looking at the poll I’d guess the issue is with the main camera, because this is (as per my perception) the most-often changed module. If the issue was with the selfie camera, the result would probably be less clear.

We might be able to tell. Because without the new camera modules, the device is also able to encrypt phone the same way as if it had the old module. The reboot problem could be related to that.

I still got the old modules, so I can test all (AFAICT) 9 configurations:

  1. With both NEW modules (Already tested. In my case: cannot encrypt, device reboots. EDIT: encrypted my phone, device still reboots. All other tests were done WITHOUT an encrypted phone. Ie. after all tests, I used the old modules to encrypt the phone.)

  2. With both OLD modules (*) (Tested, device halts)

  3. Without modules (*) (Tested, device halts)

  4. With NEW top module (**) (Tested, device does not start, will retry)
    Without bottom module

  5. Without top module (**) (Tested, device halts)
    With NEW bottom module

  6. With OLD top module (*) (Tested, device halts)
    Without bottom module

  7. Without top module (*) (Tested, device halts)
    With OLD bottom module

  8. With NEW top module (**) (Tested, device halts)
    With OLD bottom module

  9. With OLD top module (**) (Tested, device halts)
    With NEW bottom module

(*) These are all possible dupes.
(**) These are also possible dupes.

The most interesting use case is #4 and #5 or #8 and #9.

PS: I did not verify all hardware works. So we need more data for sure.


I changed only the main camera. So my feedback is:

  • with NEW main camera and OLD selfie camera -> reboot !
  • with OLD + OLD, no reboot…

From what I understood here, users with NEW main camera and NEW selfie camera have reboot too :slight_smile:

What could be interresting to test is OLD main camera + NEW selfie camera?


My encrypted FP2 reboots with LO regardless of what camera module I use. I had the reboot bug with the old camera and I have it since I replaced both modules. The phone was wiped and freshly installed twice and the bug is still there.
And just to exclude another configuration variety: I used a rooted LO in the past and my latest LO installation is not rooted - no difference.


I use a different one:

  • Install EFIdroid. Even if the multiboot solution doesn’t work right now, it add an extra booting screen where you can shutdown your device :slight_smile:
1 Like

It depends. I’ve got the new camera module and sometimes it does reboot and sometimes it doesn’t. I thought it would be a microG/tingle thing. Because often after upgrading, if I didn’t “tingle” my phone immediately it didn’t reboot but started after tingling…

At the moment I run the latest LOS nightly build without tingle and it doesn’t reboot.

Meaning your phone shuts down correctly when you choose power off?

like a joke, since yesterday evening it doesn’t shut down correctly, it reboots again after shutting down…