English

Fairphone 2 cannot connect with Wifi with WPA2

Tags: #<Tag:0x00007f05e1ee9970>

hi community!

my FP2 refused to connect with my wifi router at home. now I found out that the problem was the WPA2-encryption of the router. as I changed it from WPA2 to WPA, my phone connected without problems. since WPA2 is more secure than WPA, I’m wondering if it is really impossible for the FP2 to connect with WPA2 switched on or if there’s a way to do it.

maybe someone has experienced the same thing and knows what to do?

thank you!

xx
elisa

Welcome to our forum, Elisa!

The Fairphone 2 generally is able to connect with a WPA2 Wi-Fi. The one in front of me is currently connected to a WPA2 Wi-Fi.

Try to delete your Wi-Fi from your phone (long-press your Wi-Fi entry in the list to do that), re-configure your router to WPA2 and connect to your Wi-Fi again. Check if you typed your password correctly.

Good luck!
Tobias

3 Likes

Hi Elisa,

I can confirm your problem to some extend. My router at home (some Fritzbox) allows “WPA2”, “WPA/WPA2” and “WPA” for encryption. And there “WPA2” does not work.
At work, connecting to a “WPA2” WiFi is no problem though.
(See also How do I know the type of wifi security actually being used?)

Unfortunately I have no solution for this.

2 Likes

Fritz!OS version?

For me …

Fritz!Box 6590 Cable, Fritz!OS 7.10, security set to WPA2 … no problem with my Fairphone 2.

Fritz!Box 7590, Fritz!OS 7.12, security set to WPA2 … no problem with my Fairphone 2.

(My phone is running LineageOS, though.)

Which router model do you have?
Are there perhaps OS updates available for it?

1 Like

LineageOS + Fritz!Box 7360 / Fritz!Box 7590 works for me.

I can confirm the Problem with that router:
Speedport Smart 3 - Firmware-Version: 010137.3.0.008.1
(actual of today)

WPA2 only doesn’t work either in 2G nor in 5G. That means: Connection will stay in State “Connecting” on the FP2, never getting a working link.
If i choose WPA/WPA2 it works as usual.

My router broke down a week ago or so and my provider just gave me a new one. Now it’s a Fritz!Box 7530 and the problem is gone, i.e. the Wifi security is now set to WPA2 and it works with my FP2.

The old router was a Fritz!Box 7360. Not sure if it was the fault of the model in general or maybe missing firmware update from my side.

1 Like

Pietro_Ciuffreda wrote in the following thread:

Perhaps that’s something to try.

1 Like

Well, both @Lidwien and I had no problem on a 7360, and there were a few reports from other brands of routers. However I believe I performed the update while connected to that router, maybe that made a difference.

Same here
problem after update to fairphone Open OS 19.08.1

Connection to router (WPA 2, Model RTV1905VW from Askey) no problem. Configurated before Update.

Connection to dLAN 500 AV Wireless+ only if configured for WPA, not for WPA2.

Commenting & Upvoting the bugtracker.

Same problem with router CBN CH6640E (with WPA2-PSK) and OS 19.08.1. Switching to “mixed WPA-PSK / WPA2-PSK” brings no result. Still looking for a solution.

If that doesn’t help …

https://bugtracker.fairphone.com/project/fairphone-android-7/issue/276

"Maarten Derks 23 Oct 2019 13:43

We have a fix for this issue available for testing in the beta program.
Please consider joining the beta program by sending an email with your forum account name and a short motivation to beta@fairphone.com. New to the forum? Sign up!
As a member, head over to this forum topic to participate."