Unable to connect to wifi since fairphone OS 19.08.1 update

same problem for me. Wifi seems to be frozen

I just wanted to mention two things …

  • https://support.fairphone.com/hc/en-us/articles/213290023 … “Downgrade” section.
  • If you are affected please upvote the bug in the bugtracker so the developers see the urgency. Posting here in the community forum is totally fine, but it’s not what the developers see, the bugtracker is where it counts.
    Since the bug report there started being about Fairphone Open OS (the variant without preinstalled Google Apps and services) perhaps leave a comment there that Fairphone OS is also affected.
1 Like

I found a solution for this annoying issue: on my router (FritzBox 7360) I had to change my security settings to only WPA, so neither WPA2 nor combined mode! Now it works again …

Be aware WPA has known vulnerabilities. WPA2 is more secure.

Here the same. My FP2 can’t connect to our Fritz!Box 7360, set to WPA2 (CCMP). Hope there will be a solution soon.

I am as we speak connected to a Fritzbox 7360 in my mother’s home and it is working fine with FPOS 19.08.1.

FYI, the router has software version 06.85 and uses WPA2.


My friend has also Fritzbox 7360 on version 06.85, uses WPA2 and is on channel 6.
Working fine with Fairphone Open OS 19.08.1


Same problem here! Urgently requesting solution.

Welcome to the community forum.

1 Like

Okay! I will do that.

1 Like

Yes, I am back, but not with that smiley face.
from the bugtracker, where you have to create yet another account:

If you are able to change the settings you have at least wifi at home with your mobile device

I don’t quite understand what you mean: that you would need to have a connected device to access the settings? This can also be done by a computer connected to the router by cable.

1 Like

if it is your router you can change it, if its some wifi anywhere else you most likely can not change settings in the router

As suggested I created an account in the bugtracker forum and upvoted that bug.
This evening I will try to create the logs as described there.
Really hope this will be solved soon.

1 Like

Upvoted and replied in the bugtracker, I changed WiFi mode from 11nbg to 11bg and my FP2 is able to connect to WiFi (WPA2).

I just need to leave a reply on this topic. I (pre-)ordered both FP1&2. There were very annoying bugs after updates over the years. I fully understand that the FP developer team is unable to test every possible hardware combination but this here is a proof that they are working below a critical mass of developing capacities. Bugs sometimes take weeks before they get fixed, and wifi connection in this case is a core feature that has to be tested properly before releasing an update.

Sorry to say that: I won’t buy a FP3. This very FP2 bug was the last straw that broke the camel’s back. For me, the journey is over…

I really understand what you mean, as I preordered both phones as well.
Other than you, I happened to have a rather flawless experience with just minor annoyances; i.e. the reboots-troubles, that were easily fixed with a smal plastic shim.

And I happen to differ in another point.
As I read of quite a frew troubles concerning the FP2 and it’s design, as was a bit more cautios or anxious. It has to be very much appreciated, that Fairphone took the pains to develop Android 7 for a SoC no other manufacturer has brought this OS to, as Qualcomm doesn’t support it. But exactly the hugeness of this task made me refrain from upgrading. I am still on Android 6, though this has security patch level 02/2018.
And - while you sure are correct, that they lack personnel to take on all problems at the same time - in this case the bug happened to surface parallel to finishing and releasing the FP3.
Agreed, that WiFi bug should have ideally been fixed before release, but I guess, it is impossible to test all possibilities and it seems not everyone is facing those problems and some got the problem solved if I get this thread right:

Maybe take a look at the further developement of Fairphone and they will earn your trust for buying a phone later on.
One has always to remember, that Fairphone is not just a small company, but they have developed a modular phone concept, that has never been realized before. In cases like that problems have to be expected.
I consider myself being a kind of proud beta-tester.

1 Like

For the FritzBox 7360 users: did any of you already try to install the update to version 06.86?

Hey guys,

Since last week, I am having the same issue and since I am travelling abroad this sucks monkeyballz; I really need to be able to connect to wifi but it never does :frowning: On top of that, (in order to find a temporary solution) how can I downgrade if I can’t connect to wifi to download the previous software package? I cannot access the routers since I’m mostly using public wifi or at hotels etc so I’m really lost here, would appreciate any help anyone is willing to offer.


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.