English

Unable to connect to wifi since fairphone OS 19.08.1 update

I can’t connect to any wifi, neither open nor private. I restarted my phone as well as the 2 wifis I tried to connect to. Changed location to ‘device only’. I read in 1 post to change my wifi security protocol, but I don’t know how to do that since my phone is in german and I can’t find that option anywhere in search.
Help would be much appreciated.

5 Likes

Same problem for me, after the updating 19.08.01, alredy restarted my FP2, hard reset, nothing changes. I think it has something to do with the encryption. In fact WiFi works with WPA and with no protection at all.

I have the same problem with my FP2

Same problem here. No solution in sight yet. I just filed a support request as well, just to be safe.

same problem for me. Wifi seems to be frozen

I just wanted to mention two things …

  • https://support.fairphone.com/hc/en-us/articles/213290023 … “Downgrade” section.
  • If you are affected please upvote the bug in the bugtracker so the developers see the urgency. Posting here in the community forum is totally fine, but it’s not what the developers see, the bugtracker is where it counts.
    Since the bug report there started being about Fairphone Open OS (the variant without preinstalled Google Apps and services) perhaps leave a comment there that Fairphone OS is also affected.
1 Like

I found a solution for this annoying issue: on my router (FritzBox 7360) I had to change my security settings to only WPA, so neither WPA2 nor combined mode! Now it works again …

Be aware WPA has known vulnerabilities. WPA2 is more secure.

Here the same. My FP2 can’t connect to our Fritz!Box 7360, set to WPA2 (CCMP). Hope there will be a solution soon.

I am as we speak connected to a Fritzbox 7360 in my mother’s home and it is working fine with FPOS 19.08.1.

FYI, the router has software version 06.85 and uses WPA2.

2 Likes

My friend has also Fritzbox 7360 on version 06.85, uses WPA2 and is on channel 6.
Working fine with Fairphone Open OS 19.08.1

2 Likes

Same problem here! Urgently requesting solution.

Welcome to the community forum.

1 Like

Okay! I will do that.

1 Like

Yes, I am back, but not with that smiley face.
from the bugtracker, where you have to create yet another account:

If you are able to change the settings you have at least wifi at home with your mobile device

I don’t quite understand what you mean: that you would need to have a connected device to access the settings? This can also be done by a computer connected to the router by cable.

1 Like

if it is your router you can change it, if its some wifi anywhere else you most likely can not change settings in the router

As suggested I created an account in the bugtracker forum and upvoted that bug.
This evening I will try to create the logs as described there.
Really hope this will be solved soon.

1 Like

Upvoted and replied in the bugtracker, I changed WiFi mode from 11nbg to 11bg and my FP2 is able to connect to WiFi (WPA2).

I just need to leave a reply on this topic. I (pre-)ordered both FP1&2. There were very annoying bugs after updates over the years. I fully understand that the FP developer team is unable to test every possible hardware combination but this here is a proof that they are working below a critical mass of developing capacities. Bugs sometimes take weeks before they get fixed, and wifi connection in this case is a core feature that has to be tested properly before releasing an update.

Sorry to say that: I won’t buy a FP3. This very FP2 bug was the last straw that broke the camel’s back. For me, the journey is over…