Fairbuds app cannot update Fairbuds

I bought the in-ear Fairbuds yesterday, and it seems to be impossible to update the firmware via the iOS app. I have the most recent version of the app (2.0.3) installed on my iPhone 14. Most of the time the app cannot even find the Fairbuds, although they are connected to my phone and I can use them without problems. If the app manages to find and connect the Fairbuds, it tells me that I have to install and update. I am trying to do that, but it fails after a few seconds and tells me I should try it again later. How to solve this?


May I assume the update issue is solved for you?

No, it is not. I cannot even connect to the app most of the times and if the connection works the update fails.

1 Like

Btw, people on reddit are complaining about the same problem.


Ok so you dont have the most recent firmware, which I is useful to add when reporting bugs.

1 Like

Yeah, I don’t have the most recent firmware because the update doesn’t work…


Dont tell me here add the information in the other topic.

Else back to topic here:


Hello ,
My update on the Fairbuds does not go through it always stops at 54% should I close the case or let them out of the case.

Hi and welcome, iOS or Android?

iOS Version 17.4.1 and app version 2.0.3 (1)

Thanks for confirming so I merged with the other topic opened in parallel, have a look at the posts I linked above , maybe something helps.

So, i tried both:

I was able to connect the app by removing the buds from the case like described here: Losing connection between left and right earbud - #5 by joram
However, not sure if this is really the reason or it just worked “accidentally” like it did before from time to time.

The problem is, that the update stil doesnt work. it just stays at 0% and doesn’t do anything. I have it open since 10 minutes already, and still at 0%.

1 Like

so the official way would be to contact Fairphones support, and as this might take some time for a response,I would def. do this.

@BobVI any comment from your end? Seems at the moment rather an iOS issue at least with the new Fairbuds. I cant test I dont have the Fairbuds.

Ok, I think I found a way to make at least the connection to the app work:

  • Close Fairbuds app
  • Select Fairbuds in iOS settings unpair them and tap the “Forget” button.
  • Turn Bluetooth Off and On
  • Press Pairing button in Fairbuds case
  • Remove from case
  • Don’t connect them in the iOS settings!
  • Open app
  • App is able to connect

Unfortunately that doesn’t help with updating. Still stuck at 0%.

I noticed a second “Fairbuds” appears in the iOS settings after a while. Not sure if that is connected:

1 Like

Did you delete both and also reset the Buds?

Yes, at least 20 times.

1 Like

It worked for me after resetting the buds :slightly_smiling_face:

It does also not work for me (iOS app). Max. progress was 57% then it stopped.
I think about sending them back, if there is no solution in the next days.

I am starting to think the problem is with the Fairbuds, not with the app. I borrowed the Android phone of my wife to do the update. I can connect the app without problem, but it tells me that my Fairbuds are already up to date. However, it cannot show the version. It says: Current version: N/A
Same with the battery. The app doesn‘t know how full the battery is. It just says N/A

1 Like

I give up. I spent hours to make it work, but it’s impossible. The Fairbuds always lose their Bluetooth connection during the update. I will send them back.

1 Like