Experiences with FP2 and Lineage with MicroG

Hi there,

I’ve reactivated my FP2 reinstalled Lineage 18.1 with MicroG. Half a year ago it always crashed, but now I have to try again. freshly installed it seems to work more or less, but I’m curious if it will stay like this.

I’d also be curious about other users’ experiences.
Is it stable on your FP2?
How about plain Lineage?


I am using Lineage OS 18 for more than a year and have been very happy with it. However, recently, it became obvious that the FP2 hardware is having its trouble to keep up with the demands of the OS which means it is quite slow now. It is unfair to blame the Lineage community but I have been wondering if a switch to the Fairphone OS or an update to the latest Lineage OS might be helpful. Please let me know if anyone has experience with it.

OS demands are not very probable.

I’m running /e/OS on a Fairphone 2, which shares some similarity with LineageOS for microG, and I can’t complain.

1 Like

I tried running Lineage, but ran into a severe graphics bug that meant that the phone would freeze when scrolling through menus (this bug also appears for me in other OS’s based on the same Android version).


cool to see your answers. I wasn’t sure if this is relevant to a lot of other people anymore.

@jago I think my problems actually began after upgrading from Lineage 17. Not sure anymore if i directly tried Lineage 18 with Micro G oder just Lineage 18. But ever since I left 17 it got worse. I aso thought 19 might work better, but now I doubt it. It’s newer and maybe this rather means less tailored to FP2 as it gets older and older.

In the original post I said that I now Have Lineage 18 with MicroG. Meanwhile I changed to just Lineage 18 to see if it is more stable. (I read that MicroG is more unstable as it leaves out even more stuff that is linked to google more experimental in a way.) Lineage 18 worked quite fine for a week, but now I’m back to the same old blues. The phone is practically useless and it is not easy to figure out which changes led to this – certain apps, too many apps? – so that I don’t have any reasonable idea how to solve it.

Maybe it’s worth trying e/os/ (thanks for the hint @Ant0kneeguy though from the little I know Lineage (with Micro G) seems to me the more “sympathetic” choice.

Otherwise I may decide to pay a bit more to get a used FP3+.

Also interesting to know that other OSs have similar bugs @Ant0kneeguy. Maybe this is a strong point for leaving FP2 behind. Although whenever I fall back to my conventional mobile phone it really saddens me that today’s tech is really not meant to last, compared to normal mobile phones which still run (as they dont change internally).

My FP2 is still using LOS with MicroG and I don´t hear any complaints from his user (it not me) about it. Neither I could say anything bad about it :slight_smile:

1 Like

Thanks for letting me know.

Seems it’s hard to figure out why it’s not working for me, so I figure I’ll most probably buy another model. Thanks again for all your observations.

Using FP2 Lineage-MicroG 18.1 with Android 11, no problems - I’m happy with it :grinning:

1 Like

Wow, so it just has to do with MY fp2. Which is bad luck :frowning: as I’m not capable of figuring out the reason.

But great to learn about this anyway.

1 Like

Hi @krs2
Your FP2, maybe yes, but not necessarily the hardware! As I read through this topic I got the impression that there may be some app or configuration you’re using that is the problem. When you changed to Lineage 18 w/o MG it worked well for a week. Did you check what might have happened later to get you “back to the same old blues”?

If I wanted to keep using this phone I’d make a list of functions (apps) I must have. Then factory reset and add them (but not others). See how the phone behaves over ten days. Then, if the phone’s behaviour is still OK, gradually add others in order of decreasing importance, but one at a time leaving three days between each. Keep a detailed record of what you do (apps you install, configuration changes you make, even minor ones).

“Too many apps” is mostly only a notion that’s valid for apps that run in the background and constantly use resources. There are tools that can help you check for those.

1 Like

Thanks for sharing all your experiences! @AnotherElk Basically, the FP2 is getting hot at the point where the chip is located when doing costly stuff like video calls. However, after dismantling the FP2 it seems like it is better now. So maybe it was a hardware issue after all. However I would be still interested in anyone that has experience with LineageOS 19 or FairphoneOS compared to LineageOS 18.


Thanks for the advice. Maybe I’ll give it another try. Though I’m really close to “tapping out” this time.
In case I choose to switch phones, I might do this later, before I hand the FP2 over to someone else.

Once again thanks to everyone for the support!

1 Like

Btw I never metioned that somewhen I installed unports to check out Ubuntu Touch and the starting screen/basic software of UB Ports remained. This cannot be the reason for my problems, can it?

Get the file splash.img out of a Fairphone OS or Fairphone Open OS install file (e.g. here) and flash it to the splash partition :wink: .

1 Like


which version of LOS with MG do you use?

I think I might try getting another FP2 and check whether it works with LOS with MicroG, if for many of you it works just fine…

The latest one, don’t remember the version number, but you can see it on the website from LOS

Für ein sichere, private und zukunftsgerichtete Kommunikation im Internet, kommen auch Sie zu ProtonMail!

Gesendet von Proton Mail für Mobilgeräte

-------- Original-Nachricht --------

I am using this on my FP2, see attachments.

Thanks for sharing :slight_smile: This could be helpful later.

Right now I have another reason to believe, that my phone reboots and bootloops because of some hardware issue. I installed the latest Fairphone OS successfully and the phone’s behaviour stays the same.

Does anybody know which hardware parts could cause this?

Have you tried to run the phone without SIM (+SD card) and in Safe Mode?