English

EFIDroid (multiboot) for the Fairphone 2

multiboot
Tags: #<Tag:0x00007fefbdf437d8>

#101

Hi again,

I don’t know if I should open a new thread for that or just continue here. But I think it is related.

So, installing any ROM with TWRP and make it works with EFIDroid is not a problem. But, obviously I’ve got an issue. Whatever images/ROM I installed with TWRP (and EFIDroid) I can’t “boot” it.

I tried with LineageOS (multiple versions) and FPOS (multiple versions). So after, installation I select my freshly installed image on EFIDroid. So, then I can see the Fairphone animated logo or the circle moving on the string (for LineageOS) but next I got a reboot or “logo” animation continue endlessly (need to remove the battery to reboot the phone).

So my question is the following. Is there a way to debug this ?


#102

Currently nobody can.
The issue is: EFIDroid currently doesn’t work on the Fairphone 2.

Sure, if you are a programmer with (I guess) Android and EFI knowledge: Be a hero and fix EFIDroid for the Fairphone 2 :wink: .
Everything you would need for that should be mentioned in this topic, especially (but not only I guess) in the first post.


#103

Yep, I also think this is the right place.


#104

@AnotherElk
Currently nobody can.
The issue is: EFIDroid currently doesn’t work on the Fairphone 2.

Hmm…well, I can boot FPOS with it. Also, I can boot other images but when EFIDroid step down to the secondary images at some point the freshly installed images reboot or stay endlessly at logo step.

So, I think EFIDroid is working as it can start other OSes (That’s why I think my issue is not related to EFIDroid) and a proper package for FP2 exists. So, EFIDroid is doing its job. But I’m confuse as I don’t know what do you mean exactly by EFIDroid is not working on FP2 ?

Before using it I read this :

https://z3ntu.github.io/2016/11/01/Install-and-configure-efidroid.html (2016)


#106

Ah, I see my misunderstanding now, sorry.

Of course, you can install EFIDroid and a primary OS, and that may indeed work just fine. But that’s not what you need EFIDroid for.

EFIDroid (as it says in the topic title and in the first post) is a multiboot solution.
And as soon as you add another OS to EFIDroid apart from the primary one, booting that additional OS doesn’t work currently on the Fairphone 2, this was confirmed by several users in this topic.

So, to clarify, EFIDroid currently doesn’t work as a multiboot solution on the Fairphone 2, so at the moment it doesn’t do the very job it is there for to do.


Switching between AlternativeOS's on the FP2
#107

Hi all !
I’d like to try the EFIDroid multiboot solution, and without any surprise (I read this topic before) the secondary rom don’t boot !
As the last version is not working with FP2, I’m trying to find the last working combination.
On @z3ntu’s tutorial, according to the screenshots the following versions were used:

  • EFIdroid 0.1, build date 01 Nov 2016
  • FP Open OS version 16.09, direct link is also there.
  • TWRP 2.8.7

With installation with official EFIdroid app the build date is newer, so to get the older EFIdroid I managed to install z3ntu’s version of the EFIdroid app. It is also possible to download the builds and flash boot and recovery img with fastboot.

For the moment I tested:

  • EFIdroid 19 Jan '17 (official app) + FPOpenOS 16.09 + TWRP 3.2.1 : fail
  • EFIdroid 11 Nov '16 (fastboot) + FPOpenOS 16.09 + TWRP 3.2.1 : fail
  • EFIdroid 02 Nov '16 (z3ntu app) + FPOpenOS 16.09 + TWRP 3.2.1 : fail

Next step will be to test an older version of TWRP… I’ll keep you informed :slight_smile:


#108

Tested:

  • EFIdroid 02 Nov '16 (z3ntu app) + FPOpenOS 16.09 + TWRP 2.8.7 (OpenOS) : fail
  • EFIdroid 01 Nov '16 (fastboot) + FPOpenOS 16.09 + TWRP 2.8.7 : fail…

Now I’m running out of ideas :frowning: Perhaps my primary system is also important? I have LineageOS at the moment, I can try restoring an old backup of FPOpen 5.1 …

EDIT: Tested also from FPOpen 5.1 (16.08) as a primary; tested with install zip and with restoring TWRP backup; nothing worked.

Remark : After wiping LineageOS, (so without any EFIdroid) I tried to install FPOpen 5.1 with the fp2-sibon-16.09.0-ota-userdebug.zip file from the sdcard. The install seemed ok, but when I asked TWRP to reboot I got the message “No OS installed, are you sure?” and indeed nothing booted. So I installed it with the manual-userdebug.zip 's bash script that call fastboot.
Perhaps I misunderstood, but the “ota-userdebug.zip” is supposed to be stand-alone installation, right? or is a previous OS to be upgraded is required?


Order a fairphone with an alternative OS pre-installed?
#109

Note: I couldn’t automatically update my LineageOS main partition with EFIdroid installed. TWRP error message is:

Zip signature verification failed! Error installing zip file ‘@/cache/recovery/block.map’

Uninstalling EFIdroid (*) then manually installing from /data/lineageos_update while disabling zip verification solved the problem.

(*) I uninstalled EFIdroid to be safe, but I’m not sure it was mandatory… It is quick to reinstall anyway. I’ll test further for next update :slight_smile:


#110

Is still someone trying to make EFIDroid work on the Fairphone 2?


#111

Efidroid is currently being rewritten so there’s not much that can be done at the moment.


:gb: :fr: FP2 reboots all the time / I can't switch off my phone!
Order a fairphone with an alternative OS pre-installed?
#112

Read that months ago on xda. Any idea when they are going to release the first test version?


#113

Greetings all,
my main motivation for using something like EFIDroid would be to have a playground on my phone that I can mess with and being able to go back to a usable, stable system in no time (other than a reboot, of course). So while EFIDroid is not functioning I’m wondering: is there any other possibility / software to achieve this? Any insights / links / keywords would be greatly appreciated!
Thanks, Andreas


Order a fairphone with an alternative OS pre-installed?
#114

I don’t know any other (except multirom but that project is dead and never worked properly on the FP2)


closed #115

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.