Does another battery fit the Fairphone 1

My Fairphone 1 battery won’t charge anymore. I plug in the charging cable, but the charging sign won’t show up. I would therefore like to know if another battery fits, and if yes, which one?

I know this question has been asked before, but the answer given was yes without any further specification.

I am aware of the dangers of inserting & using a non-FP1 battery, but at this point, I’m desperate enough to give it a try. I would try to get a new one in the market section of the forum, but I live in China, not Europe…

(I will also try to get an external charger as suggested here, but I would really like to know my options.

Your problem actually sounds like your USB port is broken, not your battery. You might be wanting to look into repair shops who might be able to fix your USB port. They might as well be able to check if your battery is ok or not.


Thank you. Yes, you could be right. That didn’t occurr to me. I will try that out.

The USB port may not even be broken but simply filled with dust/dirt. I had that once. The USB cable couldn’t be inserted fully. After I cleaned the port with a needle, all was fine again.

1 Like

Tried the cleaning, unfortunately that was not the problem.

I also went to an electronics store and they told me that indeed the USB port is broken. But they said they could not fix it. Said they could replace the USB port itself, but some other part it linked up to could not be repaired? Unfortunately my language skills were not enough to understand that last part, what exactely they claimed was broken. I’ll probably try at another store, too, and see what they say. Don’t really want to give up on my FP1 yet, it’s only three years old… :frowning:

Currently using an external charger to charge my battery…

Thank you for your replies!

1 Like

You won’t have to. I left my FP1 three times at a repair shop until they fixed the issue. First they tried to resolder the old FP1 USB connector, but in the end they soldered a generic Samsung USB connector in, which at least worked for 9 months. (They repaired it this week again on warranty.) So not all hope is lost! :slight_smile:


I’m afraid I cannot help you there, but just in order to understand what might be the issue, see this post (there is a photo in the original post):

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.