Difficulty getting FP2 to boot

Hi, for a while I have had trouble getting my FP2 to turn on. It takes me a lot of attempts pressing the power button (sometimes for a long time) until it will finally turn on. So far it always worked but of course I’m afraid that it will not turn back on one day.
If I plug in the charger while the phone is in that state, nothing happens (the LED doesn’t turn on). Only if I take out the battery and plug in the charger the LED turns on, but after a minute it turns off again, no matter if I put the battery back in or not.
At first, I thought it was a charging related issue because this happened after I let the battery drain completely, but recently, I turned off the phone while the battery was at 40% and the same thing happened.
I tried pretty much all of the suggestions in FP2 Won't turn on or charge - See first post for troubleshooting. The only thing that did seem to work (sometimes) was pressing the power button for 20 seconds. I also was not able to boot into recovery mode
Not sure if it matters, but I am using LineageOS with Microg.
Any suggestion what I could do other than making backups and hoping?

Hi fpgk,
Most of what you describe would be consistent with a faulty contact on the power button, but I’m not sure I’ve understood about charging. Are you saying that the phone doesn’t charge if you plug in the charger when the phone is turned off, and that conversely it will charge if you plug in the charger when the phone is turned on?

You should certainly do a backup. Then, I would suggest you contact Support to see if they have any ideas.

I would also consider finding a good repair shop in your area. It may just be that the power button contacts need cleaning, but in this particular case it might be advisable to have it looked at by an expert. You could also try to contact a #fairphoneangel if there’s one near to you.

In the forum, there are several reports on faulty power buttons and also repair shops.

2 Likes

Thanks for your reply.
The idea about the power button seems interesting, but I honestly doubt that it is the problem. When the phone is turned on, it works without a problem lock and unlock the device. And by long pressing, I can consistently trigger the menu which offers me to shut down the phone. It seems unlikely to me that the power button only has issues while the phone is turned off.

Regarding your question about the charging: When the phone is turned on, it works fine. Sometimes, the LED is not turned on for some reason but it still charges. When the phone is turned off, the LED only lights up when the charger is plugged in while the battery is not in the phone (And it always turns off again after one minute). If I plug in the charger with the battery in the phone, the LED does not turn on. I can’t tell whether the battery is charging during that time, i.e. whether the problem is only with the LED not turning on or that the battery actually doesn’t charge.

Also thank you for your suggestion about contacting Support. Do you think they will be interested in this? I assumed they wouldn’t, because obviously the phone is wayy past warranty, but I would be happy to be proven wrong.

They still offer software support, and they still offer out-of-warranty repairs, and a complete end of any possible support for the Fairphone 2 hasn’t been announced, so asking Fairphone support can’t hurt.

3 Likes

If you make a note of the battery charge level, then turn off, plug in the charger for, say 45 minutes, then unplug and turn the phone on you’ll see whether the charge level has changed.

For the power button, I don’t know, but taken in conjunction with the charging thing, I’m beginning to wonder if there isn’t something else that is preventing boot. The phone should always boot when connected to charger.

Do you have a SD card (hopefully formatted as “portable” storage)? If so, try removing it. Try removing the SIM too (but not at the same time so you know what effect is due to which action), just to see what happens.

1 Like

So when battery is out and you connect ,the LED stays on and nothing else happens? Normally the phone should go in a kind of bootloop of short blinking of LED, pretending reboot (Fairphone Logo displays 1-2 seconds) and this is repeated over and over again. So if this does not happen its most likely not the battery. I recently had charging issues after my battery drained completely which were "fixed " with upgrading to Android 10.

1 Like

Thanks for the suggestions! I don’t want to take the risk of switching my phone off right now, as I need it urgently, but I will try that later. I actually tried taking out the sim and SD card previously and my impression was that it did not change anything. But I might try it again.

So when battery is out and you connect ,the LED stays on and nothing else happens?

Exactly. And it turns off again after one minute, without anything else happening. I did not know that the phone should enter this “bootloop” in that case.

I recently had charging issues after my battery drained completely which were "fixed " with upgrading to Android 10

I am tempted to just install a different OS or reinstall the one I have now to see if that works. Although that comes with the risk of the phone never turning on again, so we’ll see…