[Debloater + Google reducer] Unofficial Fairphone 3 debloat script

It will probably work but the results may be different (and I mean that in a bad way) because the FP2 has different bloatware. I wouldn’t try it.


Good morning, I have done all steps and it worked. Thank you for that. Unfortunately the dialer is not working properly. I can’t call anyone. Would be happy for help.

And I would like to geht the clock app for my wifes FP2, but can’t find it anywhere. Any idea?

Thanks for your work.

Cheers, Ernst

I am not sure if I forgot to add this to the GitHub README.md but check the following points:

  • Are you using the latest release? (Prior releases had the Lineage Dialer which used to crash)
  • Have you set the new dialer as the system default in "Settings >> Apps and notifications >> Default apps >> Phone/Dialer?

You can find the clock application here:

Make sure that you’re on Android 9 or else it will not install.

1 Like

Hi, thanks for quick reply!

I am on the latest release and have the simple dialer installed. And it it set as the defauld dialer.
It opens on demand and I can start a call but it immediately, lets say after a quarter of a second, it stops and the call screen disappears. If I an not able to make it work, would you mind telling me how to get back just the dialer and maybe contact app, if the second one is needed for a working dialer.

Thanks for the link to the clock. So I’ll wait until Android 9 will have come to her phone.

Cheers, Ernst

I checked if the original Dialer would be safe to install: εxodus (Yes I am privacy paranoid) and it’s probably safe.

You can get it back like this:

adb shell pm install-existing com.google.android.dialer

Hi, thanks, it worked and so phonecalls are back.

What I did next, was installed simple phone calls again and just deactivated (not with your script) phone app and now it works with the simple phone app as well. Strange, but ok.

Thanks for your help :slight_smile:

Have a good day!



glad that it worked!

1 Like

Jan, good morning. When I used your script, I saw, that the icons of the removed sofware were still there and even the apps list shows them installed, but not available for the current user. What ist the difference between deinstalled with script and deactivated in terms of app activity?
Best regards

it is very strange that they were on the home screen. But they may appear in settings as not installed for current user.

Yes, in settings they appear as not installed for current user. Does this mean, they are still on the phone and would be available for another user?

...uninstall -k --user 0 com...

User 0 is the default user. If you were to create anther user in settings, the apps would be there. So the apps are technically still on the phone and taking up space in the system partition. But they cannot run for user 0.

Thanks for that! Now this is clear for me. Have a good day.

Cheers, Ernst

To clarify, although developer access and usb debugging are essential, is it true that the phone does not need to be OEM unlocked or rooted.


Yes. You do not need root access (and therefore no unlocked bootloader)

1 Like

Thanks I was concerned about directing someone to do a degoogle.

Thanks for that little script, it is definitely helpful :slight_smile:


Encourage by this topic I’ve installed ADB on my Raspberery Pi.

Looking at the README.md I noted all the instructions for installing on various platforms so here’s a link to my install and using wifi rather than cable for the Raspberry Pi 4 Buster.


In your script why the -k ?

 uninstall [-k] PACKAGE
     remove this app package from the device 
     '-k': keep the data and cache directories
1 Like

To be honest, I have to include it but I don’t know why. If I exclude it it gives me some weird Java exception error

1 Like

I imagine that it also helps if you have to undo any of the uninstalls. The data will still be there.