Data connection on Co-op Mobile not working


I’ve just got a new Fairphone and I love it :slight_smile: I’ve never had a smartphone before so it’s all new to me but I think I’m working most of it out. However, although I’ve been able to use wifi with no problems, I don’t seem to be able to establish a data connection (3G). I have read all the relevant forum entries I could find here and followed the suggestions within, but am still having no luck. When I try to establish a connection, the data connection icon in the pull-down menu gets a small blue symbol in front of it - looks a bit like a SIM card.

My network provider is the Co-operative and I first filled in the webpage, received the APN details and followed the instructions to complete setup, but I couldn’t get a data connection. I then checked the APN settings I’d received against the manual ones at, the only difference was the name - I changed it to the one in the manual instructions to see if it made any difference but it didn’t.

I’ve also checked my SIM management settings - I only have one SIM card, I had my mobile number ported across from the network I was previously on (Orange) and although this happened successfully, the number showing under SIM information was still the one that came with my Co-op SIM card, so I changed it manually to my old (Orange) number. This didn’t help. Under Mobile Network Settings I also tried choosing my network operator both manually and automatically, but it didn’t make any difference. Additionally I restarted my phone several times throughout the processes above to see if that triggered anything, but it didn’t.

Does anyone have any suggestions? I really hope someone can help, this is starting to drive me a bit mad!
Many thanks,
Jane :slight_smile:

Hi Jane,

maybe a stupid question: did you check if you have 3G activated for the SIM slot you are using for your CoOp SIM?

Welcome to the forum, hope all will be well once you’ve sorted this out.

When you used the phone co-op form to get your settings did you choose the Pay Monthly or Pay as you Go (I believe the settings are slightly different but don’t know for sure).

To make sure you data connection is enabled, go to Settings > More > Mobile Networks > Data Connection and make sure your SIM is selected.

Also ensure the 3G service is confirgured for your SIM by going to Settings > More > Mobile Networks > 3G Service > Enable 3G and make sure your SIM is selected

Hope this helps

Hi Chris and humorkritik, thanks for the tips. I think I had already done the things you described, but I tried them again just to be sure, and also because I finally managed to upgrade to the current OS since my last message (it took a few tries) - I wondered if that might also make a difference. Sadly, it hasn’t, and neither has following the steps you suggested. Chris, I’m as sure as I can be that I chose Pay as you Go when I used the Co-op form, as that is the plan I’m on - but this is based more on assumption than having any actual clear memory of doing so!
I think I might need to phone the Co-op…
Jane :slight_smile:

This has just been resolved, I don’t know why (maybe I didn’t select the correct ones originally) but there was some problem with my APN settings - I phoned up the Co-op and they resent the settings to my phone, now my data connection is working fine and dandy :slight_smile:


Good to hear, you sorted things!

This topic is now closed. New replies are no longer allowed.