Connecting to company wi-fi fails

I have the same issue with my company’s WiFi, but I’m on a FP5. I’m using the same authentication methods and no ceritificate validation. Immediately it says ‘Failed to connect to network’. Manually adding the network does not help.

I moved your post out of the FP4 topic. You might want to describe a bit more what the issue is

Just a random guess: You might want to check (and try out the other option) what your setting with regard to “randomized MAC” vs. “device MAC” is.

I experience this issue at my workplace too. You try to connect to a PEAP secured network. You type in your credentials. Username Password, MSCHAPV2, and not using certificates. When pressing connect, insthead of even a brief attempt at making a connection, it just fails instantly.

I would consider this quite a serious issue, since for some, it would be quite essential to connect to wifi at work. I personally just resorted to using my work’s guest wifi.

Have a look at this topic:


Thank you, that helped.
It worked with the following settings:
EAP method: PEAP
Phase 2 authentication: MSCHAPV2
CA certificate: Use system certificates
Domain: I found this on our intranet
Identity: username
Password password


It worked!
Same series of settings here too. I had to use system certificates. And I just tried my company’s top level domain, and it worked.

As a side note, seems like this is Google’s doing to disallow users from making “insecure” connections. Though I wish android gave you an explanation or some brief error message, insthead of just instantly failing and leaving the user in the dust. But I guess that is to be discussed on some other Android forums. Thanks for the help!

1 Like

Yes, I’m very glad it now worked out for you! Although I agree with you regarding the explanation, letting the device check the certificate is imho really important security wise!
As you’re using company WLAN it might even include company credentials. And not checking the certificate would make it really easy for an attacker to mimic your company wifi and tricking your phone into giving out (at least a brute forcible hash value of) your credentials - even without any interaction or notification on your side.

1 Like

Hey, I thought I’d put this screenshot here to help those out who might understand it better when they see it.

1 Like