Connecting to eduroam on Fairphone 4 with Android 13

Greetings from a Fairphone 4 lover.

Since my upgrade to Android 13, some time ago, I seem to be unable to connect to WPA2-Enterprise environments, especially when the SSID ‘eduroam’ is present.

I use PEAP as EAP method and MSCHAPV2 as Phase 2 authentication. I use ‘Do not validate’ in the ‘CA certificate’ field and leave the ‘Anonymous identity’ empty. Of course, I fill in the Identity and Password fields, using credentials that are verified to work on a macOS system.

After pressing Connect, the phone immediately says ‘Failed to connect to network’, almost instantly. Like it never really tried.

Any hints are welcome.

Thanks you and regards, Erik-Jan.

What did you fill in the line Domein?
Bij Ziggo moet dat Wifispots zijn.

Hi Lidwien!
The field Domain is not visible when I select ‘Do not validate’.
My colleague, using an Android 14 system, uses exactly the same setting as I do and for him it works like a charm.
I also noticed that on general Android 13 platform there is mentioning of ‘issues occasionally preventing connection to WPA2-Enterprise networks in certain conditions’, so maybe in the current version of Android 13 on my FP4 (build dated 13 March 2024, with security update of 5 March 2024) there is one of such issues…
Thanks, Erik-Jan.


Did you already try to connect using the geteduroam app? I always found manually configuring eduroam a pain, but for me the app works flawlessly. Unfortunately, not all institutions support it, but it might be worth a try.

1 Like

Thank you, @keraton. Geteduroam is a nice app indeed. Only, my institution is not listed in the app…

Hm, too bad… I know some people in my institution who own an FP4, so I can ask one of my colleagues if they experience this problem as well. If they are on the same Android version and do not experience this issue, it may be related to institution-specific settings.

Thank you, @keraton . That would be appreciated.

A post was split to a new topic: Connecting to eduroam fails

Just a random guess: Have you checked (and tried out the other option) what your setting with regard to “randomized MAC” vs. “device MAC” is?

Thanks, @urs_lesse. I tried that but that did not change the behavior. It instantly fails, like before, without trying.

1 Like

Have you checked/asked if there is official documentation from your network people? The setup you’re describing also sounds terribly insecure and at best good enough for a short test: No CA validation, no anonymous identity! Anyone with a better Wifi-AP and some knowledge could steal your credentials.

I’m using eduroam with my FP4 for a long time without any particular issues. In the beginning I configured it manually, but the geteduroam app is certainly a great help to configure it securely from the start.
You could also try to request inclusion in the app from your institution. That would benefit everybody using it.

1 Like

The colleague I mentioned is apparently out of office, so unfortunately I can’t ask it right now.
Anyways, it seems that a solution / explanation was found in the topic that was split from this topic:

So it might be that Android refuses to establish an insecure WiFi connection, without telling you why.


I use EduRoam on my FP4 with Android 13 - so, there is no fundamental problem on the phone side.

From my experience, EduRoam can be very whimsical depending on your home organization or the organization where you are trying to use it. Try connecting to EduRoam using another device: laptop/another phone to check you can connect to EduRoam in principle.

1 Like