Compass does not work correctly

In my FP2 the compass turn only few degrees, it’s allways W-NW, neither with Google Maps, nor with Compass apps. Any suggestion ?


I have a similar problem. The app HERE Maps tells me to calibrate the compass by turning the phone in a figure-of-8 gesture until it vibrates, but it never did. The compass direction did then improve though.


I have the same problem.

In addition the direction seem to jump around a lot in for example google sky map. Vertical rotation works smooth but horizontal direction is very jumpy. See

I successfully calibrated my compass using Google Maps:

Open the Google Maps app and then follow these directions:

  • Tilt your phone forward and back
  • Move it side to side
  • And then tilt left and right

You may need to repeat the steps until your compass is calibrated.


See the linked site for a visual representation of the steps. Didn’t even need to repeat the steps.

1 Like

I repeated the steps and I think it got some improvement but the google sky map app still stutters alot.

Setting Damping to High and Sensor speed to Slow helped some but it’s still very jumpy.

I had big problems using the compass. I tried two different apps and they both behaved the same. The compass was very jumpy and would not stabilize even when the phone was lying flat on a table. Then I turned off the Acceleration sensor and the compass works very smooth. Star Walk on the other hand has problem finding directions…

Hi !
I’ve the same problem with the HERE app who ask to calibrate the compass but no results…

1 Like

Hi all,
my FP keeps telling me that I need to calibrate the compass. I can move it all day long using the gestures it shows but it won’t be calibrated. Anyone found a solution?

I also have troubles with the compass: I tried with two apps satstat and compass and compared with other phones: the magnetic field reading is instable and inconsistent (it changes direction turning the phone!, value varies between 80 to 160uT). It looks like some apps can compensate this with their own calibrations after some tilting of the phone, others not.

I’ve got the same problem with the magnetic sensor. Compass apps and Google Maps tell me the sensor accuracy is unreliable and Sky Map is very jumpy, thus unusable. Calibration with the suggested gestures doesn’t work.
I’m pretty sure it did work some time. Maybe before having updated to 1.3.6?

Is that a common issue or do most FP2s have accurate magnetic sensors?

1 Like

Works without Google-maps too, just start a compass


My problem is that my compass is almost always about 30-40 degrees off. (I checked with a real one.) Sometimes the app tells me that I need to get rid of some kind of magnetic field that would disturb but there is nothing magnetic around.
I do not know: Could the sensor be discalibrated (or so) through any process?

Not necessary magnetic but iron or steel is enough to disturb the compass.


strange enough, there was nothing made of steel or iron in the telephone’s vicinity. At least nothing I was aware of. :S But thanks for the hint, anyway. :slight_smile:

Quite off-topic but anyway: Has anyone an idea why I did not receive that badge for replying via email? :thinking: :smiley:

Edit: I mean this one:

Back to “on-topic”:

I got the same problems :-/

Same problems here, making the calibration movements does not fix it.

Hi there !

It seems that the compass is correctly calibrated but some apps (HERE, SKY MAP…) doesn’t get the good information about that and continue to indicate that it is not calibrated

I just tried Sky Map again and it seems to work fine now. The Jumpiness is gone and the stars are in the right position again :wink: even though Sky Map still says that the compass has to be calibrated.
So I think @ThYbOt your assumption is right.
Still I’m asking myself what caused those problems.