Command "Fastboot device" is not recognising the FP3

Hi all

I followed these introductions:
After entering “adb reboot bootloader” the FP3 is booting in fastboot mode.
But if I enter “fastboot device” my console says: “< waiting for any device >”

I am using Windows 10 and the platform-tools_r30.0.5-windows.
I tried with 2 different Laptops, all its USB-Ports (USB 2, 3) as well as an old USB2 Hub…
I did not press any buttons (Volume up/down) after starting the fastboot mode on the FP3…

Do you have any further ideas?
Thanks in advance and best regards
dA LoL

Check “Windows Device Manager” if the FP3 is recognized correctly, and if the appropriate driver has been applied/used for fastboot. (The device ID for fastboot is different than the one for ADB, which results in “new hardware found”.)

-> Listed unter “Universal Serial Bus Devices”
It says: “This device is working properly.”
Driver Date: 21/06/2006
Version: 10.0.19041.1
On “Update Driver”-Click, it says: “Best driver is already installed”

Is it what you have expected?
How can I check if the appropriate drives has been used for fastboot? How to get the device ID for fastboot and the one from ADB?

Seems to be OK then. Have you enabled “USB debugging” before on the FP3?

They are listed in “Properties” -> “Details” for every device that is working properly. You might want to google the respective device ID and find out if it is the one for ADB or for fastboot. But just take this info as a sidenote, because it is no longer important to solve your issue…

I’ve seen this kind of symptoms quite often in the /e/ forum. If “adb reboot bootloader” worked and a subsequent “fastboot devices” didn’t - on windows - that could always be fixed by following these instructions:

In your case it does seem to have a driver, but I could imagine it’s not the correct one. The driver date is “21/06/2006” but Android wasn’t around before 2008, so I assume that driver cannot handle smartphone specific stuff (just a guess, though).

BTW, in your first post you wrote “fastboot device” but I only know of “fastboot devices”, but that might be just a typo.


Yes, now I see…
According to andrelam’s post, I installed the tools and followed the tutorial. But on the step Select Android device, there is no Android Device to pick for me…
If I click on ADB Interface, some old “Samsumg” Entries are available and I think I should not use that one:

What could I do next?

BTW, yes it was a typo.

Yes, USB debugging is enabled.
Since I tried some things according to Ingo, the FP3 entry in the Device Manager disappeared (if the device is started, it was like that before) :-o
But if the device is started in the fastboot mode, then I have this Android Icon according to the other post and here I struggle according to my other comment…

Looking through the /e/ forum topic it sounds like installing this driver first to be a good option:

This is what I did… I even installed the Android Studio…

Ok, sorry, didn’t catch that.

Unfortunately I don’t know enough about Windows to offer more help.

Sometimes less is more.

1 Like

Howdy :slight_smile:
Thank you everyone so far…

In the meantime I gave it up with Windows 10 and I use an old laptop with a running LXQt. The good news, fastboot devices is recognising my FP3.

Next problem:
fastboot flash boot lineage-16.0-20201207-recovery-FP3.img
fastboot: error: Couldn’t parse partition size ‘0x’.

I do not really understand these boot_a/b commands, but with them I have the following result:
fastboot flash boot_a lineage-16.0-20201207-recovery-FP3.img
Sending ‘boot_a’ (65536 KB) OKAY [ 3.267s]
Writing ‘boot_a’ FAILED (remote: ‘Partition flashing is not allowed’)
fastboot: error: Command failed

In the meantime I’m googeling, hopefully you folks have also an idea…
EDIT1: Realized, that I have to fastboot oem unlock… Then I was kind of happy, that I received new steps, but then… weird… it rebooted 3 times and now I have the "standard preinstalled system again, so I have to repeat all the steps again?!? :-S I keep you all updated :smiley:

Possibly you didn’t unlock your bootloader yet?
Does it say Device state locked or unlocked on the phone in Fastboot Mode?

Hi AnotherElk

Thank you for the support, as wrote in my last “Edit”:
Realized, that I have to fastboot oem unlock… Then I was kind of happy, that I received new steps, but then… weird… it rebooted 3 times and now I have the "standard preinstalled system again, so I have to repeat all the steps again?!? :-S I keep you all updated :smiley:

Now I’m back again and the fastboot on my FP3 shows: Device State unlocked! :slight_smile:

fastboot flash boot_a lineage-16.0-20201207-recovery-FP3.img
Sending ‘boot_a’ (65536 KB) OKAY [ 3.587s]
Writing ‘boot_a’ OKAY [ 0.648s]
Finished. Total time: 4.301s

Juhu :slight_smile:
Next step is to:
With the device powered off, hold Volume Up + Power. Release when boot logo appears.

There is no boot logo, but a text “<!> the boot loader is unlocked and software integrity cannot be quaranteed. any data stored on the device may available to attackers. do not store any sensitive data on the device. Visit this link on another device…” within seconds my FP3 starts normally… Ohh wow new screen appeared…after 10 times trying…

So now I can copy the zip to the phone…
I thought it was all good, restarted the phone, still no LineAge on it :frowning:
So another try… I remember how much easier it was on FP2 :smiley:

Another edit: I did now this:
fastboot flash boot_a lineage-16.0-20201207-recovery-FP3.img
fastboot flash boot_b lineage-16.0-20201207-recovery-FP3.img

And now after pressing volume up and start, I see the recovery screen of LineAge OS -> Now I feel save and much better! (Even the Linux Machien shows me an error: "Unable to open MTP device “002,026”…)

Now again, the zip file is copying to the FP3 using adb sideload…

LineAge is installed - thank you everyone who was supporting me!
Super cool community, happy again 4 having a fairphone!

@Admins - you can now close that topic :slight_smile:

Best Regards
dA LoL


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.