English

Charging via USB Port not working

Hi Fairphone community!

I’ve got 2 problems with my FP2 (apart from which i’m really happy with the phone, especially after the android7 update!). The first one is not really a big deal and probably a software issue, but i’ll state what happened. Might have something to do with the “real” problem…

I dropped my Fairphone into a river during a kayaking trip about 4 month ago. I retrieved it after maybe 2 seconds, immediately disassembled everything and dried it for 2 days in the (indirect) sunlight since I had nothing hygroscopic on hand. Everything was working fine afterwards, only since then the phone app doesn’t pop up anymore when a call is incoming. To answer a call, I have to open the phone app manually, tap “go back to current call” (or something like that, my phone is set to German) and then I can pick up the call. Could be a coincidence (at least the software developer in my head keeps telling this) but this behaviour occurred for the first time after this little accident. For me this hickup is less pain to deal with than to reset the phone, so I just left it like that.

A couple of days ago the charging of my phone via usb stopped working properly. At first it looked like a loose connection (charging light flickering) and later it didn’t charge at all. When I connect it to my laptop it tells me something about overvoltage (no proper translation possible – error message is in German again).

  • First thing I tried was an older battery – same result.
  • I disassembled the phone, cleaned the usb port and the connection pins from the bottom module – no difference.
  • Then I build / hacked something together with an old usb wire to charge the phone via the connection pins on the back – it’s charging very slow but at least I can use the phone.
  • I ordered and installed a new bottom module (after problem #1 I won’t demand any kind of warranty :innocent: ) – SAME PROBLEM? What the …?

Since I ran out of ideas what could cause the problem or what else I can try to fix this I thought it might be worth to for help :slight_smile: Charging my phone with this selfmade thing might be nerdy but is not really practical :grimacing:

Many thanks in advance for potential help!
Johannes

The phone app issue is usually fixed with checking the notifications and permissions settings for the phone app.

Does the laptop or the phone say that?

And you don’t say anything about charging from a wall plug. If that works normally then I’d obviously suspect the laptop, not the phone.

Since you live in Germany you’ll probably have some #fairphoneangels not far from you. They could help you test whats wrong by exchanging modules until you find the culprit.

2 Likes

The laptop shows the overvoltage error. Unfortunately the phone is not charging from a wall plug as well.
I also tried different chargers and cables.

This did the trick for my first problem. Thanks a lot!

Then it can still be the battery or motherboard.
If you open up the phone do you see any signs of water damage (sediment, corrosion)?
Maybe cleaning that with alcohol could help.
You could even put all parts except the battery in an alcohol bath for a while and then let it dry for a long time again.

I already tried different batteries since I got a spare one. If it was the battery, charging from the back pins wouldn’t work as well.
So in my opinion it has to be some connection which is causing the trouble.
The only visible sign of water damage is the colored indicators which I would’t really call damage.

Well, it actually sounds a little bit like the story in


In that case I’m afraid it might be the core module…

I would not recommend that.
The pogo pins are greased internal. With a bath in alcohol they will dry out, the shifting of the pins generates abrasion and the internal resistance gains. That could end up in strange behavior related on the changed signal voltage level. From the electrical view, a variable connection via a pogo pin is critical in view of resistance value.

3 Likes

Do you have the opportunity to change the bottom module, as there could be a corrosion due to the water damage with the µUSB port?
Any Fairphone Angel near your location?

As stated above, I already ordered and installed a new one which did not help…

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.