Not charging from laptop, possible help in London?

As of today it seems that I can only charge my Fairphone from a wall socket, not a laptop. When my Fairphone is connected to a laptop the battery icon is highlighted as if it were charging, but the level of the battery doesn’t go up - in fact it soon dwindles to zero.

I’m not aware of any Fairphone Angels where I live (Leamington Spa, Warwickshire, UK). However I’m going to be in London between 21 and 25 September - are there any Angels in the capital?

Have a look at the #fairphoneangels map … there seems to be somebody in London you could contact.
(Additionally I edited the topic title a little.)

Tagging @anthony :slight_smile:

Hi Louisa,

Sorry to hear about your charging troubles!

There could be a few reasons for this. Firstly, are you using a data cable, or a charging cable? Usually data cables are a bit more expensive, and allow files to be transferred between the computer, and better reliability with charging.

Can you have a look at this article and see if it helps:


Which version of the OS are you using ? Is it android 7 beta ? This issue is identified on it.

What you can first try is :

  • If not already enabled : enable developper settings in settings
    menu. By repeateadly tapping “build number” in that same settings menu
  • then go into this developper menu, and change “USB Mode” to anything
    (charge only, MTP, midi…). It should activate the charging animation

There’s also a quick and much dirtier fix if the above doesn’t work.
It worked great for me. I had to use it, because my battery was so low that it wouldn’t give me enough time to go into developper menu before switching off.

  • Cut a little strip of paper, ~ 5mm wide. Then place it on the computer side of your charging cable, so it covers the 2 middle metal connectors on it. Maintain it in position while plugging the cable into the laptop.
  • And voilà, you covered the data pins, and can now charge again.

It’s one that enables file transfers so I suppose it’s a data cable (not that I can recall how much it cost).

The problem seems to have resolved itself since the latest FP update. That said, the phone was very intermittent in charging from my work laptop today but maybe that was because I was on a train and the laptop wasn’t plugged into an external power source. This was a bit of a last resort, after I’d arrived at the railway station with my phone battery at 60% and none of the power sockets in the waiting room and Starbucks apparently worked. Or has the FP now become worse at charging from a power socket?

As it seems to be so intermittent the reason could also be a broken bottom module (symptoms may be very low charging power, intermittent charging and charging might change if you soft press on the plugged in charging cable from top or bottom).

are you using android 7 beta ?
latest version does indeed solve charging issues.

1 Like

Not sure. How can I tell?

I hope it’s not that again - I had to change the bottom module last May. Unfortunately I was unable to follow the instruction video for disassembling the Fairphone so I ended up travelling to the Phone Co-op’s HQ in Chipping Norton to find someone who could do it for me.

Very frustrating that the take-up of the Fairphone has been so low in the UK. Admittedly the Phone Co-op hasn’t advertised it much, or indeed at all outside of the pages of Positive News and the Big Issue. Personally I’m surprised that the FP hasn’t found a market in places that are associated with support for alternative lifestyles, Green politics and the Transition Towns movement. E.g. Brighton, Bristol, Cambridge, Hebden Bridge, Machynlleth and Totnes. Or if it has, why are there no angels in these places?

I’m now stuck with the reverse of the original scenario: my Fairphone charges from a laptop but only intermittently from a wall socket. Admittedly even at the best of times I’ve had issues with charging from the mains. I have found (by trial and error) that the phone has to be at a certain distance relative to the socket to charge effectively and often I have to check (and double-check) on its progress.

I’ve come to the conclusion that the charger I was using with the wall socket was faulty (despite being less than two years old). I bought another one (from a petrol station, this being the only place I could get to after work) but this seems to be no better for charging the Fairphone, although it manages to charge my Fitbit OK.

Compare and contrast with my old Nokia: it always charged from the mains without any hassle over positioning, it only needed charging every two days at most and I never had to replace any chargers. Is this progress, I ask myself?

This week colleague lent me a charging cable which worked well with the charger I bought at the petrol station; in fact I was able to charge the Fairphone from every socket I tried, with no issues with positioning it at a certain distance. Other than that this charging cable being white (as opposed to black) and thicker, I couldn’t see any obvious difference between it and the previous one I used.

Unfortunately as of this evening I’m back to square one. Although I was able to charge my phone to 100% on a train journey to Bristol this morning, on the return journey the battery icon displayed the lightning flash symbol as if it were charging but the level of the battery dwindled to below 20%. On returning home I connected the phone to my laptop, but the problem continued. At the time of writing my phone has been attached to my laptop for an hour and a half but the battery level is zero - yet still the phone displays all functionality.

Does the phone really need a new charging unit, less than 18 months after it was replaced? Or is it the battery? Or do I need to try yet more chargers and/or cables to find a combination that works for more than a few days? Or is it something else?

Please, please reply!!

I can’t find any mention of “build number” in the settings menu. By “developer menu” do you mean “developer options”? I tried changing “Select USB Configuration” from “PTP (Picture Transfer Protocol” to “Charging” but the phone then refused to charge at all from the laptop. Although at least this time it wasn’t pretending to charge, so give it credit for being honest…

Settings->About phone->build number (both at the end of the options list)

1 Like

FP2-gms-18.04.1 release-keys
Tapped this once and got the message “No need, you are already a developer”. What does that mean?

It means you can already access the developer options, because you have tapped the build number before.

I took the old charger to my local repair cafe today. Unfortunately the repairer I saw was unable to detect what was wrong with it. He could only suggest that I take my Fairphone “back to the shop”. If only it were that simple!

The last two nights my Fairphone has been very slow to charge from the wall socket overnight. Whereas previously it’s always reached 100% in time for the alarm clock, last night it went from 65% to 75% during eight hours. Later on today it went from 8% to 30% being charged from a socket during a 30-minute train journey. This doesn’t make sense at all.

@anthony, are you around in London next weekend (16-18 November)?

Last night the battery level went from 75% to 40%. The graph (at Settings > Battery) displayed a steady decline and yet the battery icon was displaying the charging symbol. I moved the FP to another wall socket and managed to increase the battery level by a few percentage points, then moved it back to the original socket whereupon it got up to over 50% while I was having a shower.

Later on this morning I plugged the FP into a third socket whilst I was watching TV. An hour later, although the battery icon was displaying the charging symbol, the battery level was only 65%. I checked Settings > Battery and saw the message “Not charging” above the graph. I left the FP for another couple of hours, at which point the battery level was 15% but this time Settings > Battery was displaying the message “Charging from AC”. I moved the FP to my laptop and it started charging straight away, which was confirmed by Settings > Battery displaying “Charging from USB”.

I’m utterly confused. If the FP is saying it’s charging but isn’t (or vice versa), surely that’s a software rather than a hardware problem? Is there any reason why the FP should charge from one socket but not another?

I don’t know how the FP will fare being charged from a power bank. I have a train to catch later today and I’ve bought a mobile ticket but I’m not taking any chances - I’ve printed out the tickets.

Yes, software problems could lie at the heart of this. If your hardware is constantly working hard it will consume more power than chargers can provide. This happens to me when I charge in my car while playing music, Google Maps navigating me and the screen brightness set to full. Are there any apps running on the background that keep your device busy or waking it up constantly?

Another option is that your battery is simply worn. This could happen within 18 months, although I haven’t heard to a battery wearing to such extent that it’s as unreliable as you describe. Equally, a broken bottom module could make charging unreliable (interrupt frequently). Or a broken core module could force the device to charge at a much lower current than it should.

Really, you should be getting in touch with Fairphone support about this. These are serious issues that need to be recorded with them even just for warranty purposes.