Can't install open gapps on 18.10.0 (FP open)

After I updated TWRP to version 3.2.3-0 it worked. Thanks!

Thank you. With the actual TWRP it worked for me too. :slight_smile:

Yep, with 3.2.3-0 is fine, but because I need my phone today, I do a restore back to Android 6 (TWRP restore, which I made before the update to Android 7).

I download the app and do first to TWRP update, then the OS update Android 6 --> 7, then the gapps installation.

On the OS update I got a “Zip signature verification failed” with TWRP 3.2.3, but I deselect the “Zip signature verification” with the OS update file from the /cache/ folder and then it works.

Thanks for the hints

gruss ivo

I downloaded the latest version of TWRP from the Fairphone device, but I cannot open it because all my google services are failing, including TWRP apparently. Specifically, I cannot understand the instructions given on the stackexchange site. They say:

" installed after selecting Images in the Install file browser."

What file browser? What menus are they talking about?

EDIT: I manage to run TWRP and downloaded the .img file of the latest release. I still don’t get the stackexchange instructions on how to install it though =/

They talk about TWRP.
TWRP shows ZIP files to install by default. If you want to install an IMG file, there’s an “Install Image” button which switches the view to IMG files, so you can select the one you want to install.

Here’s a guide (different device, but TWRP works the same) …

Thanks, that worked for me too! Only XposedGmsCore-UnifiedNlp is not working correctly.

Check step ‘UnifiedNlp location’ failed. Your location were not found. Make sure you added at least one backend

Also the microG self check says that UnifiedNlp is not registered and that getting a location wasn’t possible.

I have multiple backends installed via F-Droid and rebooted multiple times. I never had this problem with Android 6 and am now facing this on two Fairphones 2. Has anyone an idea what to try next?

Hi, I’m wondering if you’d be able to update Sibon after upgrading TWRP. Maybe only next upgrade will show, but Fairphone @jftr should be aware that the chosen version of TWRP may not be the best choice…

Thanks. I tried following the instructions and I think I managed to install the latest version on TWRP.

Unfortunately, I am still unable to install opengapps. No matter where I put the zip file, I cannot access it through TWRP. The program only lets me navigate among folders which I cannot see when I connect the phone to the computer, or when I navigate folders within the phone. I have removed the sd card I had (made the forget it) and download only to the phone’s internal memory, but still I cannot see anything with TWRP

I’m using FP Open with a minimal set set of Google apps using opengapps (pico). Yesterday I upgraded to the new OS version 18.10.0, but forgot (in al my enthusiasm!) that I also had the opengapps installed. After the upgrade I seem to have 2 issues that might be (or not) related.

  1. The Google apps are no longer working. I guess I could fix that by flashing a newer version of the opengapps for android 7.1 should fix that, but flashing doesn’t work. When in recovery mode, I try to install only the “” and it fails, saying:
Verifying zip signature...
Zip signature verification failed!
Error installing zip file '/sdcard/'
Updating partition details...

When I try to flash using the last OTA zip file (18.04.1, android 6) AND the opengapps zip, it tells me the same, and additionally complains that the OTA zip is also invalid:

Verifying zip file...
Zip signature verified successfully.
This package is for "FP2" devices; this is a "".
Updater process ended with ERROR: 7
Error installing zip file '/sdcard/'
Updating partition details...

So now I can’t upgrade my opengapps, and they no longer work. I figure that I might be able to fix this by flashing with the 18.10.0 image when it becomes available, but it isn’t (yet?).

  1. The upgrade to 18.10.0 seems to work fine otherwise, but the phone is warm, especially near the camera module. The battery is also draining from some process. The Settings->Battery screen lists the “Miscellaneous” service as the main battery consumer after leaving the phone idling for a while. Maybe it’s some unlisted Google app that’s broken after the update and keeps spinning, but I 'm not sure.

Any ideas whether the problems can be fixed, and might be related?

I moved your post here. Please have a look at the marked solution.
The magnifying glass at the top right of the page is a search function :wink: .

I tried the search but was unable to find this thread ;/
I upgraded twrp and after that, I was able to upgrade opengapps too. Thanks! I’ll wait for a bit so the CPU can cool off, and see if that problem is also resolved now.

Alternatively you can connect your phone to a computer via USB, start TWRP, activate “ADB Sideload” in TWRP and then install your ZIP file by using adb sideload on the computer.

1 Like

I’ve also successfully updated OpenGApps after figuring out how to update TWRP. I’m sure these things are made as straightforward as is reasonable but since I find I only need it once or twice a year I can never remember how to do it and any notes I make are often superceded by the time I need to look. Lots of internet searching and reading again… Otherwise no problems.
I also had a very hot phone, quickly discharging, by the end of the whole updating process. But once everything was done, I rebooted and it seems to be “normal” again. Mind you, I have a 3-year-old battery which seems to be getting rather tired.

Thanks, but the abd webpage seems only to have .exe files and I am not using Windows. I am using Linux. Do you know if the solution you proposed can be implemented in Linux? I see no linux download links on the adb website.

Ok, second try …

‘For many Linux derivates you can find small packages for the ADB without the need for installing the whole SDK. For example, for most Debian distros you will find the packages “android-tools-adb” & and “android-tools-fastboot”.’

If in doubt, an internet search for the name of your Linux distribution + “adb” should help.

1 Like

Thanks for the advice. I tried enabling the Sideload from TWRP, but after a long time loading, it says it failed. The last message was “Starting ADB sideload feature”. I have adb command working on linux, but I was never able to connect to the device.

$ adb shell

Gave me this:

error: device unauthorized.
This adb server's $ADB_VENDOR_KEYS is not set
Try 'adb kill-server' if that seems wrong.
Otherwise check for a confirmation dialog on your device.

And trying
$ adb devices
Gives me:
List of devices attached
1baf6ee unauthorized

Following advice from here and I managed to get the device recognized:

adb devices
List of devices attached
1baf6ee	device

I tried to activate adb sideload from twrp again but, again, it gets stuck on the “Starting ADB Sideload feature…” message until it says it failed. After it fails, the outout for adb -devices is:

adb devices
List of devices attached
1baf6ee	recovery

So, it changes from “device” to “recovery”.

And I don’t seem able to use adb at all:

adb shell ls
error: exec ‘/system/bin/sh’ failed: No such file or directory

I didn’t do much with ADB Sideload up until now, but I think after this message you are supposed to just ‘adb sideload’ your ZIP from the computer side … which you didn’t … which is why it fails after some time.

Just my reasoning, could be wrong, I can’t check just now.

I think ADB Sideload doesn’t enable the whole ADB command set, that’s only available when the OS is booted.

I finally managed to sideload the opengapps zip file into the phone, but the “zip verification failed” message appeared. I tried with two different zip files that I just downloaded. I am using TWRP 3.1. I should be able to make it work, right?

Nope. You need the latest TWRP (direct link).

1 Like

I had downloaded that before, started the phone with TWRP, clicked on install and found the .img file of the 3.2 version. Everything proceeded without any error messages, but when I reboot and I start TWRP again, it still says it’s version 3.1.

I am flashing the image to recovery and not to boot. Is that OK?