English

Can't install open gapps on 18.10.0 (FP open)

I didn’t do much with ADB Sideload up until now, but I think after this message you are supposed to just ‘adb sideload’ your ZIP from the computer side … which you didn’t … which is why it fails after some time.

Just my reasoning, could be wrong, I can’t check just now.

I think ADB Sideload doesn’t enable the whole ADB command set, that’s only available when the OS is booted.

I finally managed to sideload the opengapps zip file into the phone, but the “zip verification failed” message appeared. I tried with two different zip files that I just downloaded. I am using TWRP 3.1. I should be able to make it work, right?

Nope. You need the latest TWRP (direct link).

1 Like

I had downloaded that before, started the phone with TWRP, clicked on install and found the .img file of the 3.2 version. Everything proceeded without any error messages, but when I reboot and I start TWRP again, it still says it’s version 3.1.

I am flashing the image to recovery and not to boot. Is that OK?

Hi all,

I had the same trouble with installing opengapps after updating to the latest Fairphone Open OS (Android 7.1.), so I followed the advice above and installed the latest version of TWRP 3.2.3-0
Since then, my FP2 will boot showing only the TWRP screen, I cannot figure out how to get to the normal phone function. Any help greatly appreciated. Thanks, Yves

Sounds like you installed TWRP into the boot partition, but it needs to go into the recovery partition.
If so, here’s another case … solution in the end was to wipe the phone (deleting all data) and install from scratch …

… many thanks, yes, you are right: after installing it to the recovery partition with no effect (i do not have an additional sd card in my fp2) i installed it to boot. seems like that was a mistake :slight_smile:

I am trying to manually install Fairphone Open OS (https://support.fairphone.com/hc/en-us/articles/207914363), I hope this will work

… the procedure described under (https://support.fairphone.com/hc/en-us/articles/207914363) did seem to work in itself. However, my FP2 has now been trying to boot for about an hour or (Fairphone Logo on the screen, and blue circles pulsating from left to right). Surely, that can’t be it? Many thanks for any help …

Which binary image did you use?

Hi, I used the binary linked in the link below, that being [Binary image] Fairphone OS 18.04.1 (Android 6.0)
Does that clarify things? Many thanks …

You started out from Fairphone Open OS, right? If that is that case, data on your data partition may be incompatible with the Fairphone Regular OS system image (which you appear to have used). Switching between the two normally requires wiping the data partition for this reason. In your case, I’d suggest first trying whether the binary image for Fairphone Open OS (Android 6 18.04 or Android 7 18.10) does give you a booting system.

1 Like

Fantastic advice, many thanks, I used the Fairphone Open OS binary for Android 7 and now get a bootable system. Pheew … :grinning:
One bug immediately gets my attention: on pressing the power button and selecting “shut down” the phone restarts. Nevermind.
Next mission: install the latest OpenGapps. I am following the procedure described here (https://twrp.me/fairphone/fairphone2.html), with no effect: the version of TWRP stays 3.1.1.0 and is not updated to 3.2.3.
Any ideas on that would also be greatly appreciated …

You won’t believe the workaround: Enable the torch function before shutting down.

The first 10 or so posts of this topic have information that can help you get installed from an image file in TWRP itself. After installing, you will need to reboot into TWRP (rather than the normal system) to finish the install (otherwise it reverts).

1 Like

Many thanks again. I had over-read that TWRP needs to be rebooted “in itself”. For others, this means, in TWRP, you select “reboot” and then “recovery”. GREAT STUFF. And now, with all this working again: what is a good way to make a backup under Fairphone Open OS?

I’m not an expert in back ups, and it’s a bit off-topic here, but suggestions (any of which may be a solution)

  • Search the forum for suggestions (not sure whether this has been tackled recently)
  • Manually copy all the files in /data/media (e.g. photos) and use TWRP for the rest - there’s a recent guide here.
  • Look into MyPhoneExplorer (warning: proprietary software), which seems to be a popular choice amongst veteran forum members.
2 Likes

hey were can i find any file of twrp to download! on the official side i cant find it…

TWRP downloads for the FP2 are found here if that’s what you’re asking.

Than you!
now there is a new problem… i tried to install the img via twrp but when i reboot the phone and start it to twrp it has changed nothing…

You have to reboot into TWRP right after updating otherwise the OS will overwrite TWRP again.