Can't get internet without wifi

I used to be able to access the internet via 3G (I had many warnings about reaching my data quota), but at some point this feature stopped working. Sometimes I can’t access the internet even when my phone says that wifi networks are available (this always seems to happen on a train).

I’ve followed the instructions from this earlier thread:


Under APNs I have the following listed:

EE Internet
everywhere

EE MMS
eezone

My mobile provider is the Phone Co-Op.

I am assuming you have your FP2 contract with the Phone Co-Op in the UK ? I am with them as well and initially they had me on their standard FP2 contract that uses EE as carrier. My experience with EE is that they have really bad coverage in non-urban areas. I am now still with the Phone Co-Op, but switched to their (more expensive) Vodafone based contract and I do not have any problems so far.

Your problems with WiFi on trains is common. The train itself connects to the internet via a normal mobile data connection. When the train passes an area with no or bad mobile network coverage, you still have your WiFi connection, but no internet. Even with internet connection WiFi on trains can be tricky because the fast moving train has to switch to another mobile tower quite often what can cause data disruptions.

Yes, I’m in the UK.

This may or may not be relevant…
In September I went on holiday to Montenegro, flying to Dubrovnik in neighbouring Croatia. I had checked with the Phone Co-op beforehand that I would have mobile phone coverage, but on crossing the border into Montenegro I found myself unable to make calls or texts. I had to make do to with WhatsApp, email or Facebook Messenger to contact people (wi-fi permitting, but fortunately this was available everywhere I stayed).

I mention all this because I went to a mobile phone shop (Telenor) in Montenegro and bought a new SIM card under the (mis-)apprehension that this would enable data roaming. So there is a second SIM card in my Fairphone but it’s currently disabled. I wonder if the sales assistant did something to disable the 3G data coverage. Unfortunately I’m not 100% sure that I had 3G right up to my holiday.

Hi,

dual sim devices (as Fairphones) can use only one simcard with 3G (FP1) / LT, 4G(FP2).

So you have to make sure that the simcard which is used for your data connection is activated for 3G/4G.

EDIT: more info on this topic see here:

1 Like

Remind me, where do I find “cellular network settings”?

go to 'Settings’
tap on "more"
tap on "Mobile networks"
and you are at ‘Cellular network settings’.

1 Like

I used to have two SIM cards in my FP2. 4G was enabled on SIM2. When I disabled SIM2, SIM1 still stayed on 2G only.
I had to enable the (already invalid) SIM2 again, just to set that to 2G mode, so I was able to put SIM1 into 4G mode, and finally disable SIM2 again.

1 Like

For “Phone Co-op” “Preferred network type” is greyed out (this is with “Data roaming” ticked).

For “Card 2” data roaming is unticked and preferred network type is “4G(preferred)/3G/2G”

So, right now “Phone Co-op” is restricted to 2G only.
Set Card 2 to “2G”, then you should be able to choose something better for “Phone Co-op”.

1 Like

OK, I’ve done that (with Phone Co-op now set to 4G(preferred) etc). Still unable to connect to internet with wi-fi switched off. I’ll try rebooting.

Have a read here. It’s a page from Phone Co-op how to set up your internet on your Fairphone 2.

1 Like

May also be a problem at Phone Co-op. I have had to call Telfort a few times in the past 3 years on my current contract, because their mobile broadband had stopped working for no apparent reason, and after “fixing something” at their end, internet was back. That happened on my previous phone, but with a Fairphone these provider-side issues could occur just as well.

This link refers specifically to Orange Internet, not the EE Internet I have under APNs. Should I overwrite EE Internet?

Yes, because the information in the link is information giving by the Phone Co-op itself.

1 Like

Likewise
EE MMS
eezone
?

Take a look here.
The settings for MMS by Phone Co-op for the Fairphone 2.

At this support page from Phone Co-op you can find more information.

I have replaced EE with Orange and rebooted, but I still can’t get the internet when wifi is disabled. What am I doing wrong? And is what happened in Montenegro (mentioned earlier) relevant?

It’s still quite unclear what you are doing. Are you able to make phonecalls and receive texts? If yes, did you enable data when disconnecting from wifi and did you receive new APN settings when changing sim cards?

I have always been able to make phonecalls and receive texts (apart from when I was in Montenegro).

What do I need to do to enable data when disconnecting from wifi?

I haven’t changed the sim card. There is a Montenegrin sim card in my phone but I don’t use it.

OK, so lets sum this up:

  1. Do you have mobile data enabled?
    -> Settings -> Data usage -> go the tab for the relevant SIM card -> put “Mobile data” slider to “enabled” position
    -> in the same menu, is “Set mobile data limit” checked?
  2. Which is the preferred SIM card for cellular data usage?
    -> Settings -> SIM cards -> scroll down to “Preferred SIM card for” -> “Mobile data”
  3. I think you have already check the settings in “Cellular network settings” are right, by anyway:
    -> Settings -> More -> Mobile networks -> go to the tab for the relevant SIM card
    Check that “Preferred network type” is set to 3G or 4G
    You probably don’t need data roaming when you’re staying in the country the SIM card is bought in
    Settings in “Access point names” should be configured according to your network providers specifications, like discussed in the posts above already.
1 Like