Can't get apps reinstalled after factory reset

OK, Where to start… So I got my FP, its a 2nd Batch model… Charged it right up and wacked in my GiffGaff sim, then followed the on screen instructions. So far, so good.
Then came the rumblings of trouble. My google services had “unfortunately” stopped working… what the hell thinks I, I’m not sure what services it carries out… although maps seemed no longer to know where I am. So I went into the app section and deleted google services and then went to reinstall it. It wouldn’t let me so I hit the factory reset and then tried again. The google play store is quite sure that I have it installed already and so it wont let me. This is the same for all of google’s apps, all say that I have already got the apps and so the option to put them on again isn’t there. Any thoughts? I also am having trouble getting my GiffGaff internet to work.
HELP! Does anyone else have the sim and device working properly?

Here the instructions from Fairphone. How to perform a Hard Reset on my Fairphone

I’ll give it a whirl… bearing in mind that there is no google play store app or launch widget on the phpne at the moment…

Hi Tom,
you should find the Google Apps Installer in the “All Apps and Widgets Drawer”, see this tutorial:

Or is it gone missing there as well?

Hey fury,

Its not in there either… I’m trying a roundabout route of factory reset, new gmail account and so hopefully disown my previous being and see if that sorts it out

Fingers crossed all!

Right, no joy. I think that I may have deleted google play app and it seems that I can’t download it or get it again which has meant that my phone will not speak to the google mothership and is therefore A bit buggered… all things require the play app to sync and such like… google say that you can’t download it… it’s defo not in the apps nor widgets… hidden or otherwise

Strange, that not even a Factor Reset brings the widget back. You could try a downgrade of FairphoneOS using the Fairphone updater.
Or you could try installing the GAPPS using this link:

@Tom_Nicholls Did you ‘wipe cache partition’ after your factory reset?
If so, swipe from right to left on your screen, tap in the icon with the six dots, tab on ‘widgets’ on top of the screen and go to the widget ‘Google Apps Installer’, just gently touch the widget and drag it to one of your homescreens. Now try the’Google Apps Installer’.

I’ve solved it guys! I think the following occurred… FP being “open” allowed me to delete google services and play store, the lynch pin between google and it knowing what i’ve got installed. You are then not allowed to download google play… it was either inside android or fairphone’s OS. I tried going to the software download section on FP website with my PC and downloaded android passing it into the SD card on the phone and restarted through a hard restart… no google apps… but working through the process again with the Fairphone OS… success!!! the buggers are returned and all is well… the answer is in the OS as that is where play services live! long live the Services!


Glad you have solved this

This topic is now closed. New replies are no longer allowed.